Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Search Engine Stuck on Amazon After Updating to Firefox 99.0.1 on Monterey 12.3.1

  • 25 trả lời
  • 2 gặp vấn đề này
  • 124 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

A short while ago, Firefox was automatically updated to 99.0.1 on my iMac running Monterey 12.3.1. Suddenly, for no apparent reason, the search engine is stuck on Amazon with no other search engine options available. I normally use Google.

Even if I go into the Firefox settings to the "Search" panel, it is showing ONLY Amazon as the available option in the pull-down menu under "Default Search Engine". In the "Search Bar" section, I have it set to "Add search bar in tool bar". But even if I set it to "Use the address bar for search and navigation", and then switch it back to "Add search bar in tool bar", Amazon still remains the only available search engine.

As a last step, I installed the "Google Search" add-on by 3Indian to see if I could get back my Google search engine, but Google still doesn't show up as an option anywhere, and I am still stuck with just Amazon.

Is this a bug in the latest Firefox build? Did the developers forget to enable something when they did this build perhaps?

A short while ago, Firefox was automatically updated to 99.0.1 on my iMac running Monterey 12.3.1. Suddenly, for no apparent reason, the search engine is stuck on Amazon with no other search engine options available. I normally use Google. Even if I go into the Firefox settings to the "Search" panel, it is showing ONLY Amazon as the available option in the pull-down menu under "Default Search Engine". In the "Search Bar" section, I have it set to "Add search bar in tool bar". But even if I set it to "Use the address bar for search and navigation", and then switch it back to "Add search bar in tool bar", Amazon still remains the only available search engine. As a last step, I installed the "Google Search" add-on by 3Indian to see if I could get back my Google search engine, but Google still doesn't show up as an option anywhere, and I am still stuck with just Amazon. Is this a bug in the latest Firefox build? Did the developers forget to enable something when they did this build perhaps?

Giải pháp được chọn

Well, I finally got tired of all the unexplainable nonsense, so I bit the bullet and performed a clean install of Firefox 99.0.1. Before doing that, I imported my backup "bookmarks.html" file into Safari in order to determine if it would recognize all the links in my Firefox Bookmarks Toolbar. As you may recall, for some reason, Firefox was NOT importing the Bookmarks Toolbar links. Well, Safari did recognize them. So, after reinstalling Firefox 99.0.1, I imported my bookmarks from Safari, and it worked fine. The Bookmarks Toolbar links are now recognized in Firefox. Last of all, I visited all of the major websites that I normally visit, and I saved logins and passwords in Firefox. Also, once again, I can now use the search engine of my choice. Thank God that nightmare is over ... even if I don't know what caused it. You can be sure that I am going to backup the entire "Firefox" folder in the "Application Support" folder ... just in case! :)

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (20)

more options

Something like that could be caused by an add-on or ad-ware.

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

more options

To reset the search engines, remove these files in the Firefox profile folder; search.json + search-metadata.json + search.sqlite + search.json.mozlz4

search.json.mozlz4 ==only== (v45+)

New files are created when needed.


Type about:support in the address box and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current profile.

Windows: Show/Open Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

more options

Hello Fred. Thank you for offering to help. For the record, I did not install any new add-ons before this problem occurred. All I know for certain is that the problem began right after I updated to 99.0.1 a few hours ago.

At any rate, I tried both of your suggested methods. That is, starting in safe mode -- a.k.a. troubleshoot mode -- and deleting the "search.json.mozlz4" file from my profile folder. That was the only file in there with the "search" prefix in the file name.

But despite doing both of those, the problem has not been resolved. Only Amazon continues to show under the search field in the top right corner of Firefox, and Amazon is also the only available option in the pull-down menu that is located under the "Default Search Engine" section in my Firefox settings.

So, where do we go from here? The only thing I can think of is to install the previous version of Firefox and see if the problem disappears. If it does disappear, then that would definitely seem to prove that there is a macOS-related bug in 99.0.1, I would think.

more options

Hello again Fred. Well, I did as I said I would do and it did NOT help. In other words, I shut down Firefox, opened the 99.0 DMG file, and dragged the app into the "Applications" folder, replacing 99.0.1. Upon relaunching Firefox, the very same problem still persists. :(

At this point, I am at a loss regarding what to do.

more options

Oh, one thing I forgot to mention is that further down on the Search preferences window in Firefox, there is a "Restore Default Search Engines" button, but it is grayed out. So it is useless.

more options
more options

Hello again Fred. Well, I created a brand new profile, and it is currently the active profile. However, there is still no change. Even after restarting Firefox, and using the new profile, Amazon is still the only search engine that is showing in my search field, as well as under the "Default Search Engine" section in the settings.

more options

I called for more help.


You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed free to use malware scanners. Each works differently. If one program misses something, another may pick it up.

more options

Could you check the Policies page: type or paste about:policies in the address bar and press Return to load that page. The "Active" list usually says "The Enterprise Policies service is inactive." Does your Active list say that or does it mention any search-related policies?

more options

Hello jscher. It currently says "The Enterprise Policies service is inactive."

To be honest, I am NOT convinced that this has anything to do with malware/adware of any kind. I am always very careful where I go, and what I do, in Firefox. This is something directly related to updating from 99.0 to 99.0.1. I just don't know what the problem is.

more options

Also, I did as Fred suggested and created a new profile, but that did not help. For one thing, as you know, creating a new profile causes me to lose all of my bookmarks, stored passwords, etc. Then, when I try to important my bookmarks from a bookmarks.html file, it is NOT importing my Bookmarks Toolbar. It only imports the Bookmarks Menu.

more options

Thank you for checking on Policies.

Hopefully you did not delete your old profile and you can switch back to it now via the about:profiles page.

Are you using the U.S. English version of Firefox? The "locale" should be indicated toward the bottom of the about:support page, in the Internationalization & Localization section. (Actually, I don't know whether there are any locales that would only have Amazon; seems very unlikely.)

Because the built-in search engines are packaged as hidden extensions, normally it's not possible to disable them from within Firefox. Do you use any external software that attempts to disable or remove extensions in Firefox?

more options

Here is what it says. I live on the US territory of Guam in the Western Pacific. So GU is Guam.

To answer your question. No I do not use any such software.

I am using my old profile again, so I still have all of my bookmarks and passwords. BUT, once again, I am stuck with only Amazon.

Internationalization & Localization Application Settings Requested Locales ["en-US"] Available Locales ["en-US"] App Locales ["en-US"] Regional Preferences ["en-GU"] Default Locale "en-US" Operating System System Locales ["en-GU"] Regional Preferences ["en-GU"]

more options

If it is of any help to you:

Add-ons Search Detection extension 2.0.0 true addons-search-detection@mozilla.com Advanced Threat Toolbox extension 4.1 true @amp-toolbox Amazon.com extension 1.3 true amazondotcom@search.mozilla.org Bing extension 1.3 true bing@search.mozilla.org DuckDuckGo extension 1.1 true ddg@search.mozilla.org eBay extension 1.3 true ebay@search.mozilla.org Enhancer for YouTube™ extension 2.0.113 true enhancerforyoutube@maximerf.addons.mozilla.org Facebook™ Seen Blocker extension 0.1.5 true jid0-AcfdPqSA2Ugt2vdJh6Kj7IiOp5W@jetpack Feedbro extension 4.12.4 true {a9c2ad37-e940-4892-8dce-cd73c6cbbc0c} Flagfox extension 6.1.49 true {1018e4d6-728f-4b20-ad56-37578a4de76b} Google extension 1.2 true google@search.mozilla.org Google Translator for Firefox extension 3.0.3.3 true translator@zoli.bod Search by Image extension 4.6.0 true {2e5ff8c8-32fe-46d0-9fc8-6b8986621f3c} TubeBuddy extension 1.45.1171 true e389d8c2-5554-4ba2-a36e-ac7a57093130@gmail.com uBlock Origin extension 1.42.4 true uBlock0@raymondhill.net Video DownloadHelper extension 7.6.0 true {b9db16a4-6edc-47ec-a1f4-b86292ed211d} Wikipedia (en) extension 1.1 true wikipedia@search.mozilla.org Adblock Plus - free ad blocker extension 3.11.4 false {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Google Search extension 0.2.0.3 false {0f46b35c-9cf5-4564-90a4-4078dc199dc4}

more options

Thank you for the extensions list. They are listed as enabled, as expected:

Amazon.com extension 1.3 true amazondotcom@search.mozilla.org Bing extension 1.3 true bing@search.mozilla.org DuckDuckGo extension 1.1 true ddg@search.mozilla.org eBay extension 1.3 true ebay@search.mozilla.org Google extension 1.2 true google@search.mozilla.org Wikipedia (en) extension 1.1 true wikipedia@search.mozilla.org

It is difficult to understand why Firefox isn't showing them in the Search Shortcuts box. Something is going wrong in building that list, but I don't know what it is.

How long has this been going on?

more options

Sorry … I was taking a nap.

more options

I can't explain it. Maybe it's something locale-related? Could you check this preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.search.region and pause while the list is filtered

What is this preference set to? I would assume US but...

more options

You did make sure that Firefox was fully closed (Firefox -> Quit Firefox) when you removed the search.json.mozlz4 file ?

Maybe related to some (security) software that provides the Advanced Threat Toolbox extension.

more options

jscher2000, I apologize again for the delay in responding. I've been rather busy here. Anyway, I did as you said, and browser.search.region is set to GU, which is Guam. As I said before, Guam is a U.S. territory. At any rate I changed it to US and then restarted Firefox. It made no difference. I am still seeing just Amazon in the search field at the top right area of the browser window, and Amazon continues to be the only option under "Default Search Engine" in Firefox's settings.

more options

Cor-el, to be honest, I am not absolutely certain that I did, but I assume that I did. In fact, over the course of the past few hours, I have done it several times in order to try to force Firefox to correct itself. However, such has not been the case.

As I have said a few times now, this problem started right after I upgraded from 99.0 to 99.0.1. Of that I am certain. Prior to that, I had not added any new add-ons/extensions, and even when I launch Firefox in "troubleshoot mode" where all extensions are disabled, I still just see Amazon. So, I can only conclude that this is not an extension/add-ons related issue. It is something else. I just have no idea what it is, and I don't have the expertise to figure it out.

I could just delete Firefox entirely, including all of its support folders and files, but as you can understand, that comes with a huge price: I lose all of my saved passwords and many hundreds of bookmarks.

The problem I am now having with my bookmarks is also weird. While they all currently show in Firefox, if I export them, then create a new profile, and then try to import my bookmarks to the new profile from the exported "bookmarks.html" file, for some reason, it is NOT importing anything from the "Bookmarks Toolbar" folder. The folder remains blank after the import, while the "Bookmark Menu" folder is full after the import.

So does that mean that the bookmarks in the "Bookmark Toolbar" folder are not even being properly exported? Well, I got curious, and so I opened the "bookmarks.html" file in BBEdit. And guess what? All of my links under the "Bookmarks Toolbar" are in fact listed in the file; yet for some reason, they are NOT being imported.

I wouldn't mind starting from total scratch, even if it means slowly re-entering all of my hundreds of unique passwords. However, losing hundreds of my bookmarks due to failure to import them? No thanks!

  1. 1
  2. 2