Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How do I make Firefox ignore the use-application-dns.net and always use my DNS server?

  • Không có trả lời
  • 1 gặp vấn đề này
  • 8 lượt xem
more options

Hello!

I've set up an AdGuard Home server in my network. It provides the DNS-over-HTTPS service, I added it to my Firefox Network Settings configuration as https://adguard.example.com/dns-query and my machine has adguard.example.com in its /etc/hosts file.

The upstream AdGuard DNS server is my home router, which has several static DNS entries added for hosts in my network, e.g. foo.example.com pointing to 10.0.0.100.

During regular use, the domains resolve properly - when I navigate to http://foo.example.com everything works OK.

However when my machine is connected to VPN, the browser is unable to connect to http://foo.example.com, but it is still able to reach: http://10.0.0.100, regular internet as well as https://adguard.exaple.com (which is obtained from /etc/hosts).

This is on MacOS, using openconnect as a VPN client (and of course, the VPN connection changes the host DNS servers, this is what I'm trying to circumvent with Firefox' DoH feature).

I noticed one thing: with VPN, the use-application-dns.net resolves to something, without VPN it does not. I found this article, which mentions: "When any of these checks indicates a potential issue, Firefox will disable DoH for the remainder of the network session, unless the user has enabled the “DoH always” preference as mentioned above."

I have DoH explicitly enabled, the network.trr.mode is set to 2 (tried 3 as well, did not help). There's no such option as "DoH always" in the settings!

How do I make Firefox ignore the use-application-dns.net and always use my DNS server?

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.