Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Can't open links from other apps, error "Firefox is already running"

  • 4 trả lời
  • 1 gặp vấn đề này
  • 12 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

This question was asked 6 months ago and I have the same problem.

Running Ubuntu Mate 21.04 (metacity), FF 91.0.2 (64-bit). I have it set up with two different profiles, with separate menu entries for each using "firefox -P [PROFILE NAME] -no-remote %u". One of them is set to always use private browsing mode and I use that profile as my default app in mate.

If if set chrome as my default browser, I can open links from other apps without a problem regardless of chrome being already running or not.

When I set FF as default, whenever it is already open and I try to open a link, I get a "Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile." error.

I've seen some comments about similar issues with wayland and tried setting MOZ_DBUS_REMOTE and even MOZ_ENABLE_WAYLAND to 1.

Can you help me?

Giải pháp được chọn

I am not sure what it does, but try removing -no-remote from the shortcut you use.


Are you currently using a version from the repositories of your Linux distribution? Try the Firefox version from the official Mozilla server: https://www.mozilla.org/en-US/firefox/all/

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (4)

more options

Try downloading a separate copy of Firefox and run it from the folder(do not sign into you Firefox account) to see what happens.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Hữu ích?

more options

Giải pháp được chọn

I am not sure what it does, but try removing -no-remote from the shortcut you use.


Are you currently using a version from the repositories of your Linux distribution? Try the Firefox version from the official Mozilla server: https://www.mozilla.org/en-US/firefox/all/

Hữu ích?

more options

FredMcD said

I am not sure what it does, but try removing -no-remote from the shortcut you use.

It was supposed to enable running multiple instances of the application with different profiles (http://kb.mozillazine.org/Command_line_arguments). Removing it fixed the issue. Thanks

Hữu ích?

more options

Glad to help. Safe Surfing.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.