Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

autofill saved logins and passwords and don't ask to save logins and passwords for websites

  • 5 trả lời
  • 1 gặp vấn đề này
  • 22 lượt xem
  • Trả lời mới nhất được viết bởi elmbeech

more options

Dear Community,

I have a hand full of passwords I would like Firefox to fill out but stop asking me if I like to save logins and passwords every time I have to login on a websites.

Unfortunately, when I uncheck "Ask to save logins and passwords for websites", Firefox will stop "Autofill logins and passwords", even the saved ones.

Does anyone know a workaround?

Hopefully, Elmar

Giải pháp được chọn

If you disable "Ask to save logins and passwords for websites" then you set signon.rememberSignons to false and this means that you disable the Password Manager and you can't autofill passwords. You can access the logins via Lockwise (about:logins) and you may have Fill Login and Fill Password in the right-click context menu if you have entered the Primary Password (i.e. you are logged in to the software security device (password manager.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (5)

more options

Looks like no one know a solution. Could this be solved by writing a plugin?

Hữu ích?

more options

You can create login block exceptions if this is about websites you visit regularly.

Hữu ích?

more options

Unfortunately, one can not use regular expression for login exception. This not really solves the problem. Is there not a way to enable auto fill and disable ask to save logins and passwords.

Actually where is the firefox source code maintained? Is it somehow possible to write a patch or ask for this feature in a bug tracker?

Elmar

Hữu ích?

more options

Giải pháp được chọn

If you disable "Ask to save logins and passwords for websites" then you set signon.rememberSignons to false and this means that you disable the Password Manager and you can't autofill passwords. You can access the logins via Lockwise (about:logins) and you may have Fill Login and Fill Password in the right-click context menu if you have entered the Primary Password (i.e. you are logged in to the software security device (password manager.

Hữu ích?

more options

Dear cor-el,

This is cool! This solves the problem right click is convenient enough! Thank you for your input!

In the meanwhile I found the source code: https://hg.mozilla.org/ I think this is the latest branch at the moment: https://hg.mozilla.org/mozilla-central/file/17f61493037d1a0acacadf7a4350238d0320190f

My thought was too, that I just somewhere slightly have to change the nesting, so that the autofill subroutine still gets executed, even when signon.rememberSignons is False. But since I am not too familiar with the code base, I could not figure out where. Are you familiar with the code base? Am I searching at the right place?

Elmar

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.