Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Default Search Engine Problem

  • 6 trả lời
  • 2 gặp vấn đề này
  • 80 lượt xem
  • Trả lời mới nhất được viết bởi David Rustin Lea

more options

I have Bing set up as my default search engine and it has worked fine for years. Now all of the sudden, any search I request, whether in the address bar or search window is completed by Yahoo. I have tried everything I know to try to fix this but to no avail. Also, when I click the Add-ons button to check for add -ons that I perhaps placed in error, a new blank tab opens up. I'm wondering if I should just delete Firefox and then re-install it. Any help would be greatly appreciated.

Giải pháp được chọn

Hi pfburdett, in recent months, a number of users have reported being infected by an extension that somehow blocks access to the content of the Add-ons page. As a workaround, restart Firefox in its Safe Mode first. In its Safe Mode, Firefox temporarily deactivates extensions.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Then you should not be blocked from using the Add-ons page and you can proceed with cleaning up there.

By the way, if you identify a bad extension, please name names. You also can share its unique ID that is on the Troubleshooting Information page, Add-ons table since Mozilla would need that to issue a block.

Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (6)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Yahoo “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Hữu ích?

more options

Giải pháp được chọn

Hi pfburdett, in recent months, a number of users have reported being infected by an extension that somehow blocks access to the content of the Add-ons page. As a workaround, restart Firefox in its Safe Mode first. In its Safe Mode, Firefox temporarily deactivates extensions.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Then you should not be blocked from using the Add-ons page and you can proceed with cleaning up there.

By the way, if you identify a bad extension, please name names. You also can share its unique ID that is on the Troubleshooting Information page, Add-ons table since Mozilla would need that to issue a block.

Hữu ích?

more options

Thank you both for your rapid responses. The solution that worked was the action suggested by jscher2000. I tried FredMcD's solution first, but the first step "about:addons" enter just took me to a new tab.

I did report the offending extension.

I can't thank you enough for your help. Have a great day!!

Hữu ích?

more options

pfburdett said

I did report the offending extension.

What is it?

Hữu ích?

more options

I don't remember Fred. I reported it in the popup box that came up when I selected it for deletion. Sorry.

Hữu ích?

more options

I think I have solved the problem described here. The offending extension seems to have been "blog link" which I do not ever remember adding. I removed several other extensions that didn't seem familiar, but they did not stop yahoo search from popping up in place of google results. The google results are much better organized and relevant, which is why google has been preferred all over the world for all these years!!

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.