X
Nhấn vào đây để đến phiên bản di động của trang web.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Diễn đàn trợ giúp

How do I disable Warning: Potential Security Risk Ahead for sites with invalid certificates?

Được đăng

How do I disable the warning screens that say "Warning: Potential Security Risk Ahead" when I visit sites on my home network (192.168.1.0/24)? Nothing I've tried seems to work. Thanks, Eric

How do I disable the warning screens that say "Warning: Potential Security Risk Ahead" when I visit sites on my home network (192.168.1.0/24)? Nothing I've tried seems to work. Thanks, Eric
Trích dẫn

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:73.0) Gecko/20100101 Firefox/73.0

Thông tin chi tiết

Wesley Branton
  • Top 25 Contributor
714 giải pháp 5628 câu trả lời
Được đăng

Câu trả lời hữu ích

I DO NOT RECOMMEND DOING THIS, but you should be able to disable that error message by changing the browser.xul.error_pages.enabled preference value to false from the about:config page. However, this will disable error pages for ALL WEBSITES.

Instead, the much better option is to press the Advanced button on the error screen and add a security exception, although I'm not sure if you can create a permanent exception for an IP address.

Another option could be to connect to the IP address using HTTP instead of HTTPS, since the certificate for HTTPS on that device obviously isn't setup properly anyway.

Hope this helps.

I '''<u>DO NOT RECOMMEND DOING THIS</u>''', but you should be able to disable that error message by changing the <code>browser.xul.error_pages.enabled</code> preference value to <code>false</code> from the <code>about:config</code> page. However, this will disable error pages for <u>ALL WEBSITES</u>. Instead, the much better option is to press the '''Advanced''' button on the error screen and add a security exception, although I'm not sure if you can create a permanent exception for an IP address. Another option could be to connect to the IP address using HTTP instead of HTTPS, since the certificate for HTTPS on that device obviously isn't setup properly anyway. Hope this helps.
Bài viết này có hữu ích với bạn không? 1
Trích dẫn
jscher2000
  • Top 10 Contributor
8950 giải pháp 73360 câu trả lời
Được đăng

eric64 said

How do I disable the warning screens that say "Warning: Potential Security Risk Ahead" when I visit sites on my home network (192.168.1.0/24)?

Hi Eric, does the error page have a more detailed explanation for why there is a problem connecting securely? Sometimes you need to click an "Advanced" button for that information.

''eric64 [[#question-1280566|said]]'' <blockquote> How do I disable the warning screens that say "Warning: Potential Security Risk Ahead" when I visit sites on my home network (192.168.1.0/24)? </blockquote> Hi Eric, does the error page have a more detailed explanation for why there is a problem connecting securely? Sometimes you need to click an "Advanced" button for that information.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

It says... Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for 192.168.1.10.

Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT

I recognize that this is a legitimate warning. I don't have valid certificates. But, the extra clicks are useless and annoying on my LAN. So, I'd rather disable the check.

Thanks Eric

It says... Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for 192.168.1.10. Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT I recognize that this is a legitimate warning. I don't have valid certificates. But, the extra clicks are useless and annoying on my LAN. So, I'd rather disable the check. Thanks Eric
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8950 giải pháp 73360 câu trả lời
Được đăng

Does the Exception persist? (Screenshot attached for context.)

I don't think there is a way NOT to verify website certificates at all.

Does the Exception persist? (Screenshot attached for context.) I don't think there is a way NOT to verify website certificates at all.
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8950 giải pháp 73360 câu trả lời
Được đăng

Câu trả lời hữu ích

By the way, if your exceptions do not persist, you might check the following preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste certerr and pause while the list is filtered

(3) If the security.certerrors.permanentOverride preference is bolded and has a value of false, double-click it to restore the default value of true

By the way, if your exceptions do not persist, you might check the following preference: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''certerr''' and pause while the list is filtered (3) If the '''security.certerrors.permanentOverride''' preference is bolded and has a value of false, double-click it to restore the default value of true
Bài viết này có hữu ích với bạn không? 1
Trích dẫn

Người tạo câu hỏi

I'm afraid the exceptions don't persist, even though security.certerrors.permanentOverride is set to true. Not sure why. It would be nice if that worked.

Might it be possible to have an option on Firefox to disable this for a range of IP addresses? It would be a nice feature.

I'm afraid the exceptions don't persist, even though security.certerrors.permanentOverride is set to true. Not sure why. It would be nice if that worked. Might it be possible to have an option on Firefox to disable this for a range of IP addresses? It would be a nice feature.
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17850 giải pháp 161559 câu trả lời
Được đăng

Maybe use a http:// link since these pages are on your home network and not on internet. Then you do not have to deal with certificate issues.

Maybe use a http:// link since these pages are on your home network and not on internet. Then you do not have to deal with certificate issues.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.