X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

WebAssembly support is not detected in this browser

Được đăng

This only pertains to one site in particular. This message pops up when I try to visit it. WebAssembly support is not detected in this browser. Could you please give me some suggestions or anything that might help me. I downloaded google chrome thinking it might take care of the issue, but I'm getting the same error in that as well. Thank you in advance for any help you can offer me.

This only pertains to one site in particular. This message pops up when I try to visit it. WebAssembly support is not detected in this browser. Could you please give me some suggestions or anything that might help me. I downloaded google chrome thinking it might take care of the issue, but I'm getting the same error in that as well. Thank you in advance for any help you can offer me.
Trích dẫn

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Google Update
  • Shockwave Flash 32.0 r0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8635 giải pháp 70627 câu trả lời
Được đăng

Hi powell236, your Firefox identified itself as the Extended Support Release of Firefox 52 (on Windows Vista). Is that correct?

According to a site that publishes browser compatibility tables, WebAssembly (often abbreviated wasm) was disabled in that version of Firefox: https://caniuse.com/#feat=wasm

There are some preferences in about:config to enable wasm but perhaps wasm doesn't work well in Firefox 52 and that's why it's disabled?? If you want to give it a try anyway:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste wasm and pause while the list is filtered

(3) Double-click the javascript.options.wasm preference to switch the value from false to true

(4) Double-click the javascript.options.wasm_baselinejit preference to switch the value from false to true

Probably this will take effect the next time you exit and restart Firefox.

Hi powell236, your Firefox identified itself as the Extended Support Release of Firefox 52 (on Windows Vista). Is that correct? According to a site that publishes browser compatibility tables, WebAssembly (often abbreviated wasm) was disabled in that version of Firefox: https://caniuse.com/#feat=wasm There are some preferences in about:config to enable wasm but perhaps wasm doesn't work well in Firefox 52 and that's why it's disabled?? If you want to give it a try anyway: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''wasm''' and pause while the list is filtered (3) Double-click the '''javascript.options.wasm''' preference to switch the value from false to true (4) Double-click the '''javascript.options.wasm_baselinejit''' preference to switch the value from false to true Probably this will take effect the next time you exit and restart Firefox.
Bài viết này có hữu ích với bạn không?
Trích dẫn
cor-el
  • Top 10 Contributor
  • Moderator
17415 giải pháp 157316 câu trả lời
Được đăng

See comment 22:

See comment 22: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1342060#c22 Bug 1342060#c22] - wasm: enable by default *[https://bugzilla.mozilla.org/show_bug.cgi?id=1342440 Bug 1342440] - wasm: keep wasm disabled in esr52
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Hi Jscher2000. I tried what you suggested. Didn't solve the issue. Got another error message that reads: "The browser could not allocate enough memory for the WebGL content. If you are the developer of this content, try allocating less memory to your WebGL build in the WebGL player settings." So I went back in to enable webgl force and got this error: "An error occured running the Unity content on this page. See your browser JavaScript console for more info. The error was: Script error." I have to be honest, I am beginning to confuse myself now. Thank you for your help, but I am still having the issue.

Hi Jscher2000. I tried what you suggested. Didn't solve the issue. Got another error message that reads: "The browser could not allocate enough memory for the WebGL content. If you are the developer of this content, try allocating less memory to your WebGL build in the WebGL player settings." So I went back in to enable webgl force and got this error: "An error occured running the Unity content on this page. See your browser JavaScript console for more info. The error was: Script error." I have to be honest, I am beginning to confuse myself now. Thank you for your help, but I am still having the issue.
Bài viết này có hữu ích với bạn không?
Trích dẫn
jscher2000
  • Top 10 Contributor
8635 giải pháp 70627 câu trả lời
Được đăng

I'm beginning to think you might not be able to run whatever the page's content is on your computer, it might require more resources or different graphics hardware. Running a game engine like Unity in a web page is very demanding.

I'm beginning to think you might not be able to run whatever the page's content is on your computer, it might require more resources or different graphics hardware. Running a game engine like Unity in a web page is very demanding.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

Hi jscher.. I think you may be right. The only thing that puzzles me is why I haven't had any issues with it up until now. I have been playing this game off and on for at least a year or more. Maybe it just finally took a toll, who knows. Anyway, I truly appreciate your advice and your time. Thank you.

Hi jscher.. I think you may be right. The only thing that puzzles me is why I haven't had any issues with it up until now. I have been playing this game off and on for at least a year or more. Maybe it just finally took a toll, who knows. Anyway, I truly appreciate your advice and your time. Thank you.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Jeremy Sanders
  • Top 25 Contributor
12 giải pháp 142 câu trả lời
Được đăng

Archived

Archived
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.