Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

downloads folder opens in non default file manager

  • 6 trả lời
  • 2 gặp vấn đề này
  • 32 lượt xem
  • Trả lời mới nhất được viết bởi NginUS

more options

When I click 'Open containing folder' in Downloads it opens in Nemo despite my system default File Manager being Dolphin. This is new behavior since a recent update.

On Linux Mint 18.3 & Firefox 67.0.4

Please help. Thanks.

Tất cả các câu trả lời (6)

more options

Try to use gvfs-mime.

gvfs-mime --query inode/directory
gvfs-mime --set inode/directory nemo.desktop
more options

cor-el said

Try to use gvfs-mime. gvfs-mime --query inode/directory gvfs-mime --set inode/directory nemo.desktop

Its output suggests it ought to behave as it used to, not like it is now.

 $ gvfs-mime --query inode/directory
 Default application for 'inode/directory': org.kde.dolphin.desktop
 Registered applications:
       org.kde.dolphin.desktop
       nemo.desktop
       org.kde.filelight.desktop
more options

gvfs-mime has been deprecated and it is redirected to gio mime.

that is why it breaks in KDE quite badly.

omg darn it. this Gnome gvfs is bad breakware. now I my downloads folder opens in nothing at all.

I never liked Gnome stuff at all in any way shape or form. their docs are abysmal.

https://groups.google.com/forum/#!topic/uk.comp.os.linux/dUclklAmslo

a lot of people run into this nightmare


sudo -H gio mime      inode/directory  org.kde.dolphin.desktop

Set org.kde.dolphin.desktop as the default for inode/directory

yet "open containing folder" is 100% dead . darnit.

I tried all sorts of stuff to short of looking into the ffox sources to figure out why "open containing folder" does nothing, while e.g. about:support "open folder" works OK and can be switched in KDE from say Caja to Nautilus to Dolphin and back as expected.

so generally, file associations seem healthy essentially. must be sth. special in that particular code for "open containing folder" = broken that is different from "show download folder" = working .


just the darn downld menu entry is dead. I cannot find any fault anywhere , tried gio, mimeo and all that stuff works as expected. ungoogled chrome opens downld folder as usual. really can't figure it out. refreshed, pristine profile, no addons, I tried it all, looked thru about:about from top to bottom, cleared all sorts of caches and what not. dammit. as if to mock me, "show downld folder" actually opens dolphin as always. This gives me the creeps.

must be kinda system related tho, since a pristine separate user (/home/u1 instead of /home/u2) in KDE has same symptoms. must be sth. I installed under /usr/share ... blimey Konsole error output does not say much interesting things either.

I uninstalled gvfs but that damonic gnome troll still haunts my firefox and waterfox too. I guess I'll have to set up snapper-GUI to get to the bottom of this. I recommend no one touch gvfs with a ten foot pole.

same phenomenon exhibited by KFind. that one is easier to debug.

this guy ran into the same mess: https://polywogsys.livejournal.com/309405.html

this guy nailed it ! thx!

like he sorta descibes, key is to

replace the Exec line with "Exec=/usr/bin/false" in any ****FileManager1.service file you find below /

gvfs is to blame for this mess! do not touch Gnome gvfs with a 10 foot pole!

Được chỉnh sửa bởi n5mx vào

more options

Được chỉnh sửa bởi n5mx vào

more options

I recommend to have no more than one dolphin 1.service files - keep it at

/usr/share/dbus-1/services/org.kde.dolphin.FileManager1.service

more options

Apparently this has resolved itself. No way to know if it was due to updates or a reboot or combination thereof. Either why I'm glad to have it working right again. Thanks everyone for your input.