Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

FF for OS X - Problem with accessing Preferences options

  • 10 trả lời
  • 1 gặp vấn đề này
  • 447 lượt xem
  • Trả lời mới nhất được viết bởi Sun-flower

more options

Since FF 34 I am suddenly unable to choose General from the Preferences Options. At first it was Advanced I was unable to get. It was just a blank page for that. Now I can get that OK but I can't get General. It remains on the previous option I had and won't switch to General. I have tried several restarts to no avail. I can get all the other options now except for General.

This may have begun in a previous version of FF. I don't know as I rarely go into Preferences. I have just found out about this problem straight after I installed FF34. I then installed FF 34.0.5 thinking that might have fixed the problem but it did not.

Does anybody know what has caused this problem or how it can be fixed?

Giải pháp được chọn

Here are two things to try;

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.


Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (10)

more options

Hello Sun-flower, try disabling graphics hardware acceleration.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps: Open Firefox Preferences window as follows:

  1. click the menu button New Fx Menu and select Preferences.
  2. In the Firefox Preferences window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

more options

Hi,

I tried ideato's suggestion to disable graphics hardware acceleration but this had no affect. However it showed that I was able to change my preferences OK.

I then tried cor-el's suggestion. I did not have a user.js or numbered prefs-##.js file so I renamed my pref.js file. This made my Firefox go back to the default preferences and I was then able to access the Preferences - General option again.

However I could not face the prospect of trying to manually put in all my preferences again as it seems to include my add on preferences as well so I have returned the pref.js file to what it was so that I am back to square one again.

I'm just going to have to live with being no longer able to access the Preferences - General options now. I don't need to any more as those are set the way that I want them. I am still able to access all the other options in Preferences and, it seems, I am still able to change them OK.

I'll just have to settle for the way things are now. Thank you for your help.

more options

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences

more options

Thank you FredMcD for this advice. I had FEBE and have now installed OPIE.

I have discovered that all my Preferences options are accessible when I change back to the Default Theme. I have the Noia Fox Theme but that wasn't the cause of the problem as I tested that out, alone, on a test profile and it was OK. So it must be one of my other add ons that is causing the problem.

But it is going to be too much trouble starting all over again even with FEBE and OPIE. I'll save that for if it ever gets critical. But for now, I'll just stick with my problem as I am able to switch my Theme back to Default if I ever need to get into Preferences - General.

Thank you very much for everybody's help which has made me all the wiser.

more options

Giải pháp được chọn

Here are two things to try;

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.


Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

Many thanks for not giving up on me, Fred, when I had given up myself. I did what you suggested about disabling all my add ons and re-enabling them one by one.

The culprit turned out to be Ghostery which I have had for years. I tried removing it entirely then installing a fresh copy from the Firefox website but the problem returned so I have had to stop using it and am now using Disconnect instead now.

I have sent an email to Ghostery about this problem so if it can be fixed I'll be able to use it again.

Many thanks again for helping me to totally sort my problem out. I am most grateful.

Cheers

more options

Glad to know, Happy Computing.

more options

Note that this is a known issue and has been reported before, see e.g.:

more options

Thank you for that information, cor-el. That is helpful to know. It looks like the problem has been around for a wee while now. Hopefully they'll be able to sort it out in the end.

I've just re-installed Ghostery. If I need to access the missing Preferences options, I'll just disable it in order to do that then re-enable it again afterwards.

Thank you everyone for all the help and advice you have given to me. It has helped me to find the cause of my problem and educated me more on Firefox workings which should assist me from now on.

Cheers all