X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

I'm no longer getting Allow and Remember prompt. I have to manually click the red icon in the upper left to access it. How do I restore the automatic prompt?

Được đăng

Yesterday I visited a site to which I often go, pingtest.net. Normally, when I visit that site, a thin horizontal bar appears at the top of the browser viewing frame. I do not recall what it says, but it stretches the entire length of frame, from left to right. On the right edge of the bar is an x, if I wish to close it. In addition, when this horizontal bar appears, I also get a box which is about six to seven times the height of the thin horizontal bar that appears over the left edge of the thin horizontal bar. This box stretches across the width of about a sixth or fifth of the width of the horizontal bar. It contains something like the following: Show All, Allow, Allow and Remember. I normally click the Show all option, and I normally select Allow Now for all options.

Here's what happened yesterday: I went to pingtest.net, the horizontal bar appeared, and everything seemed normal. However I took no action. Instead, I changed my mind and decided to go to a different URL. My cursor was in the middle of the screen. I moved the cursor up to what I intended to be the URL field, in order to enter a new URL. Unfortunately I didn't move the cursor sufficiently. So, instead of clicking in the URL field, I clicked right in the middle of the horizontal bar. I HAVE NO IDEA WHAT I CLICKED BUT FROM THAT MOMENT TO THIS THAT HORIZONTAL BAR HAS NEVER RE-APPEARED. WHATEVER I CLICKED, IT APPEARS I INSTRUCTED FIREFOX TO NEVER PROVIDE ME WITH THAT HORIZONTAL BAR AGAIN!!!

As a result, I am also no longer getting the grey box with the Show All, Allow, Allow and Remember options.

How can I restore normal behavior, and get the normal horizontal bar and the normal box with the Show All, Allow, Allow and Remember options?

Yesterday I visited a site to which I often go, pingtest.net. Normally, when I visit that site, a thin horizontal bar appears at the top of the browser viewing frame. I do not recall what it says, but it stretches the entire length of frame, from left to right. On the right edge of the bar is an x, if I wish to close it. In addition, when this horizontal bar appears, I also get a box which is about six to seven times the height of the thin horizontal bar that appears over the left edge of the thin horizontal bar. This box stretches across the width of about a sixth or fifth of the width of the horizontal bar. It contains something like the following: Show All, Allow, Allow and Remember. I normally click the Show all option, and I normally select Allow Now for all options. Here's what happened yesterday: I went to pingtest.net, the horizontal bar appeared, and everything seemed normal. However I took no action. Instead, I changed my mind and decided to go to a different URL. My cursor was in the middle of the screen. I moved the cursor up to what I intended to be the URL field, in order to enter a new URL. Unfortunately I didn't move the cursor sufficiently. So, instead of clicking in the URL field, I clicked right in the middle of the horizontal bar. I HAVE NO IDEA WHAT I CLICKED BUT FROM THAT MOMENT TO THIS THAT HORIZONTAL BAR HAS NEVER RE-APPEARED. WHATEVER I CLICKED, IT APPEARS I INSTRUCTED FIREFOX TO NEVER PROVIDE ME WITH THAT HORIZONTAL BAR AGAIN!!! As a result, I am also no longer getting the grey box with the Show All, Allow, Allow and Remember options. How can I restore normal behavior, and get the normal horizontal bar and the normal box with the Show All, Allow, Allow and Remember options?

Giải pháp được chọn

I'm not sure if clearing the "Site Preferences" for the last hour(s) would have effect if you wouldn't do this immediately.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Widevine Technologies, Inc. Digital Rights Management and Video Optimization
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • 5.1.30514.0
  • Octoshape embedded video plugin
  • Shockwave Flash 11.9 r900
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Plug-in for detecting Nero Kwik Media.
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

Thông tin chi tiết

Người tạo câu hỏi

Additional information: On my Windows 7 computer, the site is still behaving normally, so I can tell you in greater detail what I should be getting. The thin horizontal bar should be saying "Allow www.pingtest.net to run "Java Platform SE 7 U"? Then, on the right edge of the thin horizontal bar should be two black-on-grey messages, Continue Blocking and Allow...

That is the bar that has disappeared. HOW DO I GET THAT BACK??????

Additional information: On my Windows 7 computer, the site is still behaving normally, so I can tell you in greater detail what I should be getting. The thin horizontal bar should be saying "Allow www.pingtest.net to run "Java Platform SE 7 U"? Then, on the right edge of the thin horizontal bar should be two black-on-grey messages, Continue Blocking and Allow... That is the bar that has disappeared. HOW DO I GET THAT BACK??????

Câu trả lời hữu ích

Additional information: I went through all the menus I could think on the two computers, and they match perfectly. So I'm forced to conclude that it's some deeply buried parameter in the about:config page. Obviously the odds of my figuring out which one it is is pretty near zero. There is no way I will be able to proceed further without expert guidance. Let us hope that it will quickly be forthcoming.

Additional information: I went through all the menus I could think on the two computers, and they match perfectly. So I'm forced to conclude that it's some deeply buried parameter in the about:config page. Obviously the odds of my figuring out which one it is is pretty near zero. There is no way I will be able to proceed further without expert guidance. Let us hope that it will quickly be forthcoming.
cor-el
  • Top 10 Contributor
  • Moderator
17340 giải pháp 156761 câu trả lời
Được đăng

You can inspect and manage the permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

You can inspect and manage the permissions for all domains on the about:permissions page.

Please update the Shockwave Flash 11.9 r900 plugin. The currently installed version is outdated and has known security vulnerabilities.

You can find the latest Flash player versions for Firefox on this page:

You can inspect and manage the permissions for the domain in the currently selected tab via these steps: *Click the "[[Site Identity Button|Site Identity Button]]" (globe/padlock) on the location/address bar *Click "More Information" to open "Tools > Page Info" with the Security tab selected *Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab You can inspect and manage the permissions for all domains on the <b>about:permissions</b> page. *https://support.mozilla.org/kb/how-do-i-manage-website-permissions Please update the Shockwave Flash 11.9 r900 plugin. The currently installed version is outdated and has known security vulnerabilities. *https://www.mozilla.org/plugincheck/ You can find the latest Flash player versions for Firefox on this page: *http://www.adobe.com/special/products/flashplayer/fp_distribution3.html

Người tạo câu hỏi

Thank you for your suggestions regarding the Site Identity Permissions and the about:permissions page.

To save space above, I didn't bother putting in all the stuff I've tried unsuccessfully. The bottom line is that I've gone into the Site Identity Permissions menu multiple times in the last nightmarish seven hours still desperately trying to fix this stupid thing without success. As far as I could tell there were four items in the Site Identity Permissions that might conceivably have something to do with this screwup, Adobe Acrobat, Adobe Flash, Java Deployment Toolkit and Java (TM) Platform SE 7U. I tried leaving everything in Default except for Adobe Acrobat, for which I tried all permutations. I tried leaving everything in Default except for Adobe Flash, for which I tried all permutations. I tried leaving everything in Default except for Java Deployment Toolkit, for which I tried all permutations. I tried leaving everything in Default except for Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat and Adobe Flash, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat and Java Deployment Toolkit, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat and Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Adobe Flash and Java Deployment Toolkit, for which I tried all permutations. I tried leaving everything in Default except for Adobe Flash and Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Java Deployment Toolkit and Java (TM) Platform SE 7U. I tried leaving everything in Default except for Adobe Acrobat, Adobe Flash and Java Deployment Toolkit, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat, Adobe Flash and Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat, Java Deployment Toolkit and Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Adobe Flash, Java Deployment Toolkit and Java (TM) Platform SE 7U, for which I tried all permutations.

And, finallly, I tried leaving everything in Default except for Adobe Acrobat, Adobe Flash, Java Deployment Toolkit and Java (TM) Platform SE 7 U, for which I tried all permutations.

The above tests took about two hours, after which I ended up with a big fat zero, and seriously contemplating throwing the computer out of the window.

Thank you for bringing my attention to the about:permissions page; I did not know that existed. I pulled that up, and sure enough, I found the pingtest.net settings. However, I'm blessed if I would even begin to know which, if any, of those parameters might be the one that fixes this confounded problem.

Finally I looked at my Windows 7 computer to see if there were any telltale differences between that computer, where everything is operating properly, and the Windows 8 computer, where I screwed up that Allow/Remember horizontal bar yesterday. I checked both the Site Identity permissions for the site and the about:permissions page. Once again I drew a complete blank. Clearly, while clicking that stupid bar undoubtedly gave my Windows 8 computer instructions which ran directly counter to my wishes, those instructions did not leave footprints in either of those menus and I need to look elsewhere. I'm thinking it's either some stupid buried menu in Firefox or, who knows?, perhaps I need to look at my Flash instructions, if I knew where that stupid menu was, or my Java instructions, if I knew where that stupid menu was.

Can you tell that I'm feeling a tad homicidal right about now?

By the way, it occurred to me it might save a little time if I were to post an image showing clearly the bar I'm talking about that I made disappear on my Windows 8 box. So I've included those two images in my post. First, here is the way it's supposed to look, and does look, on my Windows 7 computer:

https://support.cdn.mozilla.net/media/uploads/images/2014-09-04-19-49-49-ba9add.png

And here's the way it now looks on my Windows 8 computer, after I screwed up the settings yesterday:

https://support.cdn.mozilla.net/media/uploads/images/2014-09-04-20-00-48-9f3612.png

See what's missing?

In addition, regarding updates, understand this is NOT a bug in some piece of software which an update will solve. This was a piece of software that was working perfectly fine until I SCREWED UP THE SETTINGS. Updating is irrelevant and won't do me any good. I need to fix the settings I screwed up, --

-- if I could only find them.

Thank you for your suggestions regarding the Site Identity Permissions and the about:permissions page. To save space above, I didn't bother putting in all the stuff I've tried unsuccessfully. The bottom line is that I've gone into the Site Identity Permissions menu multiple times in the last nightmarish seven hours still desperately trying to fix this stupid thing without success. As far as I could tell there were four items in the Site Identity Permissions that might conceivably have something to do with this screwup, Adobe Acrobat, Adobe Flash, Java Deployment Toolkit and Java (TM) Platform SE 7U. I tried leaving everything in Default except for Adobe Acrobat, for which I tried all permutations. I tried leaving everything in Default except for Adobe Flash, for which I tried all permutations. I tried leaving everything in Default except for Java Deployment Toolkit, for which I tried all permutations. I tried leaving everything in Default except for Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat and Adobe Flash, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat and Java Deployment Toolkit, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat and Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Adobe Flash and Java Deployment Toolkit, for which I tried all permutations. I tried leaving everything in Default except for Adobe Flash and Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Java Deployment Toolkit and Java (TM) Platform SE 7U. I tried leaving everything in Default except for Adobe Acrobat, Adobe Flash and Java Deployment Toolkit, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat, Adobe Flash and Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Adobe Acrobat, Java Deployment Toolkit and Java (TM) Platform SE 7U, for which I tried all permutations. I tried leaving everything in Default except for Adobe Flash, Java Deployment Toolkit and Java (TM) Platform SE 7U, for which I tried all permutations. And, finallly, I tried leaving everything in Default except for Adobe Acrobat, Adobe Flash, Java Deployment Toolkit and Java (TM) Platform SE 7 U, for which I tried all permutations. The above tests took about two hours, after which I ended up with a big fat zero, and seriously contemplating throwing the computer out of the window. Thank you for bringing my attention to the about:permissions page; I did not know that existed. I pulled that up, and sure enough, I found the pingtest.net settings. However, I'm blessed if I would even begin to know which, if any, of those parameters might be the one that fixes this confounded problem. Finally I looked at my Windows 7 computer to see if there were any telltale differences between that computer, where everything is operating properly, and the Windows 8 computer, where I screwed up that Allow/Remember horizontal bar yesterday. I checked both the Site Identity permissions for the site and the about:permissions page. Once again I drew a complete blank. Clearly, while clicking that stupid bar undoubtedly gave my Windows 8 computer instructions which ran directly counter to my wishes, those instructions did not leave footprints in either of those menus and I need to look elsewhere. I'm thinking it's either some stupid buried menu in Firefox or, who knows?, perhaps I need to look at my Flash instructions, if I knew where that stupid menu was, or my Java instructions, if I knew where that stupid menu was. Can you tell that I'm feeling a tad homicidal right about now? By the way, it occurred to me it might save a little time if I were to post an image showing clearly the bar I'm talking about that I made disappear on my Windows 8 box. So I've included those two images in my post. First, here is the way it's supposed to look, and does look, on my Windows 7 computer: https://support.cdn.mozilla.net/media/uploads/images/2014-09-04-19-49-49-ba9add.png And here's the way it now looks on my Windows 8 computer, after I screwed up the settings yesterday: https://support.cdn.mozilla.net/media/uploads/images/2014-09-04-20-00-48-9f3612.png See what's missing? In addition, regarding updates, understand this is NOT a bug in some piece of software which an update will solve. This was a piece of software that was working perfectly fine until I SCREWED UP THE SETTINGS. Updating is irrelevant and won't do me any good. I need to fix the settings I screwed up, -- -- if I could only find them.

Được chỉnh sửa bởi cor-el vào

cor-el
  • Top 10 Contributor
  • Moderator
17340 giải pháp 156761 câu trả lời
Được đăng

Try to rename (or delete) the permissions.sqlite file in the Firefox profile folder to reset all permissions.

Try to rename (or delete) the permissions.sqlite file in the Firefox profile folder to reset all permissions. *http://kb.mozillazine.org/Profile_folder_-_Firefox

Người tạo câu hỏi

Thanks for not giving up on this.

However I'll need additional info to pursue this possibility further. I'll need the name of the folder in which the permissions.sqlite file resides, I'll need to know whether I'll need to close and re-open Firefox in order to do this, I'll need to know whether I will need to clear my cache and/or my history, etc. etc.

Thanks for not giving up on this. However I'll need additional info to pursue this possibility further. I'll need the name of the folder in which the permissions.sqlite file resides, I'll need to know whether I'll need to close and re-open Firefox in order to do this, I'll need to know whether I will need to clear my cache and/or my history, etc. etc.
jscher2000
  • Top 10 Contributor
8575 giải pháp 70112 câu trả lời
Được đăng

The bar is handy because it draws your attention and has a fuller description, but if you click that red notification icon in the address bar, it should let you allow Java to run -- in other words, Allow and Allow and Remember should be there. (Screen shot added of the dialog that drops down when you click the notification icon directly instead of through the infobar)

To answer your question about the location of permissions.sqlite, that is in your profile folder. cor-el provided a link about how to find that folder, but here's a fuller description.

Note: If you proceed, you will need to re-save all non-default permissions (e.g., cookie allow/block, pop-up permission, etc.) that you had previously accumulated in that file through the Firefox interface.

You can open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename permissions.sqlite to something like permissions.old.

Start Firefox back up again and test...

The bar is handy because it draws your attention and has a fuller description, but if you click that red notification icon in the address bar, it should let you allow Java to run -- in other words, Allow and Allow and Remember should be there. ''(Screen shot added of the dialog that drops down when you click the notification icon directly instead of through the infobar)'' To answer your question about the location of permissions.sqlite, that is in your profile folder. cor-el provided a link about how to find that folder, but here's a fuller description. '''Note: If you proceed, you will need to re-save all non-default permissions (e.g., cookie allow/block, pop-up permission, etc.) that you had previously accumulated in that file through the Firefox interface.''' You can open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * Help menu > Troubleshooting Information In the first table on the page, click the "Show Folder" button Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * File menu > Exit Pause while Firefox finishes its cleanup, then rename '''permissions.sqlite''' to something like permissions.old. Start Firefox back up again and test...

Được chỉnh sửa bởi jscher2000 vào

jscher2000
  • Top 10 Contributor
8575 giải pháp 70112 câu trả lời
Được đăng

Câu trả lời hữu ích

We had another thread recently where the user clicked "Continue Blocking" and thereafter, Firefox never showed the infobar. I posted a way to clear the block so that the infobar would display once again. It's a little involved, but if it's going to keep driving you crazy, see: reset plugin behavior.

We had another thread recently where the user clicked "Continue Blocking" and thereafter, Firefox never showed the infobar. I posted a way to clear the block so that the infobar would display once again. It's a little involved, but if it's going to keep driving you crazy, see: [https://support.mozilla.org/questions/1011980 reset plugin behavior].

Người tạo câu hỏi

Thanks to Cor-El and JScher2000.

First, the good news. I exited Firefox, renamed the permissions.sqlite to another name (oldpermissions.sqlite), re-opened Firefox and established, to my satisfaction, that the problem had been corrected.

Now, as I understand it, by doing this, I'm not just correcting whatever the parameter was that I screwed up but, in fact, dumping ALL my permissions and configurations, all of those little helpful changes I've made over the months and years to keep Firefox running as I want it to run.

In other words, while this certainly corrected the problem, I will no doubt discover in the days and weeks ahead that I have not just fixed the crack in the glass. In fact, I smashed the old glass and replaced it with an entirely new one. While perhaps effective, I have specifically NOT corrected the one parameter that I actually screwed up.

I find this approach less than ideal, frankly, even while I appreciate the time and thought folks took to provide me with this admittedly very effective work-around.

So it occurred to me that it might be helpful to find out exactly what I screwed up. Once armed with that information, it might then be child's-play (hey, one can dream, right?) to know exactly where to go to fix the parameter I screwed up.

So I set out deliberately to create the same screwed-up situation, and I am happy I succeeded in doing that. I tried clicking that horizontal bar at various locations to see if I could repeat the same problem.

I have now established to my satisfaction exactly what I screwed up. If you take a look at https://support.cdn.mozilla.net/media/uploads/images/2014-09-04-19-49-49-ba9add.png and look at the right edge of the thin horizontal bar, you will see that one has an option of clicking Continue Blocking. I have proven that this what I clicked, since I was able to duplicate the problem exactly, right down to its correction using the rename-permissions Band-Aid.

So, now that we know exactly what I screwed up, namely that I clicked the Continue Blocking option, I can now phrase my question far more precisely, and it is now this: How do I undo that Continue Blocking command, once I have issued it? And does the Continue Blocking command Firefox just to block that one site, or is Firefox now under orders to continually block such items on ALL web pages?

Hopefully, having ratcheted up my specificity to a somewhat notable extent, a precise fix can now be located.

Thanks again to all taking the time to read my tale of woe and to rally round with help!

Thanks to Cor-El and JScher2000. First, the good news. I exited Firefox, renamed the permissions.sqlite to another name (oldpermissions.sqlite), re-opened Firefox and established, to my satisfaction, that the problem had been corrected. Now, as I understand it, by doing this, I'm not just correcting whatever the parameter was that I screwed up but, in fact, dumping ALL my permissions and configurations, all of those little helpful changes I've made over the months and years to keep Firefox running as I want it to run. In other words, while this certainly corrected the problem, I will no doubt discover in the days and weeks ahead that I have not just fixed the crack in the glass. In fact, I smashed the old glass and replaced it with an entirely new one. While perhaps effective, I have specifically NOT corrected the one parameter that I actually screwed up. I find this approach less than ideal, frankly, even while I appreciate the time and thought folks took to provide me with this admittedly very effective work-around. So it occurred to me that it might be helpful to find out exactly what I screwed up. Once armed with that information, it might then be child's-play (hey, one can dream, right?) to know exactly where to go to fix the parameter I screwed up. So I set out deliberately to create the same screwed-up situation, and I am happy I succeeded in doing that. I tried clicking that horizontal bar at various locations to see if I could repeat the same problem. I have now established to my satisfaction exactly what I screwed up. If you take a look at https://support.cdn.mozilla.net/media/uploads/images/2014-09-04-19-49-49-ba9add.png and look at the right edge of the thin horizontal bar, you will see that one has an option of clicking Continue Blocking. I have proven that this what I clicked, since I was able to duplicate the problem exactly, right down to its correction using the rename-permissions Band-Aid. So, now that we know exactly what I screwed up, namely that I clicked the Continue Blocking option, I can now phrase my question far more precisely, and it is now this: How do I undo that Continue Blocking command, once I have issued it? And does the Continue Blocking command Firefox just to block that one site, or is Firefox now under orders to continually block such items on ALL web pages? Hopefully, having ratcheted up my specificity to a somewhat notable extent, a precise fix can now be located. Thanks again to all taking the time to read my tale of woe and to rally round with help!

Người tạo câu hỏi

Just to clarify, once we have established precisely where the toggle for that Continue Blocking parameter resides, I intend to trash the two Band-Aid permissions files that I have just created, and to rename the oldest oldpermissions.sqlite back to permissions.sqlite. That way I will be back with my carefully and painstakingly formulated permissions file that had been tweaked and configured over an extended period of time.

Once restored to my original permissions file, it is my hope then to correct the successfully located Continue Blocking parameter while utilizing that original permissions file.

Hope that makes sense. Thanks again for your help.

Just to clarify, once we have established precisely where the toggle for that Continue Blocking parameter resides, I intend to trash the two Band-Aid permissions files that I have just created, and to rename the oldest oldpermissions.sqlite back to permissions.sqlite. That way I will be back with my carefully and painstakingly formulated permissions file that had been tweaked and configured over an extended period of time. Once restored to my original permissions file, it is my hope then to correct the successfully located Continue Blocking parameter while utilizing that original permissions file. Hope that makes sense. Thanks again for your help.
jscher2000
  • Top 10 Contributor
8575 giải pháp 70112 câu trả lời
Được đăng

Yes, you can restore your oldpermissions.sqlite file and use the approach I linked to in https://support.mozilla.org/questions/1018395#answer-624015 to undo the effect of "Continue Blocking".

Yes, you can restore your oldpermissions.sqlite file and use the approach I linked to in https://support.mozilla.org/questions/1018395#answer-624015 to undo the effect of "Continue Blocking".

Người tạo câu hỏi

THAT WAS IT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

What a relief! I am no longer feeling homicidal...............

Yes, I am back on my old permissions.sqlite file, and I trashed the two newer ones I created tonight. And yes, the infobar is back where it should be on the pingtest site.

Included in that invaluable thread to which you pointed me were the following words from you:

"The "Continue blocking" option appears to add a new entry to the permissions.sqlite database (site-specific permissions) that suppresses the Infobar forever."

Let me just say how COMPLETELY LAME IT IS that Firefox offers the unsuspecting user a way to toggle a parameter in such a way that it is IMPOSSIBLE TO TOGGLE IT BACK in an operationally normal manner. This problem quite literally ruined my whole day. I cannot imagine what whichever Firefox elf who came up with the bright idea of putting a nuclear button like that on an easily accessible panel could have possibly been thinking. Of course, most likely this particular elf was not thinking at all.

I am very relieved and grateful to you, jscher2000, that you took the time to read my query and to provide me with the precise and correct information. Thank you very much.

I am also grateful to Juno Rebel, my fellow victim, whose previous suffering and call for help probably shortened what would have been a very unpleasant time for me.

So, time for me to fix myself a stiff drink and try to forget this day ever happened.

THAT WAS IT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! What a relief! I am no longer feeling homicidal............... Yes, I am back on my old permissions.sqlite file, and I trashed the two newer ones I created tonight. And yes, the infobar is back where it should be on the pingtest site. Included in that invaluable thread to which you pointed me were the following words from you: "The "Continue blocking" option appears to add a new entry to the permissions.sqlite database (site-specific permissions) that suppresses the Infobar forever." Let me just say how COMPLETELY LAME IT IS that Firefox offers the unsuspecting user a way to toggle a parameter in such a way that it is IMPOSSIBLE TO TOGGLE IT BACK in an operationally normal manner. This problem quite literally ruined my whole day. I cannot imagine what whichever Firefox elf who came up with the bright idea of putting a nuclear button like that on an easily accessible panel could have possibly been thinking. Of course, most likely this particular elf was not thinking at all. I am very relieved and grateful to you, jscher2000, that you took the time to read my query and to provide me with the precise and correct information. Thank you very much. I am also grateful to Juno Rebel, my fellow victim, whose previous suffering and call for help probably shortened what would have been a very unpleasant time for me. So, time for me to fix myself a stiff drink and try to forget this day ever happened.

Được chỉnh sửa bởi criggs vào

cor-el
  • Top 10 Contributor
  • Moderator
17340 giải pháp 156761 câu trả lời
Được đăng

Did you check this in "Tools > Page Info > Permissions" to see if that showed that the Java plugin was blocked?

You should already see this if you click the globe at the left end of the location/address bar. Also note the red Lego block icon in the location in your screenshot.

Did you check this in "Tools > Page Info > Permissions" to see if that showed that the Java plugin was blocked? You should already see this if you click the globe at the left end of the location/address bar. Also note the red Lego block icon in the location in your screenshot.

Người tạo câu hỏi

Nope, it ain't in there; jscher2000 is right. Apparently this is not a toggle that's available through one of the normal operator menus. jscher2000 appears to be right. Through over eighteen hours of non-stop googling, hunting and testing, I found exactly one thing that would fix it, and that was jscher2000's fix using SQLite Manager. Absurd and preposterous, yes; but it's a fact, believe it or not, and reflects very poorly on whatever dim bulb first thought to give a Firefox operator the ability to PERMANENTLY block a normal operator function; truly lame.

Nope, it ain't in there; jscher2000 is right. Apparently this is not a toggle that's available through one of the normal operator menus. jscher2000 appears to be right. Through over eighteen hours of non-stop googling, hunting and testing, I found exactly one thing that would fix it, and that was jscher2000's fix using SQLite Manager. Absurd and preposterous, yes; but it's a fact, believe it or not, and reflects very poorly on whatever dim bulb first thought to give a Firefox operator the ability to PERMANENTLY block a normal operator function; truly lame.
cor-el
  • Top 10 Contributor
  • Moderator
17340 giải pháp 156761 câu trả lời
Được đăng

What also works for me is to use "Forget About This Site" to get the notification bar appear again.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

What also works for me is to use "Forget About This Site" to get the notification bar appear again. You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page. Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Người tạo câu hỏi

Thanks for the info. This is a little less drastic than the destruction/replacement of the permissions site. It might also be helpful if it is not known precisely what parameter is screwed up and cannot be corrected.

However, as you point out yourself, it has a negative impact on operation n the sense that saved passwords, cookies, and so on are also destroyed. So it remains a solution analogous to replacing the whole door because one of the hinges was squeaking. Necessary, perhaps, under certain circumstances but, fortunately, not necessary in this case.

In general, I like the principle that one should effect the smallest change possible to achieve a goal, where technical fixes are concerned. Fixes can always have unintended consequences, so it always makes sense, I think, to open the door as little as possible to those consequences.

Thanks for the info. This is a little less drastic than the destruction/replacement of the permissions site. It might also be helpful if it is not known precisely what parameter is screwed up and cannot be corrected. However, as you point out yourself, it has a negative impact on operation n the sense that saved passwords, cookies, and so on are also destroyed. So it remains a solution analogous to replacing the whole door because one of the hinges was squeaking. Necessary, perhaps, under certain circumstances but, fortunately, not necessary in this case. In general, I like the principle that one should effect the smallest change possible to achieve a goal, where technical fixes are concerned. Fixes can always have unintended consequences, so it always makes sense, I think, to open the door as little as possible to those consequences.
cor-el
  • Top 10 Contributor
  • Moderator
17340 giải pháp 156761 câu trả lời
Được đăng

Giải pháp được chọn

I'm not sure if clearing the "Site Preferences" for the last hour(s) would have effect if you wouldn't do this immediately.

I'm not sure if clearing the "Site Preferences" for the last hour(s) would have effect if you wouldn't do this immediately.

Người tạo câu hỏi

Where is Site Preferences located, please?

Where is Site Preferences located, please?
jscher2000
  • Top 10 Contributor
8575 giải pháp 70112 câu trả lời
Được đăng

Hi criggs, I think what cor-el meant was something like this:

(menu) History > Clear Recent History

Uncheck everything except Site Preferences, then pick the time range for which you want to clear them (e.g., Today). This would roll back additions to permissions.sqlite based on the time they were added.


I'm not sure how "Continue Blocking" should work. Having it hide the infobar only for the rest of the current session might make more sense, but I don't know how that could be implemented. If you want to push for that, here are two places to press:

(1) Feedback site: https://input.mozilla.org/feedback

(2) Bug tracking system: https://bugzilla.mozilla.org/

Hi criggs, I think what cor-el meant was something like this: (menu) History > Clear Recent History Uncheck everything except Site Preferences, then pick the time range for which you want to clear them (e.g., Today). This would roll back additions to permissions.sqlite based on the time they were added. ---- I'm not sure how "Continue Blocking" should work. Having it hide the infobar only for the rest of the current session might make more sense, but I don't know how that could be implemented. If you want to push for that, here are two places to press: (1) Feedback site: https://input.mozilla.org/feedback (2) Bug tracking system: https://bugzilla.mozilla.org/

Người tạo câu hỏi

Odd. I just did what you suggested. But when I checked just Site Preferences and clicked Clear Now, I got no message requesting the time frame; I presume all my Site Preferences for this site are now gone therefore (I did it while sitting on this page). How do I activate the time frame query? It looks like I didn't do it right.

Odd. I just did what you suggested. But when I checked just Site Preferences and clicked Clear Now, I got no message requesting the time frame; I presume all my Site Preferences for this site are now gone therefore (I did it while sitting on this page). How do I activate the time frame query? It looks like I didn't do it right.