تلاش سپورٹ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

memory

  • 4 جواب دیں
  • 10 میں یہ مسئلہ ہے
  • 1 دیکھیں
  • آخری جواب بذریعہ cor-el

more options

Why is Firefox always take 500 MB to 3 GB of RAM to just browse???

This is just on a Google page with two plug-ins installed and I've never seen this browser ever go below 500 MB. You need to fix the memory leak issue. This has been doing this since build 50

I would expect that it would of been fixed, but, it got worse. I bet your next version would take up 10 GB of RAM

Why is Firefox always take 500 MB to 3 GB of RAM to just browse??? This is just on a Google page with two plug-ins installed and I've never seen this browser ever go below 500 MB. You need to fix the memory leak issue. This has been doing this since build 50 I would expect that it would of been fixed, but, it got worse. I bet your next version would take up 10 GB of RAM
منسلک شدہ اسکرین شاٹٹس

منتخب شدہ حل

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can try to modify multi-process settings to see if this has effect.

  • set number of content processes to 1 if it is currently set to a higher value (4)
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • disable multi-process windows in Firefox
اس جواب کو سیاق و سباق میں پڑھیں 👍 1

تمام جوابات (4)

more options

If Firefox is using too much memory, please see this page: https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

more options

Mkll said

If Firefox is using too much memory, please see this page: https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

Already seen that and doesn't fix it.

I have 24 GB of RAM, Xeon X5670 CPU and it only has two plug-ins and still floods the RAM.

The core firefox.exe file in Task Manager is the one that takes up all of the RAM. If I shutdown the file that's taking up the RAM, the whole Firefox is shutdown.

Tells me the core file is the problem.

more options

Let's try a Refresh!

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

منتخب شدہ حل

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can try to modify multi-process settings to see if this has effect.

  • set number of content processes to 1 if it is currently set to a higher value (4)
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • disable multi-process windows in Firefox