Вирішення проблем пов`язаних з модулями

Ця стаття можливо застаріла.

Були внесені важливі зміни в англійську версію цієї сторінки. Якщо хочете, перегляньте її, доки триває переклад внесених змін: Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Якщо у вас виникають проблеми зі сторінками, які для відображення свого вмісту використовують модулі (на кшталт Flash, Windows Media Player, Java, тощо) - то можливо, якийсь із встановлених у вашому Firefox модулів спричиняє дану проблему.

Розповсюдженні проблеми спричинені модулями:

Ця стаття описує як вирішувати проблеми пов'язані з модулями. Якщо у вас проблеми, пов'язані з розширеннями чи темами - перегляньте статтю Вирішення проблем пов`язаних з розширеннями та темами. Загальну інформацію по модулям перегляньте в статті Використання модулів у Firefox.


Як визначити, чи це модуль являється причиною проблеми

Ви можете вибірково вимикати модулі під час роботи Firefox. Якщо ви підозрюєте якийсь певний модуль - вимкніть його першим, потім протестуйте на наявність проблеми. Якщо ви не знаєте, який модуль вимикати:

  1. Відкрийте вікно Додати, вибравши в меню Інструменти підпункт Додатки.
  2. У цьому вікні перейдіть на панель Модулі.
  3. Виділіть модуль у списку та натисніть кнопку Вимкнути. Повторіть цей крок для кожного модуля у списку. Вам не потрібно перезапускати Firefox для того, щоб зміни вступили в дію.
  4. Протестуйте на наявність проблеми. Якщо вона не з'являється - знову відкрийте вікно Додатки і вмикайте модулі по одному, використовуючи кнопку Увімкнути до тих пір, поки ви віднайдете проблемний модуль.

Якщо вимкнення модулю вирішує проблему - продовжіть виконання наступних кроків цієї статті.


Оновлення або встановлення заново модуля

Більшість проблем з модулями можуть бути вирішені оновленням до найостаннішої версії. Щоб перевірити на застарілість версії встановлених у вас модулів, відвідайте сторінку перевірки модулів від Мозіли.

Якщо оновлення до найостаннішої версії модуля або його перевстановлення не вирішує проблему - залиште його вимкненим.


Вилучення модулю вручну

Якщо у вас немає можливості скористатись програмою де-інсталятором для вилучення модуля, вилучіть його вручну:

  1. Надрукуйте в панелі адрес about:config та натисніть клавішу EnterReturn. ** З'явиться сторінка з повідомленням "Обережніше, цією сторінкою можна порізатись!"'. Щоб продовжити, натисніть кнопку Я буду обережним, обіцяю!.
  2. Віднайдіть опцію: plugin.expose_full_path.
  3. Клацніть двічі по опції plugin.expose_full_path, щоб змінити її значення на true.
  4. В панелі адрес введіть about:plugins, щоб відкрити сторінку Встановлені модулі.
  5. Кожен запис про модуль на сторінці Встановлені модулі матиме "Ім’я файлу:". Перейдіть до теки де знаходиться даний файл.
  6. Змініть назву файлу на щось інше, наприклад npswf32 перейменуйте в Xnpswf32

Модуль буде вилучено.


Переініціалізація бази даних модулів

В деякий випадках ви не матимете змоги встановлювати чи вилучати модулі. Можливо, переініціалізація бази даних модулів вирішить дану проблему:

  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
  5. Вилучіть файл pluginreg.dat.
  6. Запустіть Firefox
  7. В панелі адрес вдрукуйте about:plugins та натисніть EnterReturn, щоб відкрити сторінку Встановлені модулі.

Ця стаття допомогла? Зачекайте...

Цю статтю допомогли написати такі гарні люди: Bogdancev. Ви теж можете допомогти - дізнайтесь як.