Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Have started seeing diamonds with question marks on FireFox (and Chrome); changed encoding, made no difference.

  • 44 பதிலளிப்புகள்
  • 8 இந்த பிரச்னைகள் உள்ளது
  • 64 views
  • Last reply by cor-el

Both FireFox and Google Chrome (but not Internet Explorer) have been showing black diamonds with question marks in them for some time. It's not an encoding issue, as changing character encoding doesn't work. I don't know what caused it, as it all of a sudden started out of the blue. My network.http. in about:config are all default. I've tried scanning for malware, including in safe mode with the internet disconnected. Nothing has made a difference. Please help me, as this problem is incredibly hard to Google and I have no idea what to do.

All Replies (20)

If I go the that page then I see a Western(Windows-1252) encoding used: Tools > Page Info > General

So try to select that encoding:

  • View > Character Encoding > More Encodings > West European > Western (Windows-1252)

It doesn't bother me any more. I just needed to know if there was some bug in MY system. It would seem that there is not. I understand you are saying that it is the encoding on THEIR website. Whenever I go to Ignis Arden it is only there sometimes.

Try to reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files if it happens again.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

It's me again. I was having the same problem with the black diamonds appearing. I found the 'menu' button OK but the 'encoding' was in shadow. It was not clickable. Can you help please.

kadona மூலமாக திருத்தப்பட்டது

Hi kadona

Can you post a link?

Which encoding do you see listed if you got to Tools > Page Info > General?

  • Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.

You probably need a Windows (e.g. Windows-1252) or Western (ISO-8859-1) encoding to have the characters display instead of the diamonds.
This usually happens if UFT-8 is selected and the characters are in the 0x80-0x9f range that doesn't exist in UTF-8.
Note that this also can be a problem with the web page caused by copying text from another encoding.

cor-el மூலமாக திருத்தப்பட்டது

I followed through on your directions and found that the encoding on Page info is indeed UTF-8. But how do I change it? There is no facility to replace it with a different code.

You should be able to change the encoding here:

  • Firefox > Web Developer > Character Encoding
  • View > Character Encoding

You can press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.

Character encoding is not on the Web Developer. I have found it on 'view' (as stated previously) but it is in shadow...not clickable.

Which Firefox version are you running, see Help > About?

Try to start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing this problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

I got onto 'appearances' then clicked on the default thingo and all I got was when it was last updated. I could not find safe mode...I followed your link to support but it did not show me how to access 'safe mode'. the screen shot just shoed 'safe mode' but not how to get it.

I got onto 'appearances' then clicked on the default thingo and all I got was when it was last updated. I could not find safe mode...I followed your link to support but it did not show me how to access 'safe mode'. the screen shot just showed 'safe mode' but not how to get it.

kadona மூலமாக திருத்தப்பட்டது

Found Safe Mode...but was only offered one choice..and unfortunately I pressed the reset button. Look, I am truly grateful for all your time and trouble Mod. but I seem to be getting nowhere. What if I download a different version of Firefox? I can uninstall this one and get another download can't I? What version should I get? I have Windows 7.

Hi kadona, all versions of Firefox are going to handle character sets the same way.

What you could do is choose a different default encoding and see whether that helps.

orange Firefox button (or Tools menu) > Options > Content

When you click the Advanced button in the Fonts & Colors section, the lower part of the dialog allows you to choose encoding for pages that do not specify. So this won't help when the page specifies the wrong encoding, but could help when encoding is not specified.

I followed through on that but this is what I got:

'Fallback character encoding (ISO-8859-1)' There were heaps of codes to choose from, but it seems this is only a 'fallback' from something else(????) PageInfo, however, still shows the UTF-8. And the 'view' button, where I have been able to change the code in my former posts, is now in shadow and unclickable. Nothing has changed.

kadona மூலமாக திருத்தப்பட்டது

Hi kadona, I'm puzzled about the View menu being grayed out. Do you have that problem on every page? Do other menus work?

Sorry if I sound dumb, but I do have other 'menus'. Could you give me an example?

Hi kadona, I meant the top menu bar. Are you displaying the classic menu bar that has the View menu:

File, Edit, View, History, Bookmarks, Tools, Help

If you are using the compact two-column menu (orange Firefox button), you can display the classic menu bar by tapping the Alt key or pressing the F10 key.

Oh yes, I am getting that OK. That is where I pressed the 'view' button and all the others that I have gone through.  :)

  1. 1
  2. 2
  3. 3