X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Document Expired when hitting back button! Very annoying This has been ongoing intermittently for years Why cant this be fixed? Is anything being done about it?

  • 38 replies
  • 149 இந்த பிரச்னைகள் உள்ளது
  • Last reply by Terry
பதிவிடப்பட்டது

Document Expired when hitting back button! Very annoying This has been ongoing intermittently for years Why cant this be fixed? Is anything being done about it?

Document Expired when hitting back button! Very annoying This has been ongoing intermittently for years Why cant this be fixed? Is anything being done about it?

Additional System Details

இது நடந்தது

Every time Firefox opened

எப்பொழுது இது துவங்கப்பட்டது...

I updated to current version 10.0.2

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 11.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

கூடுதல் தகவல்

This has been ongoing on & off for years! It's very sad cos once again I have abandoned Firefox. What cant someone sort this out to never happen again or come up with a fix that works?

பதிவிடப்பட்டது

உதவிகரமான பதில்

How many people are sick of this!

How many people are sick of this!
cor-el
  • Top 10 Contributor
  • Moderator
17528 தீர்வுகள் 158478 பதில்கள்
பதிவிடப்பட்டது

Is that document retrieved via a secure HTTPS connection?

It is best to avoid such issues with using the Back button and open documents in a new tab with a middle-click on a link.

Is that document retrieved via a secure HTTPS connection? It is best to avoid such issues with using the Back button and open documents in a new tab with a middle-click on a link.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Don't use the back button? That is not a solution. I work on websites so I have to use the back button. Try listing on eBay without using the back button. If reverse gear didn't work on your car would you be happy doing a 10 point turn?

Don't use the back button? That is not a solution. I work on websites so I have to use the back button. Try listing on eBay without using the back button. If reverse gear didn't work on your car would you be happy doing a 10 point turn?
joehopeful 0 தீர்வுகள் 1 பதில்கள்
பதிவிடப்பட்டது

This is why I can no longer use FF - super cumbersome.

This is why I can no longer use FF - super cumbersome.
JScuderi 0 தீர்வுகள் 4 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

FIX THIS PLEASE! GIVE US THE OPTION TO TURN IT OFF.

This heavy handed security feature adds so many non-necessary clicks to my web app that it is no longer usable. I run the server I am trying to access. I wrote the secure web page I am trying to reload. I WANT it to resend the POST data with my form. FF is not allowing me, even with header("Cache-control: max-age=600"); in PHP to use the BACK button and have my form POST again.

This is the worst problem I've seen in FF in many years. Because we have to keep our software up to date, I can not revert to FF 9, I will start using Chrome or something else, but it sucks to have to leave so many other great features in FF behind.

FIX THIS PLEASE! GIVE US THE OPTION TO TURN IT OFF. This heavy handed security feature adds so many non-necessary clicks to my web app that it is no longer usable. I run the server I am trying to access. I wrote the secure web page I am trying to reload. I WANT it to resend the POST data with my form. FF is not allowing me, even with header("Cache-control: max-age=600"); in PHP to use the BACK button and have my form POST again. This is the worst problem I've seen in FF in many years. Because we have to keep our software up to date, I can not revert to FF 9, I will start using Chrome or something else, but it sucks to have to leave so many other great features in FF behind.
iliff 0 தீர்வுகள் 3 பதில்கள்
பதிவிடப்பட்டது

This misguided innovation is never less than annoying, and makes the MySQL application phpMyAdmin virtually unusable.

After you hit Refresh you also have to wrangle a confirm dialogue ~ double the misery.

µ

This misguided innovation is never less than annoying, and makes the MySQL application '''phpMyAdmin''' virtually unusable. After you hit Refresh you also have to wrangle a confirm dialogue ~ double the misery. µ
Oxylatium 71 தீர்வுகள் 563 பதில்கள்
பதிவிடப்பட்டது

Do you have a simple example (like a website with a form to fill) to provide?

Do you have a simple example (like a website with a form to fill) to provide?
Terry 9 தீர்வுகள் 266 பதில்கள்
பதிவிடப்பட்டது

What is the fix for "Document Expired" message please?

What is the fix for "Document Expired" message please?
Jonesyme 0 தீர்வுகள் 2 பதில்கள்
பதிவிடப்பட்டது

Are you serious? Try using the browser for more than 10 minutes and you'll see what we're talking about. Or maybe try using phpMyAdmin like the previous poster suggested. As a web developer you are killing me.

Honestly, you guys have just about destroyed firefox to the point of no return. I used to recommend this browser to everyone I knew. It's now an embarrassment. I can't even run FF on half of my machines because it eats every ounce of RAM I own. Quit trying to fix things that are NOT problems or I am going back to Opera.

Are you serious? Try using the browser for more than 10 minutes and you'll see what we're talking about. Or maybe try using phpMyAdmin like the previous poster suggested. As a web developer you are killing me. Honestly, you guys have just about destroyed firefox to the point of no return. I used to recommend this browser to everyone I knew. It's now an embarrassment. I can't even run FF on half of my machines because it eats every ounce of RAM I own. Quit trying to fix things that are NOT problems or I am going back to Opera.
cor-el
  • Top 10 Contributor
  • Moderator
17528 தீர்வுகள் 158478 பதில்கள்
பதிவிடப்பட்டது

This can be caused by websites that use local storage in Firefox or via a plugin like Flash.

Does it help if you downgrade to Flash 11.2 or 10.3?


You can also try to reset the preferences or try a new (test) profile.

This can be caused by websites that use local storage in Firefox or via a plugin like Flash. Does it help if you downgrade to Flash 11.2 or 10.3? *http://forums.adobe.com/thread/1022066 ---- You can also try to reset the preferences or try a new (test) profile. *https://support.mozilla.org/kb/Resetting+preferences *https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems *https://support.mozilla.org/kb/Managing+profiles *https://support.mozilla.org/kb/Recovering+important+data+from+an+old+profile
tianchu1987 0 தீர்வுகள் 1 பதில்கள்
பதிவிடப்பட்டது

Your solutions do NOT work. Please please fix this in the next release or just turn off this "feature" by default. It's super annoying.

Your solutions do NOT work. Please please fix this in the next release or just turn off this "feature" by default. It's super annoying.
Jonesyme 0 தீர்வுகள் 2 பதில்கள்
பதிவிடப்பட்டது

What's happening is anytime a user manually navigates back to a page that contained POST data, Firefox deducts that that page has expired and refuses to proceed. I understand the intention but not all websites function linearly. Sometimes you DO want to return to a page that expects POST data. Stop trying to fix things that aren't broken.

What's happening is anytime a user manually navigates back to a page that contained POST data, Firefox deducts that that page has expired and refuses to proceed. I understand the intention but not all websites function linearly. Sometimes you DO want to return to a page that expects POST data. Stop trying to fix things that aren't broken.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

It is obvious that Mozilla DON'T CARE about this problem. Most people cant be bothered to complain to them and just move on the Chrome or Opera. Thats a big mistake! Firefox used to be the best but now it's almost as bad as Internet explorer. They have know about this problem for years. A few years back they used to get rid of the problem for a couple of months and after a few updates it reappeared again I no longer use Firefox myself. It's a shame. They have their fingers in ears going lalalalalala not listening. What a joke.

It is obvious that Mozilla DON'T CARE about this problem. Most people cant be bothered to complain to them and just move on the Chrome or Opera. Thats a big mistake! Firefox used to be the best but now it's almost as bad as Internet explorer. They have know about this problem for years. A few years back they used to get rid of the problem for a couple of months and after a few updates it reappeared again I no longer use Firefox myself. It's a shame. They have their fingers in ears going lalalalalala not listening. What a joke.
BlohoJo 1 தீர்வுகள் 10 பதில்கள்
பதிவிடப்பட்டது

Fix:

go to about:config in location bar

search for browser.sessionstore.postdata

set value to -1

Fix: go to about:config in location bar search for '''browser.sessionstore.postdata''' set value to '''-1'''
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks for the reply BlohoJo but where do I find about:config in the location bar? I don't know what you mean. What is the location bar? You mean the address bar? No about config there.

Thanks for the reply BlohoJo but where do I find about:config in the location bar? I don't know what you mean. What is the location bar? You mean the address bar? No about config there.
iliff 0 தீர்வுகள் 3 பதில்கள்
பதிவிடப்பட்டது

BlohoJo means: - go to the address box (where you might key in a URL) - enter about:config - read the scary message that comes up - decide whether to risk it

BlohoJo means: - go to the address box (where you might key in a URL) - enter about:config - read the scary message that comes up - decide whether to risk it

iliff மூலமாக திருத்தப்பட்டது

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hey Bloho....It doesn't work. I'm afraid it makes no difference at all.

Document Expired




         This document is no longer available.
       


       The requested document is not available in Firefox's cache.As a security precaution, Firefox does not automatically re-request sensitive documents.Click Try Again to re-request the document from the website.
Hey Bloho....It doesn't work. I'm afraid it makes no difference at all. Document Expired This document is no longer available. The requested document is not available in Firefox's cache.As a security precaution, Firefox does not automatically re-request sensitive documents.Click Try Again to re-request the document from the website.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

OK Illif I see. I tried it but.... it doesn't work.

OK Illif I see. I tried it but.... it doesn't work.

TheOtherJon மூலமாக திருத்தப்பட்டது

BlohoJo 1 தீர்வுகள் 10 பதில்கள்
பதிவிடப்பட்டது

Did you close and restart the browser after changing browser.sessionstore.postdata to -1?

Did you close and restart the browser after changing '''browser.sessionstore.postdata''' to '''-1'''?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Yes I closed it down and restarted it. It's not working.

Yes I closed it down and restarted it. It's not working.