Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Foxnews.com causes Firefox 102.0.1 to freeze loading images

  • 9 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 1 view
  • Last reply by br5491

Foxnews.com causes Firefox 102.0.1 to freeze when scrolling pages with lots of images. Closing and restarting FF does not help. The freeze reoccurs. What does help for awhile is to delete the file places.sqlite. After that FF runs for a few hours until the problem happens again. Is there a setting or other fix for this issue?

AdBlockPlus and uBlock Origin are both installed, but are disabled on www.foxnews.com.

Foxnews.com causes Firefox 102.0.1 to freeze when scrolling pages with lots of images. Closing and restarting FF does not help. The freeze reoccurs. What does help for awhile is to delete the file places.sqlite. After that FF runs for a few hours until the problem happens again. Is there a setting or other fix for this issue? '''AdBlockPlus and uBlock Origin are both installed, but are disabled on www.foxnews.com.'''

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Does it still happen in a new profile if you block all autoplaying video? You can do this by going to about:config and changing media.autoplay.default to 5 and media.autoplay.blocking_policy to 2.

Read this answer in context 👍 0

All Replies (9)

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

The problem still occurs in troubleshooting mode. However, the freeze doesn't last as long. It is strange that this only happens with the foxnews site. Also, it does not happen when I use the MS Edge browser.

Does it still happen in a new profile without signing into Sync? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Previously I setup a new profile and it didn't help. Seemingly this problem occurs randomly after a few minutes or after a few hours. I can't force it to happen. When I delete the places.sqlite file, the problem goes away for most of a day. I have no idea what that file is used for or what it contains. I'm not technically skilled enough to use Firefox Developer. I looked at it and was overwhelmed.

Note that the System Details show that you use userChrome.css and userContent.css.

The places.sqlite file is a SQLite database that stores bookmarks and history, so you possibly have/had a problem with the history.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Does it still happen in a new profile if you block all autoplaying video? You can do this by going to about:config and changing media.autoplay.default to 5 and media.autoplay.blocking_policy to 2.

I've cleared history. media.autoplay.default was already set to 5. media.autoplay.blocking_policy was set to 0 and is now set to 2. The css is copied from MrOtherGuy on github. It enables multirow bookmarks. I typically have 60 or so single click bookmarks on the toolbar that I use on a daily basis and many more that are in bookmark menus or folders.

userContent.css is: @-moz-document domain(thehill.com){

div.player-container { display:none!important; }

}

@-moz-document domain(foxnews.com){

.featured.featured-video.video-ct.sticky-video .contain {
 display: none !important;
}

}

@-moz-document domain(foxbusinessnews.com){

.featured.featured-video.video-ct.sticky-video .contain {
 display: none !important;
}

}

@-moz-document domain(foxbusiness.com){

.featured.featured-video.video-ct.sticky-video .contain {
 display: none !important;
}

}

userChrome.css is: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

  1. tabbrowser-tabs ~ #alltabs-button {display:none!important;}
	/* Source file https://github.com/MrOtherGuy/firefox-csshacks/tree/master/chrome/multi-row_bookmarks.css made available under Mozilla Public License v. 2.0

See the above repository for updates as well as full license text. */

/* Makes bookmarks toolbar span multiple rows */

  1. PersonalToolbar{
 --multirow-bmb-n-rows: 2; /* Control how many rows are shown before scrolling */
 --multirow-bmb-row-margin: 2px; /* Control how much spacing is between rows */
 max-height: none !important;

}

  1. PlacesToolbar > hbox{
 display: block;
 width: 100vw;

}

  1. PlacesToolbarItems{
 display: flex;
 flex-wrap: wrap;
 /* --uc-bm-padding is defined in autohide_bookmarks_toolbar.css */
 max-height: calc(var(--multirow-bmb-n-rows) * (5px + 1em + (2 * (var(--multirow-bmb-row-margin) + var(--uc-bm-padding,4px))))) !important;
 overflow-y:auto;
 scrollbar-color: var(--lwt-accent-color) var(--toolbar-bgcolor) ;
 scrollbar-width: thin;

}

/* Hide the all-bookmarks button */

  1. PlacesChevron{ display: none }

/* Add some spacing between rows */

  1. PlacesToolbarItems > .bookmark-item{ margin: var(--multirow-bmb-row-margin) 2px !important; }

UPDATE

I removed userContent.css and the popup video that it was meant to block is not happening. Does the media.autoplay.blocking_policy setting = 2 have the same effect? If the freeze issue does not happen today, I'll mark this as solved. Thanks for all of the help!