Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop Http redirecting to Https on local address

  • 9 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 52 views
  • Last reply by PedroSMS

Hi,

I'm trying to configure equipment on my local network. Some of the equipment does NOT support https. Firefox continuously changes the address http://192.168.xxx.xxx to https://192.168.xxx.xxx, and the connection fails!

I have tried the various options in HTTP Only Mode, including entering Exceptions. I have also temporarily changed network.trr.mode from 5 to 1 (and 0), but nothing is working!

What can I do?

Thanking you Pedro

Hi, I'm trying to configure equipment on my local network. Some of the equipment does NOT support https. Firefox continuously changes the address http://192.168.xxx.xxx to https://192.168.xxx.xxx, and the connection fails! I have tried the various options in HTTP Only Mode, including entering Exceptions. I have also temporarily changed network.trr.mode from 5 to 1 (and 0), but nothing is working! What can I do? Thanking you Pedro

All Replies (9)

Maybe check the SiteSecurityServiceState.txt file in the Firefox profile folder.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Thank you for your reply @cor-el.

I found the "SiteSecurityServiceState.txt" file - what am I looking for, or what am meant to change?

Kind regards Pedro

That would be about a reference to the 192.168.xxx.xxx origin.

Thank you for your reply @cor-el.

There is no reference to any address in my local address range (192.168.0.0 - 192.168.255.255).

What next?

Kind regards Pedro

Hi,

Does anyone have any ideas that might help?

Kind regards Pedro

I found this. see screenshot There maybe another solution on the site that works for you. https://stackoverflow.com/questions/30532471/firefox-redirects-to-https

You shouldn't disable the HSTS preload list as this is only about domains like .dev that are on the HSTS proload list and thus can only be accessed via secure HTTPS. An IP range isn't part of HSTS. If you use Private Browsing mode then there can be a problem as exceptions work differently.

Are you using a private window? Firefox has a feature similar to HTTPS Only called HTTPS first that it uses in private windows. Maybe that is a factor? Here's how to disable it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste dom.security.https_first_pbm and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false


If you have a problem with the address bar autofilling an HTTPS version of the address, try this:

Go to the page, right-click the tab > Bookmark tab... and before saving, edit the URL from https to http. Then when you are entering the beginning of the IP address in the address bar, you should get the bookmark as a suggestion you can click in the autocomplete drop-down.

@jonzn4SUSE, thanks for your input, but that didn't work.

@jscher2000, thanks for your input too, but that didn't work either. I'm not using a private window.

I'll have to keep my old win7 machine, with ie going...

Kind regards Pedro