Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Helvetica font renders blank after updating to 112 via snap store

  • 18 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 53 views
  • Last reply by cor-el

After running `snap refresh firefox`, many sites I use no longer render any text.

Via some fiddling via the developer console, it appears to be that any text with `font-family: Helvetica`. Removing that CSS restores the text, adding it removes the text.

There's a fix for CVE-2023-29537 in this release that affects font initialization - possibly related?

After running `snap refresh firefox`, many sites I use no longer render any text. Via some fiddling via the developer console, it appears to be that any text with `font-family: Helvetica`. Removing that CSS restores the text, adding it removes the text. There's a fix for CVE-2023-29537 in this release that affects font initialization - possibly related?

All Replies (18)

I have this problem when using the flathub firefox; I also deleted the flathub and installed the binary directly from mozilla and it still had this problem.

Rolling back (`sudo snap rollback firefox; firefox --allow-downgrade`) has let me keep working for now.

Bug reports have been filed about Helvetica fonts affecting Windows users. Try installing them on your computer.

Note that the Snap version has restrictions on what folder can be accessed, so you may not have read permission for its installation folder.

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Regardless, the font was (and still is is) working on 111.

Upgrade to 112, the font breaks. Downgrade to 111, the font works.

Open inspector, Helvetica is being used. Other fonts earlier in the font-family declaration are not used because they are not installed. Helvetica gets used, but no glyphs are rendered.

If this were merely a question of a fallback font being displayed I may have never noticed, but the text is not displayed _at all_.

You dd check under the Fonts tab in the right panel in the Inspector ?

Does it work if you force a different font ?

Attached screenshots. Definitely works with `font-family: system`.

Tried running firefox from the CLI, but very little was logged. Set --MOZ_LOG_FILE but it just created a bunch of empty files; I think I need --MOZ_LOG as well, but I'm not sure which modules should be enabled to investigate this.

Tried `firefox --MOZ_LOG_FILE=/home/daniel/projects/radiopaedia/new3.log --MOZ_LOG=fontInfoLog:5`, but still nothing in the logs.

This is kinda a huge problem. Helvetica is not exactly an obscure font. How did they possibly let this get out the door? Install on Linux, visit Facebook, see no text. It's not hard to dupe.

(But is it true on all Linux or just certain Linuxes? That's a good question.)

Just double checked to make sure it wasn't specific to wayland and it isn't. It's true on wayland and xorg.

Well, this is an untenable situation. Just downgraded firefox to the extended support release that is in Debian stable, and I'm gonna forget about current firefox for now. Very disappointing.

Ed Heil said

This is kinda a huge problem. Helvetica is not exactly an obscure font. How did they possibly let this get out the door? Install on Linux, visit Facebook, see no text. It's not hard to dupe. (But is it true on all Linux or just certain Linuxes? That's a good question.)

No problem on my Linux system.

Is your firefox running via snap? Or some other distribution method?

I strongly suspect the interaction between snap confinement and the changes to font loading, in which case your kernel version & snapd version are relevant.

As I noted in my first message in the thread, "I have this problem when using the flathub firefox; I also deleted the flathub and installed the binary directly from mozilla and it still had this problem."

I don't use snap.

I am also having this problem. I am using the Firefox flatpak on a Debian Bookworm nightly install. I tried running from the binary and the problem existed there, too. Right now my only solution is leaving my settings tab open and toggling "Allow pages to choose their own fonts..." as needed.

Bug filed here: https://bugzilla.mozilla.org/show_bug.cgi?id=1827950

The nightly build linked in that thread appears to fix the issue on my end.

Note that Firefox 112.0.2 has been released to address this issue.

Fixes an issue where Linux users with bitmap fonts installed may have had entire sections of text invisible to them on some sites (bug 1827950).