Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Prevent websites to use dark theme

  • 1 பதிலளி
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 1 view
  • Last reply by Terry

Hello,

I know this question is probably somewhere here but I can't find the answer (what I tried below).

So, I have a Debian 10 computer, with Firefox 78.15.0esr. I'm using the Adwaita (dark version) theme on my OS.

The problem is that Firefox uses the dark theme in Its menus (I don't mind) but It transmits to websites this setting and thus, websites supporting dark mode use it (Google, DuckDuckGo for example). I don't like that. I want them to use the light mode but keeping my theme on my OS.

So, I tried to change the value to 0, 1, 2, 3 (I tried each for them) for the setting layout.css.prefers-color-scheme.content-override and put "Adwaita:light" in the widget.content.gtk-theme-override field in about:config. Each time I restarted Firefox. It never works, websites still continue to use the dark theme...

Thanks in advance

Hello, I know this question is probably somewhere here but I can't find the answer (what I tried below). So, I have a '''Debian 10''' computer, with '''Firefox 78.15.0esr'''. I'm using the Adwaita (dark version) theme on my OS. The problem is that Firefox uses the dark theme in Its menus (I don't mind) but It transmits to websites this setting and thus, websites supporting dark mode use it (Google, DuckDuckGo for example). I don't like that. I want them to use the light mode but keeping my theme on my OS. So, I tried to change the value to 0, 1, 2, 3 (I tried each for them) for the setting layout.css.prefers-color-scheme.content-override and put "Adwaita:light" in the widget.content.gtk-theme-override field in about:config. Each time I restarted Firefox. It never works, websites still continue to use the dark theme... Thanks in advance

All Replies (1)

Look at Web site appearance on the General page of Settings. I haven't been affected but many users are reporting issues.

https://support.mozilla.org/en-US/kb/change-web-appearance-settings-firefox

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.