Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Bookmarks double spaced

  • 39 பதிலளிப்புகள்
  • 9 இந்த பிரச்னைகள் உள்ளது
  • 312 views
  • Last reply by Chris Ilias

Not sure why the bookmarks was changed to double spaced, but I do not like it at all. Please post a work around to make the bookmarks single spaced. I was able to change how they are spaced in the bookmarks bar, but not the rest of the bookmarks that are at the top of the page under the favorites icon.

Not sure why the bookmarks was changed to double spaced, but I do not like it at all. Please post a work around to make the bookmarks single spaced. I was able to change how they are spaced in the bookmarks bar, but not the rest of the bookmarks that are at the top of the page under the favorites icon.

All Replies (20)

I can give you a quick short-term workaround, but a more durable solution requires a bit more work.

Temporary Fix -- Firefox 89-90 ONLY

For testing purposes, the developers left a preference in Firefox 89 to switch between new style and old style menus:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.contextmenus.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

Some menus may be cut off or sized incorrectly after this change until the next time you do a normal exit/restart of Firefox.

Longer Term Community Workaround

This involves setting up a userChrome.css file. The full instructions are in the following thread: https://support.mozilla.org/questions/1337841

jscher2000 - Support Volunteer மூலமாக திருத்தப்பட்டது

I am not talented enough to do the longer term and the short term only works for the bookmarks in the Bookmarks Bar and does not work for the Bookmarks under the favorites icon. Please give people like me something simple to make the change.

You can add code to the userChrome.css file below the default @namespace line. Not that you can increase the 0px to 2px to have some extra space.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

*|*:root {--arrowpanel-menuitem-padding: 0px 8px !important;}

menupopup :is(menu, menuitem) {padding-block: 0px 0px !important;}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

cor-el மூலமாக திருத்தப்பட்டது

OK, I will give it a try later.

Please do consider making the bookmarks the way they were.

Seems that I have got it. Did not work at first until I saw the above: toolkit.legacyUserProfileCustomizations.stylesheets = true When I did that the favorites menu went to single space. One problem, now the bookmarks toolbar bookmarks are double spaced. If I go back and make toolkit.legacyUserProfileCustomizations.stylesheets true then the toolbar menu is single spaced and the Favorites are double spaced.

chzuck மூலமாக திருத்தப்பட்டது

You can add this rule to set this arrowpanel-menuitem variable. If you want more space then increase the first 0px value (e.g. 2px 8px !important;)

*|*:root {--arrowpanel-menuitem-padding: 0px 8px !important;}

menupopup :is(menu,menuitem) {
  padding-block: 0px 0px!important;
}

Can you attach a screenshot to show the double spacing on the Bookmarks Toolbar ?

So the upgrade to Firefox 91 brings back the double spaced bookmarks and you now can't get round it with config. You would think that Firefox would have enough sense to keep the bookmark experience the same as all other browsers. It seems not. Given the recent reports about 50 million users stopping using Firefox in the last 12 months I wonder how many users this draconian step will loose. My bookmarks are now unusable due to the amount of scrolling involved. I have been with Firefox for a long time but if this stays then it is a step too far. Mozilla needs to urgently release a fix to this disaster.

I agree. The double spacing everywhere is so annoying. Lately I've found myself using Chrome more & more due to all the irritations in the latest Firefox versions. Now the about:config fix doesn't work.

The reason I don't use browsers other than Firefox is that their UIs are horrible, designers forcing changes on users and not giving power users any option to customize. I'd really hate to start searching for yet another new browser after ears of relative happiness with Firefox.

rw330i said

I agree. The double spacing everywhere is so annoying. Lately I've found myself using Chrome more & more due to all the irritations in the latest Firefox versions. Now the about:config fix doesn't work.

Well, I don't trust the prying eyes of chrome and try not to use their products. I rotate between Firefox, Vivaldi, Brave, and Waterfox on my 3 PCs.

njdev said

The reason I don't use browsers other than Firefox is that their UIs are horrible, designers forcing changes on users and not giving power users any option to customize. I'd really hate to start searching for yet another new browser after ears of relative happiness with Firefox.

Yes, Firefox has been a good browser for me. Sometimes they just do irritating things of which I have no choice. I do not like MS or Google products, too much spying! Not that the others don't mine my data too.

It's a long thread, so if anyone is looking for a more "step-by-step" explanation of the userChrome.css workaround, see:

https://support.mozilla.org/questions/1337841

In the code there, 4px represents 4 pixels of space above and below each item. For even less spacing, try 2px instead of 4px. (Ignore the 8px, that is for left-side and right-side spacing, not vertical.)

This is all well and good but Mozilla should be putting out usable browser updates rather than relying on users having to find a way round the distasters that they release. Do they not test new releases and seek opinions before setting them loose in the wild?

johnh1104 said

This is all well and good but Mozilla should be putting out usable browser updates rather than relying on users having to find a way round the distasters that they release. Do they not test new releases and seek opinions before setting them loose in the wild?

I heartily agree. I for one do not feel I am savvy enough to do the work around. Firefox, don't change just for changes sake!

This is awful. Not only is it a huge inconvenience, there appears no interest in FF to fix the issue or at lease give you some options in the 'Settings' area.

The color codes are all messed up too. Now the light is white for the menu bar, tabs area, search bar etc, Before some areas used to be light grey so it wasn't a hard to read white board.

Also there is no way it seems to contact these people. No email or chatting. This had to be the worst customer experience going.

jgm4661 மூலமாக திருத்தப்பட்டது

jgm4661 said

The color codes are all messed up too. Now the light is white for the menu bar, tabs area, search bar etc, Before some areas used to be light grey so it wasn't a hard to read white board.

On Windows 10, it still looks like white on gray, but the gray isn't very dark. Are you on Windows or Mac? There are some issues on MacOS with the new High Contrast theme support.

So is there a commercial or technical reason as to why they are keep repeating this cr.... unpleasantness? Not sure why but none of the previous worked solutions (short term or not) seem to work this time around.

The devs are cleaning up the code and remove a lot of pre-proton code and this make that the proton prefs either no longer work or act weirdly.

You will now have to use CSS code in userChrome.css to style the user interface.

  1. 1
  2. 2