Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Message always pops up in WIN 10 saying Mozilla Firefox is not is not my default browser even though it is.

  • 2 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 51 views
  • Last reply by frankh184

Message always pops up in WIN 10 saying Mozilla Firefox is not is not my default browser even though it is. I have decided to use Firefox over Edge as my default browser in Win 10 but every time I start Firefox a message pops up saying Firefox is not my default browser. I have gone to the next screen and confirm that it is. but each time I open and close Firefox the message reappears! I have gone on internet and tried all the solutions suggested like reinstalling, going into default apps through control panel, through the CMD prompt, etc and still no fix seems to work. The message is annoying to no end as each time I start Firefox I have to click through two extra screens to start using it. I have no problem with Chrome but I prefer Firefox because certain sites don't work well with Chrome for some reason and Firefox works well but this is getting annoying switching between apps or clicking these extra keys. I noticed a lot of people are having the same issue with WIN 10. I have no problems on my Win 7 computer but I am thinking of upgrading it and of course it will come with Win 10 so I want to solve this problem if I can now. Any new "fix" since last I checked? I have tried all so far suggested online with no success. I do note it is a it is a WIN 10 and Firefox problem. Is there anyone from MS or Mozilla that can help?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

The easiest, but perhaps not the more ideal, option I can think of is to disable the Always check if Firefox is your default browser option in the Firefox settings. It would stop the popup from displaying when you start Firefox, but it would no longer alert you if your default changed.

If you do want fix the problem, there are two things I can think of that might help you fix the problem. One is a little more difficult than the other.

I think the issue is with the way that Firefox handles multiple installations of the program. Essentially, each Firefox installation is given a unique ID number on your computer. So hypothetically, you could have two copies of Firefox installed on your computer without issues and each one could be displayed in the default apps page. My guess is that Windows 10 is showing you the generic Firefox option instead of the Firefox option that has the ID attached to it. I probably did a terrible job of explaining it, but the steps below might be able to fix the problem.

Right click on your Windows desktop and select New > Shortcut. For the location, enter https://mozilla.org and select Next. Name it whatever you want and then select Finish.

Go into Firefox and enter about:support in the address bar. Make note of the ending of the text in the Profile Folder row. You might need that later.

Now, close Firefox completely and then double click that shortcut you created. Does the popup show up?

I assume that it will not popup to tell you it's not the default. However, my guess is that you will also find that your bookmarks and other data isn't there.

If that's the case, enter about:profiles in the Firefox address bar. One of the profile names there should match what was at the end of your Profile Folder text. Press the Set as default button under that profile.

Then close Firefox and double click that shortcut we created again. This time, I'm hoping that the default message will not appear and you will have your bookmarks and stuff back again. If that's the case, you can close Firefox, delete that shortcut and then open Firefox the way that you normally do.

Hope that fixes the issue. If not, I can try and post steps for the slightly more difficult way to fix it.

Read this answer in context 👍 1

All Replies (2)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

The easiest, but perhaps not the more ideal, option I can think of is to disable the Always check if Firefox is your default browser option in the Firefox settings. It would stop the popup from displaying when you start Firefox, but it would no longer alert you if your default changed.

If you do want fix the problem, there are two things I can think of that might help you fix the problem. One is a little more difficult than the other.

I think the issue is with the way that Firefox handles multiple installations of the program. Essentially, each Firefox installation is given a unique ID number on your computer. So hypothetically, you could have two copies of Firefox installed on your computer without issues and each one could be displayed in the default apps page. My guess is that Windows 10 is showing you the generic Firefox option instead of the Firefox option that has the ID attached to it. I probably did a terrible job of explaining it, but the steps below might be able to fix the problem.

Right click on your Windows desktop and select New > Shortcut. For the location, enter https://mozilla.org and select Next. Name it whatever you want and then select Finish.

Go into Firefox and enter about:support in the address bar. Make note of the ending of the text in the Profile Folder row. You might need that later.

Now, close Firefox completely and then double click that shortcut you created. Does the popup show up?

I assume that it will not popup to tell you it's not the default. However, my guess is that you will also find that your bookmarks and other data isn't there.

If that's the case, enter about:profiles in the Firefox address bar. One of the profile names there should match what was at the end of your Profile Folder text. Press the Set as default button under that profile.

Then close Firefox and double click that shortcut we created again. This time, I'm hoping that the default message will not appear and you will have your bookmarks and stuff back again. If that's the case, you can close Firefox, delete that shortcut and then open Firefox the way that you normally do.

Hope that fixes the issue. If not, I can try and post steps for the slightly more difficult way to fix it.

Helpful?

Thank you Wesley for taking the time to respond to my question. I was going to try what you suggested. but did not need to at this time. Let me explain: Before I asked this question here, I had installed an upgrade to Firefox about two weeks before. I think that is when the problem was still persisting for a few upgrades back and I was frustrated that it was persisting after multiple upgrades. After all it has been that way even after unchecking "the check if Firefox is your default browser" So I decided to post my question.

Then soon after I did, yesterday, I received another update and Upon installing it I thought Finally the problem was solved but nope the popup still appeared after starting the machine. The difference was that at least as I could now click the do not check box and it would comply. However I knew the problem was still there.

Then I received your suggestion in my email today, Thank-you, and you mentioned the idea that Windows may save multiple versions of the program with and without ID and it prompted me to check programs installed. I noticed several versions installed and proceeded to uninstall them. After I did that Firefox asked if I wanted to refresh it so I did! I think it solved the problem. I turned off and turned on my computer several times and started Firefox and the error message does not pop up anymore. I checked "options" and the check if Firefox is default IS checked and it says Firefox IS my default browser now! Thanks for explaining about the multi installations and ID. I had notice them before but I inadvertently uninstalled the "Mozilla Maintenance" as well. I think when I deleted the multiple installs and kept the maintenance module this time with the latest version and refreshed it, it finally corrected the problem.

Previous to all this I assumed with each upgrade Firefox would "automatically uninstall the previous version" like other programs do, but when you told me that multiple versions could remain with Firefox, I finally was able to resolve this issue. Thanks again for answering my question. Have a Great Day! In the future I will check to see I have only one version. Frank  : )))

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.