Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 77.0.1 address bar seem broken. Won't show common sites without deleting anything in the URL bar, no down arrow

  • 17 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 36 views
  • Last reply by jscher2000

I had set the about:config settings after 75 came out to fix the address bar. Today I got 77.0.1 and now the address bar seems broken again. When I mouse over it, there is no longer a down arrow to click and show my common sites. If I click in the bar and then delete everything, the list of common sites appears. If I click away and click back into the blank address bar, now I have to hit the down arrow to get the list to appear. I need a way to get the down arrow back so the address bar works as expected.

These config options are all set to false:

   browser.urlbar.openViewOnFocus
   browser.urlbar.update1
   browser.urlbar.update1.interventions
   browser.urlbar.update1.searchTips
   browser.urlbar.update1.view.stripHttps

All Replies (17)

Hello jake, These steps can enable your adress bar dropdown

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.openViewOnFocus preference to switch the value from true to false

Hope this is helpful for you.

Helpful?

browser.urlbar.openViewOnFocus was set to false after the problems with the address bar that were introduced in 75. It no longer works.

Helpful?

Hi jake-firefox,

In order to use your adress bar like before, you need to set these values to true:-

browser.urlbar.openViewOnFocus browser.urlbar.update1 browser.urlbar.update1.interventions browser.urlbar.update1.searchTips

If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

Helpful?

You've already checked your add-ons and some settings (good thinking  ! ), but still : Try this one to fix it. Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled. If Firefox is not running, you can start Firefox in Safe Mode as follows:

On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut. On Mac: Hold the option key while starting Firefox. On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35 If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem. Please follow the steps in it https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Thank you

Himanshu prabhakar மூலமாக திருத்தப்பட்டது

Helpful?

Okay some good news, setting all of there to true makes it show the common site without having to delete the address bar first. But, now I've got to search options at the top of the list, one for Search with Google and one for Search with Amazon, 2 companies that I definitely don't want to search with. Plus, there's 2 less common sites in the list because of these search entries.

Safe mode does the same.

Helpful?

The above was supposed to list the options I switched to true: browser.urlbar.openViewOnFocus browser.urlbar.update1 browser.urlbar.update1.interventions browser.urlbar.update1.searchTips

I set search tips back to false but it didn't get rid of the 2 search with entries.

Helpful?

You can change search engine by typing about:preferences#search and press enter.

Then, in default search engine option you can change your default search engine. I hope that's what you are looking for. If it's not, Do Reply..... Thank you.

Helpful?

Thanks again for the quick reply. I have already changed my default search engine to duckduckgo. I have no idea why google and amazon would appear in the top of the list of common sites. I click the address bar, my common sites show, with the 2 search entries at the top with neither being my default search. With the strange behavior of the address bar since 75, I'm not able to screenshot the issue.

Helpful?

Can you please send screenshot of that??

Helpful?

By this you can remove those from top sites list.

Hover on top sites and then click on three dots. You will find a popup menu, select Dismiss option.

Hope it helps. Thanks.

Helpful?

No way to screenshot the issue. As soon as I click anything, that box that pops out on the new address bar goes away and does not appear in the screenshot.

When I hover over the address bar, the only 3 dots are labels Page Actions and none of the options are Dismiss. If I right click on one of the search options, nothing happens.

I would really appreciate getting the old address bar back. Ever since 75 I have to about:config all these settings across all the browsers I use. I can't see any benefit to the address bar changes.

Helpful?

Hi jake-firefox, in Firefox 75+, the automatically opened list is your first 8 Top Sites from the Firefox Home / new tab page. You can curate that list on the new tab page, but not from the drop-down itself.

More info: Customize the New Tab page

Helpful?

Not looking to curate the list, just want firefox to stop adding the 2 search items at the top of the list. I don't see any way to remove those on the new tab page.

Helpful?

Oh, sorry if this wasn't covered in the article I linked. Hover your mouse over each unwanted tile and a little icon should appear in the upper right corner. Click that and choose either Unpin (it may stay in the list) or Dismiss (to ban it from the list). Shashank Shekhar posted a screenshot of that in this reply:

https://support.mozilla.org/questions/1289888#answer-1320242

Helpful?

Thanks again, but the 2 items did not appear on the new page tab so there was no way to remove them with that method. But, today they no longer appear. I'm still on 77.0.1 and not sure what happened. Now if I click in the address bar my top sites appear in the drop down. My issue appears to be resolved. Thanks to all who offered assistance.

Helpful?

Well this is now a problem AGAIN. Last update must have put the 2 search options at the top of my frequent sites in the address bar drop down. I've got "search with google" at the top of the list and google is NOT my preferred search in firefox. And then there is "search with amazon", the 2nd entry. This of course knocks 2 of my regularly visited sites out of the list and is incredibly annoying. And of course, due to the way to new address bar works, it is impossible to screenshot. If we could get the old address bar back, it would be a lot better. None of the new changes seem to offer any benefits.

Helpful?

Hi jake-firefox, as you recall from Firefox 75, the list that drops from the address bar automatically when you click in it shows your first 8 Top Sites from the Firefox Home/new tab page. The older changes are largely obsolete now, so here are the new options:

I. Prevent the List Dropping Automatically

The name of the browser.urlbar.openViewOnFocus preference changed in Firefox 78 to browser.urlbar.suggest.topsites, and you now can toggle that off using a checkbox on the Options/Preferences page:

II. Changing the Automatic List from New Tab Page Top Sites to Frequently Visited URLs

Unfortunately, turning off the Top Sites section of the Firefox Home / new tab page no longer does this. To summon the old list, you can type a space in the address bar instead.

You also can make the Top Sites list more useful to you by taking control of its contents. Either:

(A) Remove the pre-pinned and default items so Firefox fills it from your own history

(B) Replace the pre-pinned and default items with your own selection of items (this may be easier after Firefox has filled in sites from history than adding them all from scratch)

More info in this article: Customize the New Tab page

If you previously turned off the Top Sites section, you'll need to turn that back on: Hide or display content in New Tab

You may want to add at least one more row of Top Sites to the page in preparation for a change in Firefox 79 that will expand the list beyond 8 rows.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.