Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After update to Firefox 73, browser no longer loads pages

  • 10 பதிலளிப்புகள்
  • 4 இந்த பிரச்னைகள் உள்ளது
  • 1317 views
  • Last reply by veescott

After updating to Firefox 73 (running on Windows 7), no pages will load. Saved tabs have a blank URL bar, opening a new tab and putting in a URL does nothing, no built-in pages (such as the various about: pages, options page, etc.) work, nothing. All basic troubleshooting (including refreshing, reinstallation, and so on) completed with no change.

(Do not trust generated system details on this question - posting from another computer.)

PyroDesu மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Okay, figured out what was going on. I think.

The update had automatically turned on compatibility mode for Windows 7. Which would make sense, if it weren't broken. Turn off compatibility mode, and it's working again.

Read this answer in context 👍 1

All Replies (10)

hello, at https://old.reddit.com/r/firefox/comments/f2d5cu/nothing_will_load/ affected users said a similar problem was caused with custom exploit protection rules for firefox under windows 10 or running the browser in compatibility mode...

No custom exploit protection rules, and not running on Windows 10 or in compatibility mode (that I know of).

You posted with Firefox 65 on Windows 10 according to the user agent:

  • Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

If you used the same computer as the one that has this problem then it is likely that you run the Firefox 73 version in compatibility mode for Windows 7.

Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

As noted in the original post, the generated system details are inaccurate as the post was made from a different machine (one, notably, with a functional copy of Firefox). The machine with the issue is running Windows 7 Ultimate, freshly updated to Firefox 73.

I have the exact same issue. Firefox 73 on Windows 7 Professional. If I try other browsers all webpages load normally. Also, I uninstalled Firefox and installed an older version (67.0). this fixed the issue. But on the next firefox restart the new version 73 installed and the problem reappeared. Login with othe account didn't fix the issue.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Okay, figured out what was going on. I think.

The update had automatically turned on compatibility mode for Windows 7. Which would make sense, if it weren't broken. Turn off compatibility mode, and it's working again.

Well, this didn't work for me. Compatibility mode is not enabled and pages won't load. Even if I enable and disable it again it doesn't work.

@dassan76 - if your problem is different, can you please file a new question for it: https://support.mozilla.org/en-US/questions/new thank you!

That fixed it for me. Unticking compatibility mode. I'm using Windows 10 64bit

robinrobin மூலமாக திருத்தப்பட்டது

I have the same problem as dassan76. I'm using Windows 10 and after updating to Firefox 73, the pages won't load. They won't load under Safe Mode, they won't load after I check and uncheck the compatibility mode.