Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Blocked by X-Frame-Options Policy

  • 24 பதிலளிப்புகள்
  • 16 இந்த பிரச்னைகள் உள்ளது
  • 2151 views
  • Last reply by kris.sor

After Firefox updated, I can no longer access www.apple.com. This is the error I get now:

Blocked by X-Frame-Options Policy

An error occurred during a connection to idmsa.apple.com.

Firefox prevented this page from loading in this context because the page has an X-Frame-Options policy that disallows it.

Can anyone tell me how to fix this issue as soon as possible. Thank You.

All Replies (20)

When I run Firefox from the Default User (has nothing installed- just plain), I have no issues. When I run Firefox from my user account with all the Extensions disabled, I still get the problem. See attached screen shot. I hope someone will be able to help me with this issue. Thank You.

I am experiencing the same issue when I go to:

https://srfonlinemeditation.org/calendar/

And then login to teamup.com via the embedded calendar.

When I restart with add-ons disabled and log out of my Firefox account this makes no difference. The error message that I get inside the frame of the normally embedded calendar is:

Blocked by X-Frame-Options Policy

An error occurred during a connection to teamup.com.

Firefox prevented this page from loading in this context because the page has an X-Frame-Options policy that disallows it.

I tried disabling cookies for srfonlinemeditation.org and teamup.com. This made no difference after refreshing the page.

When I went to https://srfonlinemeditation.org/calendar/

I could see the embedded calendar and am logged in to teamup.com in the embedded calendar.

Blocked by X-Frame-Options Policy

An error occurred during a connection to accounts.google.com.

Firefox prevented this page from loading in this context because the page has an X-Frame-Options policy that disallows it.

Blocked by X-Frame-Options Policy

This policy is preventing me from getting into some of my payment systems like: coinpayments or coinbase and http://clickhere2join.com/h03

And my Business Links: https://orutv.tv//# Blocked by X-Frame-Options Policy An error occurred during a connection to orutv.tv. Firefox prevented this page from loading in this context because the page has an X-Frame-Options policy that disallows it.


I NEED to get into these websites, Please Help Me Get Rid of this Block!

2dianareed மூலமாக திருத்தப்பட்டது

This happens if a web page tries to open an external link in an iframe and this website doesn't allows to be opened that way. You can try to right-click in the iframe area and use "This Frame: Open Frame in New Tab" to see if that gives you the page.

to simple questions , try simple answer please .Where is the iframe mentionned ? until yesterday , no problems , whatever site I browsed . From early today , every second pages search send me that ennoying answer , and it can't be just a server going crazy ...We also cannot have to do that right-click constantly ! If you do not want stupid non litterate like me go back to IE or similar , please fix that bug .

regards

Can Firefox, resolve this issue, without getting any late.

Thanks,

See this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1593321

- - - - - - - - - - - - -

For now you could give this add-on a try :

https://addons.mozilla.org/en-US/firefox/addon/ignore-x-frame-options-header/

This message should only appear when the owner of the embedded page instructs browsers not to let it be embedded. You can understand why high security sites like financial services and payment services want to exercise control over the other sites that embed their content. I suggest a cautious approach to this issue.

If the problem is an embedded page that redirects to a login page, try opening a new tab and signing in on that other site directly, then returning to the page with the frame and reloading it. And if you have time, let both sites know about the problem.

Con la última actualización me bloquea y no me deja subir fotos a blogger, ojala y lo arreglen o tendré que desinstalar firefox, después de que llevo usándolo antes siquiera de que se llamara firefox.

Hi benjaminmatas

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

As a Firefox user for many years, all of a sudden after logging into my hospital's web site in order to make a lab appointment for blood tests, I am getting this message:

An error occurred during a connection to mychart.eisenhowerhealth.org.

Firefox prevented this page from loading in this context because the page has an X-Frame-Options policy that disallows it.


I came to this Firefox support site and find only third party recommended fixes, none of which make me feel comfortable to load. What is Firefox doing to fix this problem so its users can use Firefox? This time I had to load Microsoft Edge in order to make my appointment and that is unacceptable.

When I'm accessing to music.apple.com trying to sign in it's not allowing what the hell, now i have to use chrome for that what's wrong with you mozilla. what is this new x frame option bug. please resolve it otherwise people will stick to chrome

I have this problem on support.getmailbird.com

Darryl said

I have this problem on support.getmailbird.com

Hello Darryl,

See my last comment in   this bug report

Experienced this issue with Fox News (video embedded in https://www.foxnews.com/politics/gop-sues-california-newsom-vote-by-mail-order-illegal-power-grab-claim). Opened a Chrome browser window, pasted the URL in a new tab and viewed the video with no issues. To me, it's an undesirable solution, but it worked. Mozilla needs to get their problem fixed soon or people will be leaving them.

Hi folks, I'm a Firefox engineer and we're actively looking into this issue, but unfortunately we're having trouble reproducing almost all of the reported breakages. We need more information and want to ask for your help.

We have prepared a few detailed questions, feel free to post answers here or send them to me privately via email (jhofmann at mozilla dot com).

  • What page(s) are you visiting when encountering the problem?
  • Is this issue permanently reproducible for you? i.e. if you reload the page and try it a few times, does it always happen?
  • Does this issue reproduce on a clean profile (you can find instructions on how to create a new temporary profile here)?
  • Can you please send us your about:support information (go to about:support and click "Copy raw data to clipboard")? Particularly, it is interesting to us which extensions you have installed and how your tracking protections are set up.

This would help us a lot in tracking this down!

Thank you!

Johann Hofmann மூலமாக திருத்தப்பட்டது

@ Johann Hofmann,

Thank you in advance for anything you can do !

To all :

See the last few comments from Christoph Kerschbaumer in this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1593321

Same problem for a user on our club's website. This is a Wordpress site and the calendar is embedded with the copied code from the Google calendar's settingspage. He uses a plain vanilla FF (latest version) 64bit Win10 NL.

Error: Geblokkeerd door beleid voor X-Frame-Options

Fout tijdens het verbinden met accounts.google.com.

Firefox heeft voorkomen dat de pagina in deze context werd geladen, omdat de pagina een beleid voor X-Frame-Options heeft dat dit niet toestaat.

I remotely installed the ignore-x-frame-options-header add-on and added on6wl.be google.com and calendar.google.com but error remains. Starting Firefox in "safe mode" has no effect.

He's the only Firefox user with this problem and I can't reproduce on any of the systems I have access to (Windows/Android/Apple). He has the problem on both his laptops with Win10. He reported this problem a few weeks ago so it's not only the most recent FF that's affected, it must be at least 2 or 3 versions ago since this started.

  1. 1
  2. 2