Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Plugin Container for Firefox is freezing my Facebook session - why?

  • 8 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by GregMachart

I log in to Facebook and then run a game called Throne Rush. When I am done there and try to go back to FB, the FB screen freezes. I then run Task Manager and there is a sub-process under Firefox(7) and it says "Plugin Container for Firefox". Once I delete that, the FB screen goes back to normal. If have re-installed Firefox with and without the plugins enabled and it doesn't make a difference. I am using the latest version of Firefox - version 62. I don't know what changed but this just started yesterday. Thanks

All Replies (8)

Hi, Since the information you shared is inaccurate, please list the actually Extensions that were running at the time of the issue. Example :

SO which one where you using ???

What others ?? What Security Software ?

When I click on the details in the task manager for that line - it says it is plugin-container.exe. I don't know its path, is there a way to find that? I use Webroot and it is at Attached is screen print of the other plugins I use. Thanks

Hi, those are add-ons, I asked about Extensions. Yes can see that you use Webroot. It is not running and it is no longer supported by Firefox. Some issues regarding it.

You said you used a container. I need to know which one. You have said this is running in Task Manager : plugin-container.exe

Please Click on it in Task Manager Then Right Click and look at it's Properties, Also Right Click it and Open File Location.

Forget about the above please :

Please do a Refresh : but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:


The OP is referring to Plugin Container which is used with Plugins and not Extensions. The Plugin container has existed with Firefox since 3.6.4

btw Addons or Add-ons is a general term that groups together the separate Extensions, Themes (image and complete), Plugins, search engines, dictionaries, language packs. Really wish Mozilla just kept things separate and simple.

Took all the steps - did a refresh and Facebook does not fill and my Firefox session locks up. Any tab that I would have had going in Firefox will be locked up too. Again, this is something that just started happening yesterday so one of the pieces of software in this puzzle must have changed. Attached is a screen print showing what little bit of Facebook shows up when I come out of the game. Thanks for trying. I love Firefox but I may need to use another browser if this is not resolved. Thanks

Thank You James. So plugin-container.exe am taking it is related to you playing a Flash Game Am wondering why it is that and not in a Processes.

Please uninstall Flash with this :

Then Reinstall with Flash Player Version: Current Version Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Make sure when you reinstall that it is set to Ask to Allow.

When finished also please turn off Hardware Acceleration

Restart Firefox and give Facebook a try.

If still issues as this is a older system please move to ESR but please do the other things below 1st :

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

I just downloaded Chrome and it works fine as does Microsoft Edge. It appears to be something that changed in Facebook and/or its games that Firefox can't handle.

I have been busy but will let you know what happened and what is happening now. I took Flash off of this laptop and re-installed it. I went into Facebook and ran my game. I then went back to Facebook and it worked fine. So I went back to your instructions above and saw that when installing Flash I should have selected "Ask to Allow", which I didn't so I went back in and removed Flash again, re-installed it selecting the "Ask to Allow" option. Went back in to FB and my game and ever since then - it works about 20% of the time so I still have to have Task Manager running all the time to kill that sub-process when it doesn't work. During the weekend I was using my Desktop PC with an older version of Windows and everything worked fine. I also used another PC with Windows 10 and it worked fine. So there must be a piece of software or a setting on this laptop that does not allow that plugin container to work correctly all of the time. If I have time later I will try some of the other things mentioned above but for now - I will limp along I guess...