Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox webcam permissions for websites not working

  • 6 பதிலளிப்புகள்
  • 11 இந்த பிரச்னைகள் உள்ளது
  • 8 views
  • Last reply by seriousgeek

I'm trying to grant webcam access permanently for a website, so that each time the page is accessed, it does not show up the popup to grant access to webcam. I use the Permissions page accessed using Ctlr+I and changed the Webcam access to allow, but this change is not working as Firefox still asks me for webcam access each time the page is loaded. Could you please help in fixing this problem?

I'm trying to grant webcam access permanently for a website, so that each time the page is accessed, it does not show up the popup to grant access to webcam. I use the Permissions page accessed using Ctlr+I and changed the Webcam access to allow, but this change is not working as Firefox still asks me for webcam access each time the page is loaded. Could you please help in fixing this problem?

All Replies (6)

hi seriousgeek, firefox will only allow permanent camera permissions for websites which are loaded through https. https://blog.mozilla.org/security/2015/04/30/deprecating-non-secure-http/

Thanks for your reply philipp. My web application is secured by https. It works well with Chrome where it does not repeatedly ask for webcam access. Does it not work with self signed certificates in Firefox?

seriousgeek மூலமாக திருத்தப்பட்டது

hm, i don't know that much about it but i don't think that self-signed certs should make a difference here - could you test if the permission gets stored for other websites, like this wertc demo page: https://apprtc.appspot.com/ ?

Hey philipp, I have the same problem with the wertc demo page as well. I need to grant access each time even though i have given the website permissions. I'm using Mac OS, in case that helps.

ok thanks. have you set firefox into private browsing mode ("never save history") under the firefox menu ≡ > options > privacy panel or are you clearing site specific-settings there on shutdown?

The Privacy panel says Firefox will remember history, so I guess it should save the site specific settings. After giving the permissions, the site information does show that Webcam has been allowed for that website, even though permission is asked each time.