Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

youtube videos no longer play

  • 3 பதிலளிப்புகள்
  • 90 இந்த பிரச்னைகள் உள்ளது
  • 12721 views
  • Last reply by calvin2a

I recently installed the latest versions of Firefox and of Adobe Flash Player ActiveX.

Now I'm getting the familiar youtube message:

An error occurred, please try again later. Learn More

whenever attempting to view youtube videos in Firefox.

Chrome still works fine.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Re ActiveX, I mentioned that because its update was coincidental with the ceasing of YouTube videos to play.

Clear the cache of the browser and the plugin (right click on the player, select Global Settings and clear storage. Expand the storage for the player. Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. None of that works.

In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox. There is no such checkbox in that location for Firefox v.34, the current version.

Fyi, here's what does work: Disable a Firefox Add-on entitled "YouTube Center 2.1.0" YouTube videos began playing again. Did have a hassle logging into YouTube, what with google requiring use of its proprietary account. So you can marked this "Solved"!-)

Read this answer in context 👍 13

All Replies (3)

Sometimes video can be slow due to internet connection, video player issues and performance issues. In order to find out which one it is, we can try the following:

  • Clear the cache of the browser and the plugin (right click on the player, select Global Settings and clear storage.))
  • Expand the storage for the player.
  • Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

The ActiveX version is for Internet Explorer only. Chrome comes with its own Pepper Flash and uses that by default and is one of the reasons for the frequent Chrome updates.

Also as of today you need to use current supported versions of Flash player as otherwise they will be Click to play.

https://helpx.adobe.com/security/products/flash-player/apsb14-27.html https://www.adobe.com/products/flashplayer/distribution3.html https://addons.mozilla.org/firefox/blocked/p794

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Re ActiveX, I mentioned that because its update was coincidental with the ceasing of YouTube videos to play.

Clear the cache of the browser and the plugin (right click on the player, select Global Settings and clear storage. Expand the storage for the player. Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. None of that works.

In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox. There is no such checkbox in that location for Firefox v.34, the current version.

Fyi, here's what does work: Disable a Firefox Add-on entitled "YouTube Center 2.1.0" YouTube videos began playing again. Did have a hassle logging into YouTube, what with google requiring use of its proprietary account. So you can marked this "Solved"!-)