Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

Autofill stopped working for protonmail

  • 3 svar
  • 0 har detta problem
  • 2 visningar
  • Senaste svar av cor-el

more options

Today the autofill feature for passwords / username stopped working on Protonmail login. Windows 10. Specifically the username option. I have two accounts and formerly could select which account. Now i have to enter the username manually, however the password tab still works for password autofill / selection. This is the only site I am having this issue with.

Today the autofill feature for passwords / username stopped working on Protonmail login. Windows 10. Specifically the username option. I have two accounts and formerly could select which account. Now i have to enter the username manually, however the password tab still works for password autofill / selection. This is the only site I am having this issue with.

Vald lösning

I have experimented and found that having multiple account names / options for autofill (two in this case) was causing the issue. However this has not been an issue prior to today. I am keeping the main account name in use for the time being and have deleted the secondary option until this is rectified.

Läs svaret i sitt sammanhang 👍 0

Alla svar (3)

more options

Vald lösning

I have experimented and found that having multiple account names / options for autofill (two in this case) was causing the issue. However this has not been an issue prior to today. I am keeping the main account name in use for the time being and have deleted the secondary option until this is rectified.

Hjälpsam?

more options

They appear to have made changes to the login form and have replicated the username code in an iframe (https://account-api.proton.me/challenge/v4/html?Type=0&Name=login), so this HTML code appears twice and the username field in the iframe gets focus and isn't recognized by Firefox. The username field in the form is moved out of view. This makes it impossible for Firefox to fill the username in the iframe via the password manager. I don't know if saved form data is able to fill this input field as both fields have the same #username ID and the field is in a iframe. The password field is placed in a normal position in the DOM and is recognized as the password field (i.e.it has "Use Saved Password" in the context menu).

Ändrad av cor-el

Hjälpsam?

more options

Based on your above reply it looks that if there is one login saved that Firefox fills the first (hidden) field with the username and that is acceptable. Since the input field is not visible and can't be focused you won't be able to select a username from the drop-down list.

Hjälpsam?

Ställ en fråga

Du måste logga in på ditt konto för att svara på inlägg. Starta en ny fråga om du ännu inte har ett konto.