Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Latest Java update

  • 119 odpovedí
  • 167 má tento problém
  • 1122 zobrazení
  • Posledná odpoveď od Mr. News

more options

Hi, My Firefox plug-in check is telling me that there is an update for Java, but when I visit the link it's still taking me to the old update (the Java 7 update 9). Also, according to the Java test page, Java 7u9 is still showing that it's the latest...it says I have the recommended version.

Is there an newer update somewhere?


Vybrané riešenie

  • update*

It looks as though the issue has been fixed. When checked my plug-ins this evening, the 7u9 had corrected itself and is now displaying the actual update (7u10).

I've uninstalled the 7u9 completely and everything is checking out on FF! :)

Čítať túto odpoveď v kontexte 👍 9

Všetky odpovede (19)

more options


Java 7 Update 13 is the latest version of Java and fixes a number of security vulnerabilities. If you still have Java 7 Update 9, updating to Java 7 Update 13 should automatically remove that version. if it doesn't and you are getting a Java installation error 1714 then I found:

...which says,

Error 1714 is an Install Shield error code. It indicates that the installation process has failed. 
Please follow the steps below for resolving this issue.

Remove any traces of the failed Java installation by uninstalling Java
Run Microsoft uninstall utility to repair corrupted registry keys that prevents programs from being completely uninstalled or blocking new installations and updates.
Download and install the Windows offline installer package.

For more information on installing java on Windows see: http://kb.mozillazine.org/Java#On_Windows

more options

P.S on fixing Error 1714:

This Oracle Discussion forum thread confirms that the Microsoft uninstall utility linked in my previous reply resolved the problem:

https://forums.oracle.com/forums/thread.jspa?messageID=10259774 Thread: Cannot install Java update or uninstall old version (Java error 1714)

Re: Cannot install Java update or uninstall old version (Java error 1714)
Posted: Apr 18, 2012 8:01 PM 
Hey dude, i had this same problem and i think i've found a fix. Go to this link http://support.microsoft.com/mats/Program_Install_and_Uninstall and download the tool. It should run you through some steps. I followed the steps for having trouble uninstalling and then eventually it gives you the option to choose the application you are having problems with from a list.
Just choose the older java version and it will remove it for you. Check the windows program list and the Java entry should be properly uninstalled and you can then install the latest version of Java. Worked for me - hope it does for you
more options

Hearing about Java 7-13, I uninstalled all previous versions of Java (7-09, 7-10) from my computer (they had been disabled manually in FF), and re-booted. Then installed Java 7-13, no problems, everything looked great, FF plug-in check came up all green. But when I attempt to verify my version on Oracle's Java verification, it can't find it. Nothing blocked, no reason. I tried a re-install, went fine, still same problem. I did note that in the Java Control Panel, in the Java tab, when I view the currently installed JRE (7-13), it is UNchecked (not enabled), and will not allow itself to be checked. So apparently I have Java 7-13, FF sees it and has the plug-in installed properly, but Java will not allow itself to be enabled on my machine.

I've just about had it with Java, after living perfectly without it for the past month or so. I'm thinking of uninstalling it permanently, and just forgetting about it. Waste of time and brainpower trying to get it to work, now that Oracle's screwed it up forever.

UPDATE: Well I solved the problem, sort of. Went to the JRE list in the Java Control Panel, clicked Add, searched for Java apps, found one in an old JRE7 folder in Programs, clicked it and it found 7-13, and added it an another JRE (identical to the one above it), but checked (enabled) this time. Then ran the Java verification again, which floated a pop-up asking me if it was OK to run this app (clicked OK), and voila- it says I now have version 7-13. Wow that was easy-- NOT!!!

Upravil(a) Mr. News dňa

more options

Java Control Panel's "Java" tab is described here:

...and includes this image: Underneath it says,

Click the Find button to launch the JRE Finder. This utility searches for unregistered private Java Runtime Environments installed in your computer and adds them to the Java Runtime Versions panel.

Does your Windows list of installed programs include a JavaFX version by any chance? That can prevent Java from being properly registered. Ref: http://kb.mozillazine.org/Java#Uninstall_JavaFX

(Nice job in finding that workaround, by the way).

more options

Alice, I don't believe I ever had JavaFX, or if I did, I uninstalled it several months ago.

I didn't find any of the Java or FF Help pages helpful for my issue; I think the Java installation was slightly fouled up by the presence of an old Java sub-folder in Program Files. Java 7-13 appeared in the JRE settings (as imaged above), but could not be check-marked. I used the "Add" button, navigated to the Java sub-folders, and it found the correct 7-13 on its own.

Oddly enough, two identical versions then appeared in the JRE settings panel, the second one checked, the first unchecked. I closed the Control Panel, ran the Java Verify applet (it now asked for permission), and it found the correct version now running. But when I re-opened the Java Control Panel, the un-checked listing had vanished, and there was now only one, checked, listing for 7-13.

Such are the mysteries of Java, not to mention Windows. I find it helps in solving many Windows anomalies if one tries to think like a Microsoft programmer, or, alternatively, like a complete psychotic. The solution usually manifests itself like a biblical vision, or, alternatively, like a severe case of indigestion...

more options

Thanks for all the info, but I already tried all of that. I even ran a full virus scan (think there are some things that ended up in the 'virus chest' that might no be viruses).

The Microsoft Install/Uninstall or "Fixit" app had an error, so that was of no help.

I had an "The feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternate path to a folder containing the installation package 'jre 1.7.0_09-c.msi' in the box below. (I'm getting something similar now when iTunes tries to update, then Apple tells me it's the current version?)

I also found when I went to programs under the 'properties' tab in the Java icon, int the Java(TM) Control panel it said 'cannot find the registry key specified: HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environments\1.7.0_11. Not a clue what that means.

I think I'm going to have to pay somebody to figure this out. I am starting to lose my mind. I usually don't have this much trouble uninstalling Java and installing a different/older version when need be.

I haven't given up yet, though, lol.

more options

I also went to the 'Start' button------>My Computer---->C:\---->Program Files--->Java. and found 4 folders there: jre 1.5.0, jre 6, jre 7, and the file i downloaded to update to 7U13 named 'jxpiinstall'.

Maybe that will help figure out how to fix this?

more options

Charity: Yikes, it sounds like you have a lot of loose Java bits rattling around your machine. First, I would make sure there are no Javas listed in Add/Remove Programs... if there are, uninstall them from there. Then, I would delete any files and folders you can find that smack of Java. (It leaves various folders/files behind even after being uninstalled.) Maybe run a search for "Java." Then re-boot, and try installing 7-13 (after re-downloading the offline version). If your Registry is seriously messed up, that may require professional intervention. Keep in mind that Java is not actually necessary for most computer users. I got along fine without it for a couple of months so, if your computer is working OK in all other respects, you might consider abandoning Oracle's monster for the moment. Unless you really need Java for gaming or something else...

more options

Charity5150, you said,

The Microsoft Install/Uninstall or "Fixit" app had an error,

... which would be this: http://support.microsoft.com/mats/Program_Install_and_Uninstall

Since using using that tool is part of the solution to fixing the Java uninstall and install errors you were getting (see http://www.java.com/en/download/help/error_1714.xml and the oracle forum post I referenced before ) I would try again. You should make a note of the exact error message. You can then ask for help at Microsoft: http://support.microsoft.com/gp/install2?&ln=en-us since this isn't actually a Firefox problem but a Java and Windows problem.

more options

Alice and mrnews, thanks for the help. I FINALLY got the FixIt (online) to work. It uninstalled the Java 7u9. I removed folders from the Program files 'Java' folder. Now going to reboot and try to download Java 6U37? I think it was or 7U13. Thanks for all your help. It is GREATLY appreciated. Dang Pogo.com for making me a game addict! Otherwise, I don't think I would ever need Java, lol.

more options

Yes, it's the Java 7u13 package you want. Some have had better success downloading and installing the OFFline version (about 30MB), which then installs from your desktop. I had a very smooth installation with that package, expect for one glitch, the solution to which is detailed above, on this page of this thread. (You may not even have that problem, if you have thoroughly removed all traces of previous Java installations.)

Upravil(a) Mr. News dňa

more options

You can download the Java 7 Update 13 offline installer from http://www.java.com/en/download/windows_offline.jsp

more options

Thank you both so much for all the help. I finally got Java 7U13 installed.....

    but there's a catch.  It only works on Internet Explorer, NOT on Mozilla Firefox. FF still has the add-ons as the old ones even on the Java page. So for now, I'll use Java on IE and see how it goes until I can fix it otherwise. *Sigh* I really don't like IE. Anyway, thanks again for all the help.
more options

Start-->Control Panel-->Java, to open Java Control Panel.

On "Java" tab, click "View" and make sure there is only one version (1.7.0_13) and that there is a checkmark under "Enabled."

On "Advanced" tab, under "Default Java for browsers" make sure both "Microsoft Internet Explorer" AND "Mozilla family" are checked.

Then, go C:-->Program Files-->Java-->jre7-->bin-->plugin (or plugin2), and look for a file called npjp2.dll. If you mouse-over this, it should tell you it's the "Next Generation Java Plug-in 10.13.2 for Mozilla browsers." If there are any other dll files in that folder which indicate they are different versions of Java Plug-in for Mozilla, delete them. Restart FF, and it should now see only the latest Java version.

more options

Went to Java Control Panel...2 versions there 6U38 (I unchecked that one as 'Remove' didn't come up as an option there) and 7U13 (which was enabled.) Microsoft and Mozilla were both checked.

Then, I went to C:--->Program Files--->Java-->jre7--->bin-->plugin2 found the file npjp2.dll "Next Generation Java Plug-in 10.13.2 for Mozilla browsers." Found no other dll files that mentioned java plug-in.

I'll try restarting and see how it goes. Going through all those Microsoft and Oracle Help pages didn't help as much as the Mozilla folks. Thanks again. You guys rock here!

more options

After rebooting the system, if Java still isn't working in Firefox:

Make sure the Java(TM) Platform SE 7 U13 plugin is enabled in the Firefox Add-ons Manager Plugins list. See http://kb.mozillazine.org/Java#Enabling_Java (If that plugin isn't even listed, first try the suggestions under the If the Java plugin does not appear in the Add-ons Manager, even though Java is installed ... heading.)

The problem could be a missing registry entry for the Mozilla plugin, which has been a problem on some systems since java 7 Update 10. See http://kb.mozillazine.org/Java#Windows_installation_issues .... under Add back missing registry key

Upravil(a) AliceWyman dňa

more options

OK......AFter many a trial and error, Java is FINALLY working in FF and pogo once again. Just out of the blue even though it was enabled in the browser and I had restarted FF, etc. Oh well, I'll take it. Thanks again mrnews and Alice for all your help.

more options

Ah, more Java fun and games. I did want to post this in case anyone else finds this is the way to go. What happened to me after the JavaU10 battle was I found, one morning, that there was an Java icon in my task manager tray telling me that there was a new version of Java available. I clicked it and went through the process without ever visiting Java or Oracle and it went through without a hitch...showing up immediately in FF add-ons.

I am windows 7 premium version 32 bit...well this machine is. It *might* be useful to try to update Java from the Java Icon in Windows control panel instead of using browsers...just thought I'd put this up here with this, the "java saga" thread, as something to try.

Good luck all.

more options

Good point, Axis. I found the same notification 2 days ago on my step-mom's netbook (a very old Acer on which I recently installed FF), and had the same experience: trouble-free installation of Java 7_13 (albeit really slow). I think, though, that this notification/installation route is initiated very belatedly by Oracle, and depends on how you have Java configured, or if you even have it installed at all. I had de-activated and then removed it completely from my own machine, so no notification was forthcoming. I did notice that this installation process did warn that it might uninstall Java version 6 completely, and it probably did so.

Upravil(a) Mr. News dňa

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6