Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Javascript opens new empty tab, without the expected content.

  • 7 odpovedí
  • 2 majú tento problém
  • 10 zobrazení
  • Posledná odpoveď od Barmy

more options

Ever since I upgraded to Firefox 5.0, when I click on a link with javascript that I expect will start a download, it opens a new blank tab, and nothing else happens and no error is displayed. Options>Content shows that "Enable Javascript" is checked. Advanced JavaScript Settings has only "Disable or replace context menus" checked.

If I copy the javascript link and use it in IE 8, it works fine.

Ever since I upgraded to Firefox 5.0, when I click on a link with javascript that I expect will start a download, it opens a new blank tab, and nothing else happens and no error is displayed. Options>Content shows that "Enable Javascript" is checked. Advanced JavaScript Settings has only "Disable or replace context menus" checked. If I copy the javascript link and use it in IE 8, it works fine.

Všetky odpovede (7)

more options

Click the orange Firefox button, go to Options | Options | General.

In the menu in the middle, is the option: "Show downloads window when downloading a file" checkmarked?

If it is, could you please give me a link where this problem occurs.

more options

"Show downloads window when downloading a file" is checked. (And, FWIW, the box for "Close it when all downloads are finished" is unchecked, and the button for "Always ask me where to save files" is selected.)

http://esupport.sony.com/US/perl/model-documents.pl?mdl=DCRSR40 This page has a section for downloading manuals and the first link, for "Handycam Handbook" uses the following:

javascript:moreinfowindow('http://www.docs.sony.com/reflib/docget.asp?manualid=83343&template_id=1&region_id=1&DL=',600,560,10,10,'Manuals')

When I click it, a new tab opens to "about:blank", the tab in the tab bar has the circling green "progress" graphic active for a few seconds, and then it stops.

I also tried just using the URL in that link: http://www.docs.sony.com/reflib/docget.asp?manualid=83343&template_id=1&region_id=1&DL= http://www.docs.sony.com/reflib/docget.asp?manualid=83343 But both of these give the same behavior described above.

http://www.docs.sony.com/reflib/docget.asp gives "ERROR: Invalid Document Provided"

http://www.docs.sony.com/reflib brings up a login screen for "authorized users".

more options

Also, FWIW, in my about:config, all Preferences that meet the filter "javascript" are using the default values EXCEPT for pref.advanced.javascript.disable_button.advanced which was apparently "user set" to a boolean value of "false".

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Could you please do the following.

  1. In the location bar where you normally type in a web address, type about:config and hit Enter.

  2. If you see a window which says "This might void your warranty!", click the button which says "I'll be careful, I promise" so you can continue with the next step.

  3. In the filter at the top, copy/paste: extensions.logging.enabled

  4. Double click it to change it from "False" to "True".

  5. Close Firefox and then restart it again.

  6. Click the orange Firefox button, then click Web Developer followed by Error Console.

  7. Click the Clear All button and then close it.

  8. Next, go do what you normally do which produces the error.

  9. Repeat step 6 and then copy the contents of the Error Console into this thread please.


N.B. You cannot do a "Select all" in the Error Console and have copy the contents individually. So you might want to consider copying them to Notepad first and then move them from there. Disable "Word Wrap" first in Notepad's "Format" menu before you copy the contents.

more options

I have tgis exact same symptom, but it occurs when I am logged into my webmail account. Javascript links that are functional such as "delete", "reply", forward" , etc. Do not function. Instead a new tab or window (depending on my settings) opens (about:blank) instead of carrying out the function. Running in safe mode changes nothing.

more options

Following the instructions of Xircal here are the error codes - Warning: Error in parsing value for 'cursor'. Declaration dropped. Source File: http://mail.care2.com/mail/ms_message.asp?MsgID={65DFC366-C4FC-43BE-9F50-6DCF23B39B7B}&SM=F&FolderName=/Inbox Line: 0

Error: Compose is not defined Source File: javascript:Compose('%7B65DFC366%2DC4FC%2D43BE%2D9F50%2D6DCF23B39B7B%7D','reply') Line: 1

Error: QuickReplyToggle is not defined Source File: javascript:QuickReplyToggle() Line: 1

Error: Compose is not defined Source File: javascript:Compose('%7B65DFC366%2DC4FC%2D43BE%2D9F50%2D6DCF23B39B7B%7D','forward') Line: 1

Error: MsgAction is not defined Source File: javascript:MsgAction('%7B65DFC366%2DC4FC%2D43BE%2D9F50%2D6DCF23B39B7B%7D',%20'Delete',%20'/Inbox') Line: 1

My webmail is unusable in Fx6. I can read it but can't reply to anything.