Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Firefox even in safe mode unresponsive to some websites

  • 27 odpovedí
  • 0 má tento problém
  • 977 zobrazení
  • Posledná odpoveď od Paul Kinzelman

more options

I don't know when it started (quite awhile), but when I go to some websites even in FF safe mode, I wait a long time but get nothing displayed and it stops spinning/waiting (the circle arrow upper left stops). Occasionally when I reload, it comes up but usually it doesn't. Other websites it works fine.

In fact, if I browse to some websites, sit and wait awhile, then go to chrome or edge, type in the same website, the page displays even while FF is sitting there waiting.

ebay.com seems to work great, but for instance this morning, this one doesn't: https://www.crowdpac.com/news/741938 but sometimes this works: https://www.crowdpac.com then try it again (refresh) and it never responds.

And in fact, I'm using Edge to submit this question because when I browsed to https://support.mozilla.org/en-US/questions/new/desktop#search in Firefox/Safe and clicked on the Sign-In/Up button, nothing happened. With Edge it worked fine and I'm able to type this in.

I don't know when it started (quite awhile), but when I go to some websites even in FF safe mode, I wait a long time but get nothing displayed and it stops spinning/waiting (the circle arrow upper left stops). Occasionally when I reload, it comes up but usually it doesn't. Other websites it works fine. In fact, if I browse to some websites, sit and wait awhile, then go to chrome or edge, type in the same website, the page displays even while FF is sitting there waiting. ebay.com seems to work great, but for instance this morning, this one doesn't: https://www.crowdpac.com/news/741938 but sometimes this works: https://www.crowdpac.com then try it again (refresh) and it never responds. And in fact, I'm using Edge to submit this question because when I browsed to https://support.mozilla.org/en-US/questions/new/desktop#search in Firefox/Safe and clicked on the Sign-In/Up button, nothing happened. With Edge it worked fine and I'm able to type this in.

Všetky odpovede (20)

more options

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

I've spent the last week trying your suggestions (thank you!). It seems that clearing all cookies and the cache for all time didn't help. But holding the shift key and reload does.

That seems strange, if I clear the cache which doesn't help, but holding the shift key that bypasses the cache does, that doesn't make sense.

more options

A hard refresh bypasses various caches and not just the disk cache.

more options

That makes it sound that the problem wasn't with Firefox, but was cached elsewhere along the servers in this connection trail.

more options

No, I think it's FF. While FF is spinning on *some* websites, I can start up Chrome or Edge, browse to that same URL, the result displays, while FF is still spinning. Other websites it works fine, just like Chrome or Edge.

It's often subjective, and there can be other problems, which is why it took awhile to get back to the suggestions. But holding the shift down while refresh seems to help.

more options

Here are the load times for me. see screenshots Who are you using for DNS?

more options

Im using the standard comcast dns. but if its the DNS why would other browsers work?

more options

You see that all browsers behave differently. What do you have set here? see screenshot Just try a different DNS and see if it works better. Also try this app to see if another DNS provider performs better. https://www.grc.com/dns/benchmark.htm

Upravil(a) jonzn4SUSE dňa

more options

I ran it, and it said that 10.0.0.1 (which is my local router) is the fastest. But I don't understand your comment that 'all browsers behave differently'. Of course in general they do, but in this case, I think it's significant.

Chrome and Edge both successfully go everywhere.

FF on *some* URLs, sits and waits.

In fact, I can browse to a URL on FF, it's sitting there waiting, I can start up Edge or Chrome, go to the same URL, and get the proper response, while FF is still waiting and ends up giving up (the X turns into a circle). And if I refresh FF still doesn't display. I would think if the DNS is cached on the local PC, the original FF URL request would cause the DNS resolution to be cached locally and subsequent requests to the same URL (and the URLs called by that request) would be quite fast.

Plus, on FF, if I hold the SHFT key down when I do a refresh while FF has failed to get to the web page, the browser displays the web page properly.

more options

Try disabling any third-party antivirus or security software. Kaspersky can cause performance issues if you have "Inject script into web traffic to interact with web pages" enabled and don't have the companion browser extension installed.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

more options

I'm using Total Defense, I disabled it (AFAIK) and haven't really noticed much difference.

I haven't tried a new profile, but if I start FF in safe mode and it still happens, would that make a difference?

Also, FF acts the same on a completely different second system with Total Defense.

However, on a 3rd system, with no anti-virus, FF seems to work OK on the same sites that don't work on the Total Defense systems. So maybe it's an interaction between FF and TD?

But why would both Chrome and Edge work while FF doesn't, if it's not in FF itself? Wouldn't these others be similarly inhibited by any anti-virus software in the same way as FF if the problem were ?

more options

Note that you may only disable the user interface of your A-V software, but this software is still working in the background.

more options

Yes, I might have to call their support, but why would TD not inhibit the other browsers going to the same URL?

more options

Chrome and Edge are both Chromium-based browsers while Firefox is quite different.

Go to about:third-party in the address bar and try disabling the modules for Total Defense.

more options

There's nothing about TD under 'about:third-party'.

Your comment about C and E being different from FF suggests maybe there's something wrong in FF.

Interesting this morning, one of the websites that typically has this problem (nextdoor.com) responded great this morning. However, another one (crowdpac.com) responded better but still not right.

I went to https://www.crowdpac.com/feed?new_id=745870&utm_source=punewsletter&utm_medium=email&utm_campaign=09192023 and it sat and was spinning, and i went to Edge, copy and pasted the same URL, the result came back while FF was still spinning.

However, I noticed that the page body itself was spinning saying "Loading feed...", but the refresh icon (the circle/arrow to the left of the URL display up top) said it was done (it was a circle, not an X). Then a bit later (20 seconds maybe?) it actually completed. This sounds like FF was doing some computing instead of waiting for data maybe?

more options
  • Disable all modules in about:third-party.
  • Change secure DNS over HTTPS (DoH) to "Off" or "Increased Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".
  • Uninstall Total Defense to confirm that it works without it.
more options
more options

Zeroknight: I already tried FF in safe mode, so I doubt doing this would help. I checked Secure DNS and Proxy settings, and they were already off. I completely wiped Total Defense off my system, and there was no change so I reinstalled it.

cor-el: (Any relation to Corel Draw? :-) I looks like I need to get past Bitlocker so I'm going to have to research how to do this...

But given I don't have the problem in Edge/Chrome, and I don't have the problem in FF if I refresh FF with the shift key, wouldn't that mean that the problem is within FF?

more options

Paul Kinzelman said

However, on a 3rd system, with no anti-virus, FF seems to work OK

The crowdpac feed loads the same for me on Firefox as Chrome.

Safe/Troubleshoot Mode does not disable third-party modules, try disabling all modules in about:third-party.

You might need to reboot after uninstalling Total Defense.

more options

I thought that (disabling 3rd party) was the whole point of safe mode? I went to about:third-party and don't see any way to disable the modules and I tried searching help and didn't see anything. I believe I did reboot after TD uninstall, that's part of the process but I suppose I could try it again. And I've now unbitlockered my system so I can try the Windows safe mode as well.

  1. 1
  2. 2