Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Firefox History Set to "Always Use Private Browsing Mode" but "Recently Closed Tabs" Still Appear in History

  • 10 odpovedí
  • 2 majú tento problém
  • 277 zobrazení
  • Posledná odpoveď od cor-el

more options

I have my Firefox Firefox Privacy & Security History settings set to 'Always Use Private Browsing Mode.' Yet every time I open Firefox and visit the History tab, 'Recently Closed Tabs' shows a history of the websites I've visited. How do I disable this feature?

I have my Firefox Firefox Privacy & Security History settings set to 'Always Use Private Browsing Mode.' Yet every time I open Firefox and visit the History tab, 'Recently Closed Tabs' shows a history of the websites I've visited. How do I disable this feature?
Priložené obrázky

Vybrané riešenie

Recently closed tabs are only cleared after you close all private windows. You can disable it by going to about:config in the address bar and changing browser.sessionstore.max_tabs_undo to 0.

Čítať túto odpoveď v kontexte 👍 2

Všetky odpovede (10)

more options

Can I set Firefox to always use Private Browsing? In the Menu bar at the top of the screen, click Firefox and select Preferences. ... Select the Privacy & Security panel and go to the History section. Choose Use custom settings for history from the drop-down menu and check the Always use private browsing mode setting.

Regards, Jimmy

more options

Thanks Jimmy but that wasn’t my question. I’m already using private browsing. Please reread my question.

more options

Are you sure you closed every single Firefox window? The session persists as long as one window remains.

See if it still happens with all your extensions disabled.

more options

The problem persists after shutting down Firefox. I have no extensions so nothing to disable.

more options

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

more options

Refreshed existing profile. Then went into Settings and reset 'Always Use Private Browsing Mode.' 'Recently Closed Tabs' still appearing in History. There must be a way to disable this. Private Browsing isn’t private if it remembers your ‘Recently Closed Tabs?’

more options

Vybrané riešenie

Recently closed tabs are only cleared after you close all private windows. You can disable it by going to about:config in the address bar and changing browser.sessionstore.max_tabs_undo to 0.

more options

To terminate your Firefox session on Mac, make sure to use Quit, either:

  • menu button > Quit
  • (menu bar) Firefox > Quit

(As a Windows person, I don't know the exact wording, sorry.)

If you still have previous session browsing history or open/closed tabs after using Quit, maybe automatic private browsing isn't actually taking effect?

more options

I am using windows. Firefox deletes history in private mode after 1 hour. I cannot get history deleted on closing the browser. When I reopen Firefox, it auto completes my Url entry. Sometimes the history is retained after 5 hours.

My dilemma is I want history in non-private mode, but not in private mode.

It is a concern. I may have to go back to Edge browser.

more options

@spinvst

Do you notice leftover/orphaned Firefox processes in the Windows task manager after you close Firefox? Do you use the close X or Exit in the menu ? Using Exit/quit is the recommended way to ensure that Firefox closes properly.