Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't access a (poor) site, Ff states: Warning: Unresponsive script and so on... I guess I have to overstep Adobe Flash Player. Can you help?

  • 19 odpovedí
  • 2 majú tento problém
  • 91 zobrazení
  • Posledná odpoveď od James

more options

Hello Techies, First meet my system... Linux 32bits (Lubuntu), provided with: Lightspark, an SWF player, and all what Linux comes with.

Firefox ESR 52.4.0 (very old machine, its CPU doesn't have the SSE2 extension) provided with: HTTPS Everywhere, Ubuntu Modifications, YesScript OpenH264 Video Codec, Shockwave Flash, Widevine content Decryption module

I try to connect to a site, a radio station one, and Ff tells me a web page is slowing down the load process. Wait? Stop? Waiting is useless because the page never loads. Stopping leads to the site (simple http, without "s") but many parts of it do not respond. In other parts of the site Adobe Flash Player is mandatory to access the content. As you can imagine my system is not provided with Adobe and I guess this is why Ff warns me and can't access the site. I'm not installing Adobe, I don't even know if it is possible, and safe! How can I fix this? To me I should overstep Adobe, installing to the system something similar that the site can "like". Any suggestion? If you need it I can give the exact URL of the site. Many thanks for your educated answer!

Upravil(a) Alberto67 dňa

Vybrané riešenie

In you package manager you need to get rid of the old liblightsparkplugin related package and install Flash Player from Adobe.

You can install the Flash Player manually, however you then need to do updates manually. https://get.adobe.com/flashplayer/otherversions/

As you said you have a old CPU that does not support SSE2, Firefox Releases on Linux since Firefox 53.0 and later have dropped support of older CPU's that does not support SSE2. This is why Firefox 57.0.1 does not run.

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (19)

more options

You are using a very old version of flash.

Flash: Grab the uninstaller from here:

http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows

http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Then reinstall the latest version.

Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version 27.0.0.130

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only>


See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

When I wrote the question I was not using any Adobe Flash Player at all. My machine does not run Windows. My machine does not run Mac. My machine runs Linux. Two hours ago I installed Adobe Flash Player but nothing happened, the site kept being unaccessible as I mentioned above. Now I suppose I might have done some mistake setting up my Firefof ESR or I have made some mistake installing Adobe. The site I'm trying to access is the only that gives me this problem. Is there an app a site using Adobe can like so that I can access it? Or some cute way to configure Firefox to let it chew the site? Thank you and regard

more options

Please provide public link(s) (no password) that we can check out. No Personal Information Please !


Perform the instructions I posted above on the 'sick' computer to make sure its flash and drivers are up to date.


Note: If you look at the top right corner of the forum question you created, you will find a window called Question details. This is the system data that was created when you posted the question. Even if you don't use flash on that machine, it should be updated or removed.

more options

Hello FredMcD, I've read something about the end of an era of some plugins we are living now and I guess I've been caught in it!

I looked for additional drivers but there aren't any. (By the way I tried to read: https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration#w_search-for-and-install-new-graphics-drivers but I could find very few instructions. To me something is wrong with the page or my 'sick' machine didn't access properly the page)

I tried to update Shockwave Flash using Firefox but the result was: no update found. More, it's not removable.

I looked for Shockwave Flash out of Firefox, using Synaptic Package Manager, I found it, removed it and installed it again, but nothing happened. Neither updates are available here.

The URL that made me ask you help is: http://www.rtl.it/redazione/raffaele-morelli/

(No Personal Information, no passwords!)

It's an Italian radio station website. clicking the buttons left of the picture you shuold listen to old episodes.

Many thanks and regard

more options

Knock knock! Hello FredMcD, are you still in?...

more options

Sorry, I'm out of ideas. I called for more help.

more options

Ok, take your time...!

more options

Adobe Flash Player on Linux might be a little different, I believe you have to install the install packages from a reliable source for Linux. However I would advise that Flash technologies will no longer be supported at the end of 2020, this is for the user's safety and security for a stable browsing experience on the open web.

Sorry for the lecture, I believe the latest news on how to install the updates are here https://wiki.debian.org/FlashPlayer, http://www.omgubuntu.co.uk/2016/09/adobe-announced-will-restart-support-flash-linux, and https://www.if-not-true-then-false.com/2010/install-adobe-flash-player-10-on-fedora-centos-red-hat-rhel/ (I was not sure what version of Linux you had)

Performance wise, try disabling hardware acceleration for flash and only enable it for that site for functionality. But I do not recommend this being a permanent change for the safety of your browsing ;-)

more options

What Flash version do you currently have installed? See also the about:plugins page.

You can find a Lego block icon at the left end of the location bar indicating that the web page uses a plugin (Flash) that Firefox might block. You can click this Lego block icon to allow or block this plugin.

more options

Hello Techies, The only Flash installed to my system via Firefox is: Shockwave Flash 12.1 r720. I do not have any Adobe Flash Player. I guess whether there could be some non-Adobe Linux app or Firefox addon a site probably needing Adobe can like so that I don't have to install Adobe. The site I cited is the only one affected by this problem. Thanks

more options

Adobe Flash Player is the same plugin as Shockwave Flash plugin, but yours is fairly old since Adobe started to support Firefox in Linux starting with Flash 24.0 (previous Flash versions were Flash 11.0.x security updates).

As written above: You can download the latest Flash player plugin for Firefox on this page.

Did you look for the Lego block icon on the location/address bar that should be there if a page uses the Shockwave Flash plugin?

You should see this icon when you visit this page.

You can check the version of the currently installed Flash player here:

more options

Hello cor-el, I didn't know Shockwave was a relative of AdobeFP...

Thanks for the page I can connect to download AdobeFP.

I did look for the Lego block but I did not see any block. This should mean that the page does not use Shockwave Flash plugin, to me.

more options

Shockwave Flash is a old name for the Flash Player Plugin as some places in Firefox may still refer to Flash Player as Shockwave Flash.

Note Adobe has another Plugin called Shockwave Player that is only for Windows and Mac OSX so do not confuse the two by calling the Flash Player plugin as Shockwave.

The version 12.1 r720 is due to using the old Lightspark Shockwave Flash 12.1 r720 plugin you have installed on system which gets identified as Shockwave Flash.

Adobe used to only support Linux with updates to the old the 11.2.x ESR branch until they finally supported Linux again with Releases (and not just Beta builds in testing month earlier) back in mid December 2016.

If Firefox was still running when you install the Flash Player Plugin then either restart Firefox or type about:plugins in the Location (address) bar in Firefox to scan for what Plugins Firefox is making use of on your system. This and other about: urls are listed in about:about and do note the :

more options

Did the unresponsive script stop?

more options

Hello James, my installed plugins are:

--OpenH264 Video Codec provided by Cisco Systems, Inc.

   File: 1.6
   Path: /home/alberto/.mozilla/firefox/6yzl2ybj.default/gmp-gmpopenh264/1.6
   Version: 1.6
   State: Enabled
   This plugin is automatically installed by Mozilla to comply with the WebRTC specification and to enable WebRTC calls with devices that require the H.264 video codec. Visit http://www.openh264.org/ to view the codec source code and learn more about the implementation.

--Widevine Content Decryption Module provided by Google Inc.

   File: 1.4.8.903
   Path: /home/alberto/.mozilla/firefox/6yzl2ybj.default/gmp-widevinecdm/1.4.8.903
   Version: 1.4.8.903
   State: Enabled
   Play back protected web video.

--Shockwave Flash

   File: liblightsparkplugin.so
   Path: /usr/lib/lightspark/liblightsparkplugin.so
   Version: 
   State: Enabled
   Shockwave Flash 12.1 r720

I got lost and confused. What am I supposed to do now? (I'm still using Firefox ESR 52.4 as Firefox 57 does not even start...) Thanks

more options

Well, Firefox ESR 52.5, now...

more options

Still there?

more options

Knock, knock! James? Anybody?

more options

Vybrané riešenie

In you package manager you need to get rid of the old liblightsparkplugin related package and install Flash Player from Adobe.

You can install the Flash Player manually, however you then need to do updates manually. https://get.adobe.com/flashplayer/otherversions/

As you said you have a old CPU that does not support SSE2, Firefox Releases on Linux since Firefox 53.0 and later have dropped support of older CPU's that does not support SSE2. This is why Firefox 57.0.1 does not run.