X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

how do I turn off Mobil mode.

Размещено

I have a nexus 10, which with a 10" screen is not really a mobile device. Unfortunately, Firefox is telling web pages that it is. Given this information, some web pages redirect to an abbreviated page. Turning on "request desktop site" does not work since I am no longer on the site I want and this button is not persistent. Thus the question, how do I turn off mobility notification?

I have a nexus 10, which with a 10" screen is not really a mobile device. Unfortunately, Firefox is telling web pages that it is. Given this information, some web pages redirect to an abbreviated page. Turning on "request desktop site" does not work since I am no longer on the site I want and this button is not persistent. Thus the question, how do I turn off mobility notification?

Выбранное решение

Hi,

Please try changing the user agent.

To change the User Agent string, just enter about:config as an address in the address bar of FireFox, the location where you normally enter a URL (link). I recommend to preserve the original value, which you can get when you enter just about: in the address bar.

Now press the right mouse button to get the context menu and select "String" from the menu entry "New". Enter the preference name "general.useragent.override", without the quotes. Next, enter the new User Agent value: "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:25.0) Gecko/20100101 Firefox/25.0" ( also without quotes) .

Hope this helps!

Прочитайте этот ответ в контексте 1

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Android; Tablet; rv:26.0) Gecko/26.0 Firefox/26.0

Дополнительная информация

debjanichatterjee 2 решений 38 ответов
Размещено

Выбранное решение

Hi,

Please try changing the user agent.

To change the User Agent string, just enter about:config as an address in the address bar of FireFox, the location where you normally enter a URL (link). I recommend to preserve the original value, which you can get when you enter just about: in the address bar.

Now press the right mouse button to get the context menu and select "String" from the menu entry "New". Enter the preference name "general.useragent.override", without the quotes. Next, enter the new User Agent value: "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:25.0) Gecko/20100101 Firefox/25.0" ( also without quotes) .

Hope this helps!

Hi, Please try changing the user agent. To change the User Agent string, just enter about:config as an address in the address bar of FireFox, the location where you normally enter a URL (link). I recommend to preserve the original value, which you can get when you enter just about: in the address bar. Now press the right mouse button to get the context menu and select "String" from the menu entry "New". Enter the preference name "general.useragent.override", without the quotes. Next, enter the new User Agent value: "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:25.0) Gecko/20100101 Firefox/25.0" ( also without quotes) . Hope this helps!

Изменено debjanichatterjee

James
  • Top 25 Contributor
  • Moderator
1603 решений 11348 ответов
Размещено

Some websites may be giving you the mobile version instead of desktop or a choice.

One option is to use the Phony extension on mobile Firefox. Make sure you switch back to normal useragent so you can install new Extensions on a.m.o then. https://addons.mozilla.org/en-US/android/addon/phony/

Some websites may be giving you the mobile version instead of desktop or a choice. One option is to use the Phony extension on mobile Firefox. Make sure you switch back to normal useragent so you can install new Extensions on a.m.o then. https://addons.mozilla.org/en-US/android/addon/phony/
debjanichatterjee 2 решений 38 ответов
Размещено

Hello,

I am glad to hear that your problem has been resolved.

I hope you continue using our products and thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. I hope you continue using our products and thank you for contacting Mozilla Support.
James
  • Top 25 Contributor
  • Moderator
1603 решений 11348 ответов
Размещено

The problem has not been resolved very well though.

It would be best to not make the change more permanently as suggested in first reply, especially if you want to be able to install Extensions at https://addons.mozilla.org/en-US/android/addon/ as it may say you do not have a compatible version. One may forget in future that the useragent was overridden in about:config and the user may then wonder why s/he could not install extensions on android Firefox.

The problem has not been resolved very well though. It would be best to not make the change more permanently as suggested in first reply, especially if you want to be able to install Extensions at https://addons.mozilla.org/en-US/android/addon/ as it may say you do not have a compatible version. One may forget in future that the useragent was overridden in about:config and the user may then wonder why s/he could not install extensions on android Firefox.
Размещено

Задавший вопрос

hopefully, this problem will be addressed by the Mozilla developers and a better solution developed. at a minimum, how about the full Firefox compiled for this is? also, how about Thunderbird compiled for this is?

hopefully, this problem will be addressed by the Mozilla developers and a better solution developed. at a minimum, how about the full Firefox compiled for this is? also, how about Thunderbird compiled for this is?