Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

URL bar not using keyword.url to search, instead using whatever engine is active in the search bar.

  • 7 ответов
  • 22 имеют эту проблему
  • 9 просмотров
  • Последний ответ от philipp

more options

Earlier when i used to enter some words in the address bar and press enter firefox would use google's browse by name search and redirect to what i want. For example if i wrote fb, it took me to facebook, and if i wrote something ambiguous it would open a google search for the query. Recenly, it somehow changed. I have keyword.enabled set to true and the keyword.url is http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= but when i enter something in the address bar, it uses the active engine in the search box. if i have wikipedia active in the search box and i type google in the address bar, it takes me to the wikipedia page for google.

Выбранное решение

you could also try to use http://ready.to/search/en/ to create your own custom search provider...

Прочитайте этот ответ в контексте 👍 1

Все ответы (7)

more options

hello, you're using the nightly version. i think you might be witnessing the preparations for the australis redesign with a unified address/search bar...

edit: apparently it isn't related to the UI change immediately, but the background is explained in bug #738818 (please don't post in bug reports).

Изменено philipp

more options

is there any way to reenable keyword.url? Or do i have to add a search engine for google search by name manually? If so, how do i do that?

Thanks a lot for your reply

more options

i fear the integrated keyword.url option will be gone for good (until there is an addon which will offer a replacement).

you could add a custom serch provider for a "i'm feeling lucky"-search at google from here: http://mycroftproject.com/search-engines.html?name=Google+%28I%27m+Feeling+Lucky%29

more options

thanks for that, but I'm feeling lucky is different from search by name. I'm feeling lucky just redirects you to the first page of the search results, whereas search by name only redirects if the search term is for a popular website or something like that.

more options

Выбранное решение

you could also try to use http://ready.to/search/en/ to create your own custom search provider...

more options

The best I can come up with is to add DuckDuckGo to your search engines, make sure it's active, then type an exclamation point (!) before your query -- i.e., "! firefox". This activates the "Feeling Ducky" result, which is practically identical to Google's "Feeling Lucky" result.

more options

in the meanwhile there's the KeywordSearch addon which can be used to work around the change: https://addons.mozilla.org/firefox/addon/keyword-search/