Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

New Page Pocket recomendations re-enabling periodically

  • 10 ответов
  • 0 имеют эту проблему
  • 42 просмотра
  • Последний ответ от FIGBird

more options

Issue: The "Recommended stories" setting for the new tab default home page periodically re-enables itself.

Version Info: Firefox 124.0.1 (64-bit) OS: Linux Mint 21.1 Cinnamon

Additional Information:

  • I do not use pocket, at all
  • All settings that I can find related to pocket are disabled
  • I do use Firefox Sync, however the other device (124.0.1 (64-bit) on pop_os!) does not have this issue
  • Does not correlate to version updates (Mint has automatic updates disabled in policies)
  • Does not occur after a simple restart

I am tired of disabling this setting and having it return seemingly randomly. I have no interest in these stories, and consider them spam.

Please assist me in determining why this is happening on this device and how we can go about preventing it going forward.

Thanks, Steven

'''Issue:''' The "Recommended stories" setting for the new tab default home page periodically re-enables itself. '''Version Info:''' Firefox 124.0.1 (64-bit) OS: Linux Mint 21.1 Cinnamon '''Additional Information:''' * I do not use pocket, at all * All settings that I can find related to pocket are disabled * I do use Firefox Sync, however the other device (124.0.1 (64-bit) on pop_os!) does not have this issue * Does not correlate to version updates (Mint has automatic updates disabled in policies) * Does not occur after a simple restart I am tired of disabling this setting and having it return seemingly randomly. I have no interest in these stories, and consider them spam. Please assist me in determining why this is happening on this device and how we can go about preventing it going forward. Thanks, Steven

Все ответы (10)

more options

As a follow up, today, the setting has reset again.

My best guess as to what is going on has something to do with Firefox sync, but it doesn't make much sense to me.

I say this because today, on my laptop, I changed one of the frequently used sites displayed on the new tab page. As soon as I swapped devices to my desktop and I opened the new tab home page I saw the sponsored links again.

However, I was unable to reproduce the settings reset. This is why it doesn't make sense to me. However, I figure that information may be useful.

My sync settings are:

  • Bookmarks
  • History
  • Add-ons
  • Settings
  • Open tabs

As noted before, I have NOT updated the Firefox version since the original post (there is an update available for this device, but have been putting it off to prove that it wasn't that).

I'll continue to post data as I run into stuff that seems relevant. Regardless, I am still at a loss as to what is going on, and would appreciate some help triaging/resolving this.

Полезно?

more options

There are quite a few browser.newtabpage.activity-stream prefs that deal with the Firefox Home page part of syncing settings as you can see by these services.sync.prefs control prefs.

  • services.sync.prefs.sync.browser.newtabpage.activity-stream

The prefs about Pocket are the topstories prefs.

  • browser.newtabpage.*topstories

So I assume that you are referring to this pref:

  • browser.newtabpage.activity-stream.feeds.section.topstories
  • services.sync.prefs.sync.browser.newtabpage.activity-stream.feeds.section.topstories

Полезно?

more options

I do not know which of those settings it is, I am talking about the one I have circled in this screen grab from the new tab page settings panel.

All settings in about:config searching for "services.sync.prefs.sync.browser.newtabpage.activity-stream" are marked as true.

I have also attached the results of "browser.newtabpage.*topstories"

Полезно?

more options

As you can see in the screenshot that shows this section in the Inspector, this is about the pref I mentioned above and possibly a second pref.

  • browser.newtabpage.activity-stream.feeds.section.topstories
  • browser.newtabpage.activity-stream.showSponsored

Полезно?

more options

I do not understand what you are suggesting I do.

The setting is not reverted on restart of either Firefox or the system, so the provided link does not make sense. I can try some of those things, but they do not seem relevant at all to the issue. Am I missing something?

As indicated in the original post, the specific setting reverts seemingly randomly, not all of them. For example, the revert this morning didn't even have the system powered down, and Firefox was open.

Полезно?

more options

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Полезно?

more options

Is browser.search.region the same in each browser profile being synced?

Change services.sync.prefs.sync.browser.newtabpage.activity-stream.feeds.section.topstories to false to stop this particular setting from being synced.

Полезно?

more options

I can boot up my laptop to confirm, but they should both be in the same region. I have not changed that setting, though, so its possible it defaulted to something else.

As for disabling "services.sync.prefs.sync.browser.newtabpage.activity-stream.feeds.section.topstories", I will give that a try.

When I changed that a new setting in about:config "services.sync.prefs.sync-seen.services.sync.prefs.sync.browser.newtabpage.activity-stream.feeds.section.topstories" appeared. Are you suggesting I disable that too?

Полезно?

more options

No, sync-seen (services.sync.prefs.sync-seen) prefs are OK and used for telemetry statistics. I noticed this Pocket pref:

  • browser.newtabpage.activity-stream.section.highlights.includePocket
  • services.sync.prefs.sync.browser.newtabpage.activity-stream.section.highlights.includePocket

You can disable Pocket if you do not want to use it, but this may not work for the topstories.

  • about:config => extensions.pocket.enabled => false

Полезно?

more options

I do not use pocket and have no desire to, so I set "extensions.pocket.enabled" to false, and have set the other two settings to false as well.

I won't really know if its working unless it happens again, given I do not have a good way to reproduce it. I'll give it a few days and see if it shows back up.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.