Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

VPN needs W 10?

  • 9 ответов
  • 1 имеет эту проблему
  • 12 просмотров
  • Последний ответ от cor-el

more options

I have used FireFox for years Now I can not download VPN as it requiers W 10+ I can not afford new computer, I am a Disabled Viet Nam Vet/ A MARINE I dd not what all these new apps and maybe Windows is blocking download - HELP

I have used FireFox for years Now I can not download VPN as it requiers W 10+ I can not afford new computer, I am a Disabled Viet Nam Vet/ A MARINE I dd not what all these new apps and maybe Windows is blocking download - HELP

Все ответы (9)

more options

I do not understand all the requirements Window wants in order to download W 10 to this laptop. their site had too many steps or questions I wrecked my truck a few weeks ago - so I can not take my computer anywhere to be fixed or updated suggestions please, Thanks Lenovo laptop W7. also have Samsung laptop same w7

Полезно?

more options

No response yet

Полезно?

more options

Hi

The product that you refer to is one of our premium products. In order to get premium support from a dedicated agent, please select the product below to submit your question:

Полезно?

more options

Полезно?

more options

from the FAQ on https://www.mozilla.org/products/vpn/

What devices is Mozilla VPN compatible with? Mozilla VPN is compatible with mobile, tablet, and desktop on: Windows 10/11 (64-bit only) macOS (10.15 and up) Android (version 8 and up) iOS (13.0 and up) Linux (Ubuntu 20.04 and up)

Though for Linux if you can meet the system requirements for current versions of Firefox then you can run the Mozilla VPN.


willys59sw said

No response yet

This is a Support Forum and not some form of direct chat or ticket system so responses can take anywhere from minutes to hours or longer.

However for the premium products that are subscription like Mozilla VPN they have their own support sections as Paul pointed out in reply above. This section you posted this thread in is for (desktop) Firefox support.

Полезно?

more options

Note for the old EOL Windows 7, 8, 8.1 users, every other major web browser already dropped support back in Jan/Feb last year while Mozilla is still supporting for the time being until Fx 115.9.0esr in Sept 2024.

https://support.mozilla.org/en-US/kb/firefox-users-windows-7-8-and-81-moving-extended-support

To use more current versions of Firefox after will require Windows 10 or late or perhaps dual boot with a recent Linux distro. I suggest using a lighter desktop like XFCE over say KDE or GNOME if you do so,

Изменено James

Полезно?

more options

From your question it sounds that you are on Windows 7 where Mozilla VPN requires Windows 10 as the minimum, so you are out of luck and won't be able to use this VPN on Windows 7.

When it comes to updating your devices to Windows 10, we can't help you with that apart from suggesting a Linux distro where this VNP runs and you would have to contact MS or go to a Windows oriented forum for help.

Полезно?

more options

It seems like the whole internet system now requires a VPN, I comprehend security issues, but why have my computers been made worthless. I FEEL CHEATED, there should be a solution for disabled VETS, my disability compensation is only 30% barely covers cost of Spectrum service & cat food. And co-pay for ambulance trips

Полезно?

more options

You can look for another VPN service that runs in Windows 7 or search the Add-ons website for a VPN extension.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.