Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Clicking download icon or link in displayed PDF ignores "ask where" setting

  • 10 ответов
  • 0 имеют эту проблему
  • 38 просмотров
  • Последний ответ от Dave

more options

I have Firefox set to ask me where to download files that I want to download. It works for normal download links, but when I'm using my credit card company site's PDF viewer to look at a statement and I click on the download icon or link in the upper-left, it simply downloads the PDF (to my chosen "Save files to" folder in Settings). Is there a current way to change this behavior? Is this something that the website's code determines, overriding my Firefox setting?

I have Firefox set to ask me where to download files that I want to download. It works for normal download links, but when I'm using my credit card company site's PDF viewer to look at a statement and I click on the download icon or link in the upper-left, it simply downloads the PDF (to my chosen "Save files to" folder in Settings). Is there a current way to change this behavior? Is this something that the website's code determines, overriding my Firefox setting?
Приложенные скриншоты

Выбранное решение

Try changing browser.download.force_save_internally_handled_attachments to true in about:config then restart the browser.

Прочитайте этот ответ в контексте 👍 2

Все ответы (10)

more options

Dave said

when I'm using my credit card company site's PDF viewer to look at a statement and I click on the download icon or link in the upper-left, it simply downloads the PDF (to my chosen "Save files to" folder in Settings).

There is the answer to your question. You're using their PDF viewer. Right click on pdf file and open in Firefox and then it should prompt you. I went to the irs site and viewed a pdf in Firefox and then clicked the download option in Firefox and it prompts me. see screenshot

Полезно?

more options

Directly below the "Always ask you where to save files" setting, you need to change each file type to "Always ask" and other files to "Ask whether to open or save files".

Полезно?

more options

Here's a screenshot.

Полезно?

more options

The problem is that there is no PDF file to click on. They have a Statements link, which opens the current statement in their viewer, which contains a drop-down tool to view other months' statements. I can find no way to download the current PDF to where I want to.

Chrome doesn't suffer this issue. Clicking the same download link (in the Capital One PDF viewer) in Chrome brings up the folder picker so I can put it where I want it. I was hoping the same thing was possible in Firefox (which I recently switched to).

I have the PDF behavior set to "Open in Firefox" so that I can view a PDF first, then make the choice (or not) to download it and to where. As mentioned, Firefox then doesn't give me the choice of where in the case of my credit card company's interface, while Chrome does. If I set it to "Always ask," I lose the instant-view ability. Maybe that's the best I can get from Firefox?

Полезно?

more options

It would help if we could see what you're seeing. Create a screenshot and block out personal info. Use the snipping tool and then save the image. Then go into paint and block personal info.

Полезно?

more options

Change browser.download.open_pdf_attachments_inline to true in about:config then restart the browser. This will open in the Firefox PDF viewer first and then you can save it where you want.

Полезно?

more options

Here ya go, jon...

Изменено Dave

Полезно?

more options

@zeroknight... thanks. That appears to be a pretty good work-around. It opens the PDF in the Firefox viewer (from the Capital One viewer's download button), from which I can then direct a download to my folder of preference--with only one additional click. The download to my default downloads folder still happens, but I guess I can just periodically go clean that up.

Any other thoughts around making this work better?

Many thanks.

Полезно?

more options

Выбранное решение

Try changing browser.download.force_save_internally_handled_attachments to true in about:config then restart the browser.

Полезно?

more options

Yesssss...

At first it didn't work, but then I went back to the former config key you cited, changed it back to FALSE, and then new key toggle worked!

Thanks for much for staying with me on this.  :^)

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.