Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

AutoConfig Alert

  • 18 ответов
  • 1 имеет эту проблему
  • 222 просмотра
  • Последний ответ от Chase Cathey

more options

Good morning,

I'm reaching out to see if I can get some assistance with Firefox on of our network. I'm System Admin at Goodfellow AFB. I've tried searching this issues on the web and found similar issues but solutions that were recommend online have not worked for us. Yes I have uninstalled Firefox completely and installed it from scratch. I know it has something to do with autoconfig file but not sure what exactly I'm looking for. Thanks.

Good morning, I'm reaching out to see if I can get some assistance with Firefox on of our network. I'm System Admin at Goodfellow AFB. I've tried searching this issues on the web and found similar issues but solutions that were recommend online have not worked for us. Yes I have uninstalled Firefox completely and installed it from scratch. I know it has something to do with autoconfig file but not sure what exactly I'm looking for. Thanks.
Приложенные скриншоты

Выбранное решение

The channel-prefs.js file is the default file that can remain in the folder.

The autoconfig.js file instructs Firefox to execute the mozilla.cfg script file at the main level of the program folder. It likely is in one of these locations:

  • C:\Program Files\Mozilla Firefox\mozilla.cfg
  • C:\Program Files (x86)\Mozilla Firefox\mozilla.cfg

Does the mozilla.cfg file look like something you're intentionally pushing out? If not, both autoconfig.js and mozilla.cfg could be removed.

Прочитайте этот ответ в контексте 👍 1

Все ответы (18)

more options

Изменено cor-el

more options

Yes I am using Firefox. It prompts you twice with that message and after you click OK both times. Firefox opens and runs fine. I know it's not supposed to do that I'm trying to figure out why.

more options

Any info about autoconfig issues in the Browser Console after you start Firefox ?

more options

I don't know. The option to make it show the Browser Console is not there for me. I'm assuming GPO has is disabled or hidden

more options

Try starting in

C:\Program Files\Mozilla Firefox\defaults\pref

Firefox creates a file here named channel-prefs.js. Any other .js file in this folder could be the one pointing Firefox to that .cfg file.

more options

Ok I found the 2 .js files. What do I need to do to them?

more options

Is the extra file -- and the .cfg file it points to -- meant to implement anything important? If not, you could simply remove them.

more options

Ok. Does these look important? (screenshots below)

more options

Выбранное решение

The channel-prefs.js file is the default file that can remain in the folder.

The autoconfig.js file instructs Firefox to execute the mozilla.cfg script file at the main level of the program folder. It likely is in one of these locations:

  • C:\Program Files\Mozilla Firefox\mozilla.cfg
  • C:\Program Files (x86)\Mozilla Firefox\mozilla.cfg

Does the mozilla.cfg file look like something you're intentionally pushing out? If not, both autoconfig.js and mozilla.cfg could be removed.

more options

I don't believe so. Ok, that's what I wanted to know if I could remove them and it not break something else. So I went ahead and removed them. The browser seems to be working fine and that message didn't pop up.

Do you know of a script I can use to push out to all my machine so I can delete those files remotely?

If not, thanks again for you help!

more options

I don't think there would be a script specific to Firefox itself, just a general script that removes a particular file at a particular location. Probably something on a Windows admin or PowerScript forum?

more options

Ok cool, I will look into it. So deleting the the files solved my problem but after restarting my computer. It brings them back. So any ideas if I need to change something in the file to keep it from asking with that pop up. I guess I need to look at my Group Policy management.

more options

It sounds like some other tool is putting those files there. If you send them to me (the CFG in particular) I should be able to diagnose what software is installing them - mkaply at mozilla.com

more options

Mike how do I send that file to you?

more options

It should be in the directory where Firefox is installed

    C:\Program Files\Mozilla Firefox\mozilla.cfg
   C:\Program Files (x86)\Mozilla Firefox\mozilla.cfg 

And you can send it to my Mozilla email - mkaply at mozilla.com

more options

Yes sir I know and I just sent it . Thanks

more options

So in looking at the file, it does look like a pretty standard set of configurations based on a previous version of the STIG. There's nothing in it that points to a particular vendor

I was looking at it to see if we had made change to cause this to start failing (renaming a pref or something like that), but what I discovered is that it unfortunately has two code errors in it:

lockPref("extensions.htmlaboutaddons.recommendations.enabled", "false"); lockPref("security.ssl3.rsa_des_ede3_sha", "false");

These use "false" instead of false which is causing the actual errors.

So it looks like you'll need to determine what is putting this file into Firefox in order to prevent this message (or get the file fixed).

more options

Mike,

Sorry I totally forgot to respond to you. I got busy working on another project but I just wanted to let you know that your solution worked. I did it locally on my computer and it seemed to do the trick. Now I'm updating the main cfg file on the DC to see if it will push that update to all workstations. On the DC the file path for the main cfg file should be something similar below.

C:\Windows\SYSVOL\domain\Firefox_STIG\mozilla.cfg

Thanks again!