Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

An address is a URL. A search is keywords. They are not interchangeable. How do I get Firefox to stop mixing them up?

  • 7 ответов
  • 1 имеет эту проблему
  • 42 просмотра
  • Последний ответ от boundlessly

more options

When I want a URL, I type it in the address bar. Search has no relevance to a URL, and any intervention of Search gets in the way, and creates errors.

When I click in the search bar, it's because I want a keyword search with one of the search engines. A search is not a URL.

They are two completely different things, and treating either one as the other is error. I do not want Firefox to kidnap my cursor and teleport it to somewhere I didn't click. They are two entirely different spaces, they are not interchangeable. When I click in the search bar, it's because I want a search. Don't you dare second guess me and change my click to the address bar.

How do I turn off this stupid stupid stupid error behavior of FIrefox?

I tried this and it didn't work. In about:config • keyword.enabled and toggle it from True to False. • browser.fixup.alternate.enabled and toggle it from True to False.

When I want a URL, I type it in the address bar. Search has no relevance to a URL, and any intervention of Search gets in the way, and creates errors. When I click in the search bar, it's because I want a keyword search with one of the search engines. A search is not a URL. They are two completely different things, and treating either one as the other is error. I do not want Firefox to kidnap my cursor and teleport it to somewhere I didn't click. They are two entirely different spaces, they are not interchangeable. When I click in the search bar, it's because I want a search. <i><b>Don't you dare</i></b> second guess me and change my click to the address bar. How do I turn off this stupid stupid stupid error behavior of FIrefox? I tried this and it didn't work. In about:config • keyword.enabled and toggle it from True to False. • browser.fixup.alternate.enabled and toggle it from True to False.

Выбранное решение

Note that I wrote above to modify the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar pref.

Прочитайте этот ответ в контексте 👍 1

Все ответы (7)

more options

General rule: Humans are smart, and have intent and agency. Software has none of the three. Software should not attempt to compete with humans.

more options

You can set this pref to false on the about:config page.

  • browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar = false

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

Dear Cor-el --

That much I know. As I wrote, I tried this and it didn't work. In about:config

  •  keyword.enabled and toggle it from True to False. 
  •  browser.fixup.alternate.enabled and toggle it from True to False.

Which specific config variables do I need to set in order to return to circa-version-68 circa-2019 behavior.

Thank you.

more options

Thanks -- I've tried • keyword.enabled and toggle it from True to False.

 •  browser.fixup.alternate.enabled and toggle it from True to False.

and rebooted between. I still have the problem -- on the Mozilla home page, when I click into the search bar on the home page, and type the first character, the cursor bounces to the address bar. I do not want that. If I want a URL, I will type it in the address bar. If I click in a search bar, it's because I want a search.

How do I get that?

And the Zoom client and the Adobe viewer plugin broke too.

This is why so many users take the strongest steps possible to defend against Firefox updates. So far, I've lost four or five hours of billable time fixing things that broke between 68ESR and 91.3ESR. There is NO feature you can possibly add that's worth this much time lost.

more options

I found this one.

https://support.mozilla.org/en-US/questions/1338543

That fixed the problem.

This change was stupid stupid stupid. Is there any adult supervision for what gets merged in, and the setting of defaults?

more options

Выбранное решение

Note that I wrote above to modify the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar pref.

more options

Dear Cor-el -- thank you. I looked too quickly.