Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

pdf Files will not open with adobe acrobat and I have the open pdf files with adobe acrobat checked?

  • 5 ответов
  • 1 имеет эту проблему
  • 143 просмотра
  • Последний ответ от amryde

more options

I use html pages on an internal hard drive that link to pdf documents. For some reason since Version 91.0.2 was installed I can not get the pdf documents to open with Adobe Acrobat Reader DC.The new version insist on opening the pdf's in the Firefox web browser. When I click on a pdf link at an external website the files will open in Adobe Acrobat. I used the code below to test the open in Adobe Acrobat execution and it works on the w3School example. When I run it strait from my hard drive the document opens in the Firefox web browser.

<!DOCTYPE html>
<html>
  <head>
    <title>Title of the document</title>
  </head>
  <body>
    <h1>PDF Example</h1>
    <p>Open a PDF file <a href="datasheet_cube-model-715.pdf">example</a>.</p>
  </body>
</html>

Please let me know if there is a solution. Thank you,

Изменено cor-el

Выбранное решение

There has been a change in Firefox 91 on how locally stored PDF files are handled, see:

Note that this will work better in Firefox 93. As a workaround for now you can disable the builtin PDFjs Viewer by setting "about.config => pdfjs.disabled = false".

  • 1726501 - Internal PDF Reader is always used when called from a local HTML file [93]
Прочитайте этот ответ в контексте 👍 1

Все ответы (5)

more options

What is the default set to for .pdf in Windows?

Полезно?

more options

Выбранное решение

There has been a change in Firefox 91 on how locally stored PDF files are handled, see:

Note that this will work better in Firefox 93. As a workaround for now you can disable the builtin PDFjs Viewer by setting "about.config => pdfjs.disabled = false".

  • 1726501 - Internal PDF Reader is always used when called from a local HTML file [93]

Полезно?

more options

Thank you Cor-el "pdfjs.disabled=true" did the trick! I wanted to mention that the reason for needing to open a pdf in Adobe Acrobat Reader is that when printing I can select print current page, a feature that is missing in all the web browser viewers. It would be useful, I think if FireFox could add that function. Anyway, problem solved for now. Thanks again.

Полезно?

more options

I make websites that index sets of PDF documents, often annual reports or sets of tables. Firefox was great when it opened these PDFs in Adobe Reader or Acrobat. The users could compare 2 or more side by side, search, print, etc. Now they can only open one at a time and have to hit the browser 'back' button to return to the index--if they close the tab, they have to restart the site. This is a deal-breaker for me and Firefox--I used to recommend it as the best browser to use for these sites, but now I can't.

None of the possibilities under settings/applications work--not 'use Adobe Acrobat', nor 'Windows default', nor even 'always ask.'

I will try the "about.config => pdfjs.disabled = false" workaround for my own use if you will tell me where I find that statement to change it.

Полезно?

more options

Well for a geek your solution works, for me it does not. Thanks Firefox.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.