Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Stop inactive tabs from throttling down/ timing out

  • 2 ответа
  • 1 имеет эту проблему
  • 3 просмотра
  • Последний ответ от mikeyfila

more options

Hi I run a program called nodered on a raspberry pi in docker. I use a browser to reach the user interface via lan. If that tab sits in the background too long (~5 min) the connection with the server resets and resets the gui.

I lose all current debugging information and any unsaved changes. Saving the page will stop the lost progress but not the current debugging. In other words just saving the page each time will only solve 1/2 of the problem.

Is there anyway to keep a background page active so it doesn't reset after a few minutes?

https://nodered.org/

Изменено mikeyfila

Все ответы (2)

more options

You can try to adjust some keepalive prefs on the about:config page to see if that works.

Полезно?

more options

Hi thanks for the response. I should have mentioned I adjusted everything I could find about background tabs and java script I could find.

I changed them to -1. This was the time out setting for the active tab pref. I assume that means infinity? It didn't make a difference. Do you know if -1 is just that, infinity? or should I just be using really large numbers?

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.