Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Autofill too aggressive in URL bar

  • 3 ответа
  • 1 имеет эту проблему
  • 6 просмотров
  • Последний ответ от NoahSUMO

more options

I tried to type “teddy bear” into the url bar. After I typed the letter “t”, it autocompleted a url that began “th”. I kept typing. Instead of overwriting the “th” to “te”, it kept the “h”, leading to “the”. The result was “theddy bear”. This reproduces 100% of the time for me. Variants on this bug make it difficult to type in search terms.

I have a short screen recording of it in action but this form won’t let me upload it—photos only.

Выбранное решение

Ah thanks for reporting it then! :D I get what you mean about it being useful. I'll poke around and see if there's a workaround for this or at least a bug on file about improving how autofill works in the url bar.

Maybe by adding a way to signal you want to do a non-history search by entering a special character first or long pressing the url bar & choosing something like "Private search". So that it doesn't search for anything in your personal data & let's you finish typing the search without autofilling & throwing a typo into what you were typing. :)

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options

Thanks for reporting this! I think might be caused by the search suggestions feature. If we disable that, it should stop that behavior. Please read the article below & let me know if that stopped it. If not, I will see if there's a different setting we have to disable as that's surely annoying & disruptive.

Turn search suggestions on or off on Firefox for iOS https://support.mozilla.org/en-US/kb/turn-search-suggestions-or-firefox-ios

Полезно?

more options

Thanks for the reply! I have search suggestions off already. The autofill is of a previous url I visited. I’m not sure whether there’s a way to disable that, but I’m not sure I’d want to—it’s pretty useful.

This seems like a bug. My goal here was mainly to report it; I couldn’t find any other bug reporting options. (Although other workaround ideas are welcome.)

Полезно?

more options

Выбранное решение

Ah thanks for reporting it then! :D I get what you mean about it being useful. I'll poke around and see if there's a workaround for this or at least a bug on file about improving how autofill works in the url bar.

Maybe by adding a way to signal you want to do a non-history search by entering a special character first or long pressing the url bar & choosing something like "Private search". So that it doesn't search for anything in your personal data & let's you finish typing the search without autofilling & throwing a typo into what you were typing. :)

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.