Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

When I open a new tab how to remove the cursor focused on the address bar by default

  • 6 ответов
  • 4 имеют эту проблему
  • 1332 просмотра
  • Последний ответ от jscher2000

more options

Hi, I have updated to the latest verson 75.0, and I am a little uncomfortable for the default action when I open a new tab, the cursor focused on the address bar , and the address bar was widened and made a little shadow to the bookmarks bar which caused discomfort for me, because I always open website by bookmarks bar, no need for typing the full address in the adress bar. I have searched the config options but none is effective and also tried about:config, is there anyway not to widen the address bar or is there a configuration when I click the bookmark in current tab,it will open in new tab not replace the current tab .If it is possible by not downloading a lower verson,please let me know how to config it,thank you.

Приложенные скриншоты

Выбранное решение

Hi hellowd, I think that's actually 3 questions.

(1) When opening a new tab, can you set Firefox not to put the cursor into the address bar?

Right now, there is no setting for that.

(2) Can we set the Firefox address bar not to overshadow the bookmarks toolbar?

Right now, there is a setting to roll back to the Firefox 74-style address bar. This is a temporary setting while they work out the final bugs with this new design, so it probably will stop working later this year. But you might enjoy using it for now. Here's how:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box in the page, type or paste URLB and pause while the list is filtered

(C) Double-click the browser.urlbar.update1 preference to switch the value from true to false

(The other way is to manipulate the styling of the new design. More details on that if you're interested in diving deeper.)

(3) Is there a configuration when I click the bookmark in current tab,it will open in new tab not replace the current tab?

Could you try this change and see whether you like it:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box in the page, type or paste intab and pause while the list is filtered

(C) Double-click the browser.tabs.loadBookmarksInTabs preference to switch the value from true to false

Does that help?

Прочитайте этот ответ в контексте 👍 2

Все ответы (6)

more options

Выбранное решение

Hi hellowd, I think that's actually 3 questions.

(1) When opening a new tab, can you set Firefox not to put the cursor into the address bar?

Right now, there is no setting for that.

(2) Can we set the Firefox address bar not to overshadow the bookmarks toolbar?

Right now, there is a setting to roll back to the Firefox 74-style address bar. This is a temporary setting while they work out the final bugs with this new design, so it probably will stop working later this year. But you might enjoy using it for now. Here's how:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box in the page, type or paste URLB and pause while the list is filtered

(C) Double-click the browser.urlbar.update1 preference to switch the value from true to false

(The other way is to manipulate the styling of the new design. More details on that if you're interested in diving deeper.)

(3) Is there a configuration when I click the bookmark in current tab,it will open in new tab not replace the current tab?

Could you try this change and see whether you like it:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box in the page, type or paste intab and pause while the list is filtered

(C) Double-click the browser.tabs.loadBookmarksInTabs preference to switch the value from true to false

Does that help?

more options

Wow, perfect! I will use the third solution which will reduce my operation count and enhance a little effectiveness. Thank you very much!

more options

I would definitely prefer the cursor to be in the search bar (not the address bar) when opening new tabs, as it was before updating to Version 80.0

I strongly suggest that developers offer “cursor in the search bar” as an optional setting for users who share this preference. After all, user preference should count for something!

more options

Hi roderickla, I use the built-in new tab page, so I haven't noticed any change in Firefox 80: address bar before, address bar now. What page are you using and how are you setting that up? If you use the New Tab Override extension, I believe it has a setting for where to put the cursor.*

* More detail in this later reply: answer-1347990

Изменено jscher2000

more options

Regarding the default cursor position in the address bar instead of search box for new tabs, this is annoying and I fail to see why this change was made. If we wanted the browser to function in this fashion, we'd be using Edge or Chrome. Stop changing the stuff that works well and is intuitively obvious for the core users.

more options

Hi tom.ellsworth, I'm going to guess what happened to you:

  • You use an add-on to replace the built-in new tab page with a different one
  • You updated to Firefox 80

Before Firefox 61, add-on authors could control whether the cursor went into the address bar or into the page. In Firefox 61-79, the cursor went into the page automatically and add-on authors could not offer the option. Firefox 80 restored the Firefox 60 behavior: cursor is in the address bar by default, and add-on authors can offer an option to move it into the page instead.

If you are using New Tab Override, that option became available in the August 3rd update, so you probably have it already. You can use its toolbar button (first screenshot) or press Shift+F12 to call up the options page. Then check the box in the Focus section (second screenshot). If that box is not there, you need to update the extension.

If you are using a different new tab add-on, check its listing for more information, or contact its author, or switch to New Tab Override.

https://addons.mozilla.org/firefox/addon/new-tab-override/

Does that fix it?

(Probably the focus box should be checked by default since that's what users have become used to in the past two years but... it's not my extension.)