Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Remove default visit link from awesome bar.

  • 2 ответа
  • 1 имеет эту проблему
  • 30 просмотров
  • Последний ответ от Naby

more options

Hi all,

This is the same as this archived thread: https://support.mozilla.org/en-US/questions/1099829. In short: The Visit url that appears in the awesome bar when typing a webpage is highly annoying and I want it gone, as it insist of giving me a URL that I've only visited by accident, and is actually wrong...

This archived thread lists this as asnwer: 1 Go to about:config in Firefox 2 Click the I'll be careful button 3 Locate the browser.urlbar.unifiedcomplete boolean 4 Change the value to false But, the browser.urlbar.unifiedcomplete boolean mentioned in that thread's answer doesn't show in my Firefox (66.0.1). What do I need to amend instead? I can't get rid of this Visit link any other way, I've tried all the suggestions for removing history, and nothing works...

Thank you in advance.

Выбранное решение

In current Firefox releases you need to use code in userChrome.css remove the visit line.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="visiturl"]{display:none !important}
Прочитайте этот ответ в контексте 👍 1

Все ответы (2)

more options

Выбранное решение

In current Firefox releases you need to use code in userChrome.css remove the visit line.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="visiturl"]{display:none !important}
more options

Thank you, that did the trick. I hadn't seen that question and answer in my search.