Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Intermittant 'insecure'. My secure site displays as insecure only on Firefox, sometimes.

  • 7 ответов
  • 5 имеют эту проблему
  • 176 просмотров
  • Последний ответ от DanHughes

more options

My site has a valid ssl certificate. I have a screen shot where Firefox displays the secure web address in the browser with the information on the Firefox error 'insecure' page listing the same address as one of the sites secured by the certificate. Chrome is displaying correctly and often Firefox displays it correctly also. But not this time.

Выбранное решение

Thanks for your insight. I will begin from there and work through it initially with godaddy and look at our settings. You've given my plenty to go on with. Thanks.

Прочитайте этот ответ в контексте 👍 0

Все ответы (7)

more options

Hmm, it's odd that your Firefox gives inconsistent results. If you reload bypassing cache (Ctrl+Shift+r) does that make any difference?

If you use any intermediary software such as parental controls, those may block access based on time of day. If you notice a pattern related to time of day, it would be worth checking that.

Otherwise, do you want to share a URL for the site?

more options

I've narrowed it down to a problem when we send a link to a customer by email as follows www.designs4aquariums.com/returning-visitor it comes up as 'insecure' but when I manually edit the address to remove the 'www' is comes up as secure.

The screen shot shows both the browser address and on the error page, the same address as one covered by the ssl.

more options

Yes, I see. Unfortunately, your GoDaddy cert only has the www subdomain for the main site, and not for the other sites covered by the certificate. I don't know whether they will fix that for free, but that clearly would be best.

If the messages you sent out did not have the HTTPS protocol coded into them -- the user's browser will try HTTP first -- you could look into whether you can change your Apache or PHP settings so that either (1) a redirect from www => base domain is handled first before the redirect from http => https, or (2) they are combined into a single step. Apache configuration is a bit of a headache, so I'll leave those parts to you and GoDaddy.

(If the messages did have the HTTPS protocol coded into them, you'll need a new certificate.)

more options

Выбранное решение

Thanks for your insight. I will begin from there and work through it initially with godaddy and look at our settings. You've given my plenty to go on with. Thanks.

more options

Alt names:

DNS Name: diaryofuniverse.com
DNS Name: www.diaryofuniverse.com
DNS Name: blokes.uno
DNS Name: danzblog.com
DNS Name: designs4aquariums.com
DNS Name: earthpast.com

So it will currently only work without the www. prefix.

more options

This suggests that I should be able to add variations into the sub-domains within the GoDaddy CPanel. I understand only 5 sites are covered by the ssl but maybe I can add the www versions to each and solve the issue that way.

more options

I have now added some code to the htaccess file for each site RewriteEngine On RewriteCond %{SERVER_PORT} 80 RewriteRule ^(.*)$ https://example.com/$1 [R,L] which forces http:// and http://www and just plain www all to use the https:// certificate I bought from GoDaddy. Problem solved.