Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Sparkles emoji renders as unicode--but all other emojis are fine. Help.

  • 8 ответов
  • 2 имеют эту проблему
  • 1476 просмотров
  • Последний ответ от epowers

more options

I feel like I'm going crazy. The sparkle emoji always renders as unicode but every other emoji is fine... see attached pictures.

This doesn't happen in Chrome--only FF--so I think it's a Firefox issue. But WHAT?? I tried clearing my cache. I can't think of anything else? I can't find anyone else with this same issue online. I really really don't want to use Chrome but this is driving me nuts.

Приложенные скриншоты

Изменено epowers

Выбранное решение

Hallelujah!!!! I fixed it.

All I had to do was change my default font (under options>content) from Arial to Segoe UI Emoji.

Thanks to this Reddit thread for giving me the idea. (The thread is about Microsoft Edge not FF but it still helped haha)

Прочитайте этот ответ в контексте 👍 0

Все ответы (8)

more options

You wrote "Sparkles emoji renders as unicode", but I'm not seeing this issue in the screenshots you posted, so I'm not sure what you see instead of the emojis.

Do you see little boxes with a hex code?

Can you attach a screenshot?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB
more options

The original screenshots do show the problem.

There are no boxes; the problem isn't that the character doesn't show up at all, it's that it shows up in black and white. It's the simpler unicode character, rather than the colorful emoji. It appears to be that the actual EmojiOne font is selectively not showing up.

Here's a screenshot which compares Chrome and Firefox's rendering of this character so that you can see the difference (Chrome is on the left, FF on the right). Chrome's rendering is how it should appear.

Изменено epowers

more options

The characters are send as Unicode character as you can see in the Page Source, so it depends on the icon you have what you see in the browser unless the website overrides this with CSS code (sprite image and background-position). I don't know how Google Chrome displays the image, but a website can modify the appearance of such images and Google may have code or use a special font. You would have to check that in the Inspector.

more options

...looking in inspector makes things even weirder. For some reason the sparkle emoji is sent as the unicode character, when other emojis are not?

by the way, this doesn't just happen when searching on Google--it happens on other websites too. The sparkles emoji consistently shows up as unicode when others do not.

more options

OK. I've figured something else out. I (somehow???) found a copy & pastable version of the sparkles emoji that (as you can see in the browser) is actually the unicode plus some kind of suffix that forces the browser to render it as an emoji rather than unicode.

But other emojis are actually a typable character which is a separate character from the unicode version.

So the sparkles emoji is treated differently than other emojis for... some reason? Is this actually a problem with the emoji font itself on my computer?? (I'm using Windows 10.)

I assume Chrome renders all unicode characters and the color emoji characters as the emojis automatically, whereas Firefox distinguishes between the unicode character and the emoji character.

Изменено epowers

more options

Firefox appears to be using the emojione font.

Quote: Added a built-in Emoji set for operating systems without native Emoji fonts (Windows 8.0 and lower and Linux)


Изменено cor-el

more options

I already have Firefox 51.0.1 and the EmojiOne font is installed on my computer (and located in C:\Program Files (x86)\Mozilla Firefox\fonts). So that's not it. :/

Plus, Windows 10 theoretically has native emoji support. I guess there are some bugs?

Изменено epowers

more options

Выбранное решение

Hallelujah!!!! I fixed it.

All I had to do was change my default font (under options>content) from Arial to Segoe UI Emoji.

Thanks to this Reddit thread for giving me the idea. (The thread is about Microsoft Edge not FF but it still helped haha)