Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How do I prevent the loss of all my tabs in all my groups when closing Mozilla?

  • 3 ответа
  • 1 имеет эту проблему
  • 7 просмотров
  • Последний ответ от cor-el

more options

I use grouped tabs. I only have one window (i.e., one group) opened at a time. Yesterday (and again today), on closing Mozilla (v. 42.0) I received a warning that X tabs were being closed. X was large enough that it had to be all tabs in all groups. Since only one window/group was opened, I closed Mozilla. When I started it today, the window that opened had all my pinned tabs, but no other tabs and when I clicked the "group your tabs" icon, all other groups had disappeared. I spent hours today finding an old version that would bring back the basic information, but it was old--didn't have my newest pinned tabs and many, many of my more recent tabs in my various groups. I had to go through all the history for this month to try to find the missing tabs. I'm going to have to go through prior months of history as well (but ran out of time today). When I tried to close Mozilla tonight, I got that message that it was going to close X tabs again. I can't lose all this information--it's critical for my work. I've elected not to turn off Mozilla (and, therefore, not my computer) hoping someone can tell me what to do so I don't lose all this information again. Obviously I can't just leave it running 24/7. (It's a laptop and I have to travel with it.) Please help.

Выбранное решение

See Preferences -> General -> When Firefox starts. Select "Show my windows and tabs from last time" and you should be fine.

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options

Выбранное решение

See Preferences -> General -> When Firefox starts. Select "Show my windows and tabs from last time" and you should be fine.

more options

Thanks. That did it. Don't know why the problem suddenly occurred since I certainly hadn't been in changing preferences ... electronic mysteries. Thanks again.

more options

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button > Exit (Power button)
  • Windows: File > Exit
  • Mac: Firefox > Quit Firefox
  • Linux: File > Quit

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Browsing History
  • Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.
  • Clearing Cookies will remove all selected cookies including cookies with an allow exception that you want to keep.