Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How to turn of gear icon so new tab shows a completely blank page with no gear icon?

  • 14 ответов
  • 12 имеют эту проблему
  • 1750 просмотров
  • Последний ответ от vectorraptor

more options

I want a new tab to be a complete blank page. How do I remove the annoy gear icon so the new tab is truly blank?

Выбранное решение

your image shows about:newtab and not "about:blank" like jscher2000 has suggested to you. the preference in about:config you were referencing is no longer supported in firefox 41, that's probably where the confusion stems from. so please scroll up, go through what was already recommended as this will fix your issue.

Прочитайте этот ответ в контексте 👍 2

Все ответы (14)

more options

You will need to use an add-ons such as the following, and specify the internal address about:blank as the page you want to use:

https://addons.mozilla.org/firefox/addon/new-tab-override/

more options

jscher2000 said

You will need to use an add-ons such as the following, and specify the internal address about:blank as the page you want to use: https://addons.mozilla.org/firefox/addon/new-tab-override/

That does not work, and of course I had already done the same using about:config. It does not remove the gear icon. I want a blank page with no gear/cogwheel icon -- just blank--100% white--no "settings" icon. No blot in the upper right corner.

Изменено LarsEighner

more options

Hi LarsEighner, just to make sure, did you go to the Add-ons page, Extensions section, click the Options button for New Tab Override and enter about:blank into its form? I haven't loaded Firefox 41 yet, but I'll try to test it myself later tonight if that isn't working for you.

more options

Okay, it seems to work in my test. I have attached screen shots of where you need to enter about:blank.

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, find New Tab Override and click its Options button. Depending on the height of your screen, you may need to scroll down to enter about:blank into the form. Then tab or click away from that form field and you can test using Ctrl+t.

Success?

more options

Are you an auto-responder?

It does not remove the "Settings" gear-shaped icon. The about:blank page is not blank. IT IS NOT BLANK. IT HAS A GEAR (COGWHEEL/SETTINGS) ICON ON IT. I WANT A REALLY BLANK PAGE!!!!!!!!!! I don't want that and I do not want the litte tic-tac-toe icon either. I want the whole blank tab to be completely blank, like white all over, like a snow-covered field, with no icons on it.

Do any of you read English?

And what is this about asking for contributions for plugins that do nothing that cannot be done by editing about:config directly? Is all this stuff for hand-held monkeys?

I want a completely blank page when I open a new tab. I do not want any kind of setting icon on the page. How hard is that to understand?

Изменено LarsEighner

more options

Выбранное решение

your image shows about:newtab and not "about:blank" like jscher2000 has suggested to you. the preference in about:config you were referencing is no longer supported in firefox 41, that's probably where the confusion stems from. so please scroll up, go through what was already recommended as this will fix your issue.

more options

Same issue here and while the addon does fix it I wonder if this will be the standard for future updates. Namely messing up basic features (like about:config not having an effect for certain things) which then can only be accessed or used through addons and hacks... Not a bright future. For now I hope they will fix this in the next update or close to that. We can wait for next update so take your time and make sure that update does not kill off anything already working. 'cause that's weird.

more options

Hi Kokuyouseki, I think this is unlikely to be changed back to a preference in a future version of Firefox. To give feedback on changes for future versions, you can use this page:

https://input.mozilla.org/feedback

more options

The browser.newtab.url pref is no longer supported, so setting this pref doesn't have effect.

If the New Tab Override extension isn't working then you may have another extension that also tries to set the new tab page.

Look at this extension to use the home page:

Classic Theme Restorer includes this feature as well. In CTR version 1.3.9 you can find the "New tab page url" in the Tabs (1) window.


You can use this command in the Browser Console to check the current new tab setting:

  • NewTabURL.get();

You can use this command to set the new tab URL:

  • NewTabURL.override("about:blank");

Toggle devtools.chrome.enabled to true on the about:config page to enable the command line in the Browser Console.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

jscher2000 said

You will need to use an add-ons such as the following, and specify the internal address about:blank as the page you want to use: https://addons.mozilla.org/firefox/addon/new-tab-override/

Unfortunately, this addon no longer seems to work. I downloaded it, went into its options, and set the new tab url to about:blank. My new tabs still have the little gear icon. Perhaps Firefox disabled even this ability some time in the last few months.

Изменено vectorraptor

more options

cor-el said

You can use this command in the Browser Console to check the current new tab setting:
  • NewTabURL.get();
You can use this command to set the new tab URL:
  • NewTabURL.override("about:blank");
Toggle devtools.chrome.enabled to true on the about:config page to enable the command line in the Browser Console. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

This is the solution that works. Weirdly, when I entered the above command, I received a response of "undefined", but now my new tab page is beautifully blank!

more options

Hi vectorraptor, the extensions that modify the new tab page use the exact same script command that you typed manually, so the interface is still built in to Firefox. Which makes it more puzzling that New Tab Override didn't work for you.

more options

Do you have other extensions that can set the new tab page?

Can you list the extensions?


You can look at this extension to set the new tab page:

You can set the new tab URL via the Options/Preferences of the extension on the about:addons page.

You can look at this extension if you use the home page as the new tab page.

Classic Theme Restorer includes this feature as well. In current CTR versions (1.3.9+) you find "New tab page url" in the Tabs (1) section.

more options

jscher2000 said

Hi vectorraptor, the extensions that modify the new tab page use the exact same script command that you typed manually, so the interface is still built in to Firefox. Which makes it more puzzling that New Tab Override didn't work for you.

Very puzzling indeed. Could be I was doing something wrong with the extension? But I'm not sure how.