Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Integrated Webcam not working

  • 6 odpowiedzi
  • 0 osób ma ten problem
  • 25 wyświetleń
  • Ostatnia odpowiedź od zeroknight

more options

The integrated webcam (IMC Networks Integrated Camera, according to lsusb) on my linux laptop does not work in firefox (v124). It works in desktop apps (eg webcamoid), and chromium. I've checked the permissions (about:preferences#privacy), and that is not the problem. about:support does not list the device in the input at all. I've tried using LD_PRELOAD=/usr/lib64/libv4l/libv4l1compat.so, but that has not helped. Does anyone have any suggestions?

The integrated webcam (IMC Networks Integrated Camera, according to lsusb) on my linux laptop does not work in firefox (v124). It works in desktop apps (eg webcamoid), and chromium. I've checked the permissions (about:preferences#privacy), and that is not the problem. about:support does not list the device in the input at all. I've tried using LD_PRELOAD=/usr/lib64/libv4l/libv4l1compat.so, but that has not helped. Does anyone have any suggestions?

Wszystkie odpowiedzi (6)

more options

Works for me. Do you get the popup asking for permission? see screenshot https://webcamtests.com/ What OS? What Desktop? X11 or Wayland?

Did you try Firefox in Troubleshoot Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search104

Try downloading Firefox from Mozilla, run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release


Operating System: openSUSE Tumbleweed 20240407 KDE Plasma Version: 6.0.3 KDE Frameworks Version: 6.0.0 Qt Version: 6.6.3 Kernel Version: 6.8.4-rc1-1-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Manufacturer: HP Product Name: HP ProBook 455 15.6 inch G9 Notebook PC

Pomocne?

more options

As I said, it's not a permissions problem. There is no popup, firefox is apparently not aware the camera exists, but it works in chromium and webcamoid. I've attached screenshots of webcamtests.com using firefox and chromium respectively.

# lsusb -s 3:3

Bus 003 Device 003: ID 13d3:56ba IMC Networks Integrated Camera

OS: Gentoo KDE Plasma Version: 5.27 KDE Frameworks Version: 5.115 Qt Version: 6.6.3 Kernel Version: 6.7.9-gentoo-x86_64 Graphics Platform: X11 Processors: Intel(R) Core(TM) i7-1065G7 CPU @ 1.30GHz Memory: 15.2GB Graphics Processor: NVidia Manufacturer: Lenovo Product Name: Lenovo Yoga S740-14IIL

Pomocne?

more options

I see an add-on in Firefox, but not in chromium. Did you try Firefox in Troubleshoot Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search104

Did you try downloading Firefox from Mozilla, run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Also try a live usb stick if needed.

I'm on a different laptop, I do get a pop-up asking permission, and it also works on Nightly browser with no issue. see screenshot

Also see if there is anything in the settings under permissions.

Operating System: openSUSE Tumbleweed 20240409 KDE Plasma Version: 6.0.3 KDE Frameworks Version: 6.0.0 Qt Version: 6.7.0 Kernel Version: 6.8.4-rc1-1-default (64-bit) Graphics Platform: X11 Processors: 16 × Intel® Xeon® W-10885M CPU @ 2.40GHz Memory: 125.1 GiB of RAM Graphics Processor: Mesa Intel® UHD Graphics P630 Manufacturer: HP Product Name: HP ZBook Fury 17 G7 Mobile Workstation

Zmodyfikowany przez jonzn4SUSE w dniu

Pomocne?

more options

Try disabling Tracking Protection for the site.

Check that privacy.resistFingerprinting is false in about:config.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Pomocne?

more options

I installed firefox-bin, and it works - but I lose my profile :-(

Starting firefox in safemode does not fix the problem.

Turning off tracking protection, ublock origin and hardware acceleration did not fix the problem.

So now it seems I need to work out what is different between the build of the binary and my local build....

Pomocne?

more options

You can point to an existing profile, do you see it listed in the profile manager?

You could also try the flatpak package.

Pomocne?

Zadaj pytanie

Aby odpowiadać na posty, musisz zalogować się na swoje konto. Zadaj pytanie, jeśli nie masz jeszcze konta.