Hvorfor fungerer ikke Java, Silverlight, Adobe Acrobat og andre programtillegg lengre?

Fra og med Firefox versjon 52, sluppet 7. Mars 2017, er installerte NPAPI programtillegg ikke lengre støttet i Firefox, utenom Adobe Flash. Noen av programtilleggene som ikke lenger lastes inn i Firefox, selv om de kan være installert på datamaskinen din, inkluderer Java, Microsoft Silverlight og Adobe Acrobat. Se dette komabilitetsdokumentet for detaljer.

I løpet av de siste årene har Firefox implementert ulike web-APIer, slik at nettsteder kan gjøre de samme tingene de alltid har gjort uten programtillegg, så du vil mest sannsynlig ikke legge merke til noen endring i nettleseropplevelsen din.

Hvorfor gjorde Firefox dette?

Internett er full av nettsteder som er mer enn bare statiske sider, som for eksempel å vise video, ha lyd og spill. NPAPI-promgramtillegg, spesielt Flash, har bidratt til å aktivere disse interaktive sidene. Men de gjør også din surfing langsommere, mindre sikker og mer sannsynlig til å krasje.

I løpet av de siste årene, har Firefox arbeidet hardt for å lage erstatninger til disse programtilleggene. Sammen kalles de Web APIs. De er utformet for å erstatte funksjonen til disse promgramtilleggene uten å undergrave din internett sikkerhet, stabilitet og ytelse.

Tidligere var disse web-APIene ikke helt klare, så Firefox startet overgangen ved å gjøre at programtillegg lastet manuelt (trykk for å aktivere).

I dag er de klare. Mange nettsteder har tatt dem i bruk, og nesten alle favorittsidene dine kan nytes uten å bruke gamle og usikre promgramtillegg. Firefox slutter seg til andre moderne nettlesere som Google Chrome og Microsoft Edge, for å fjerne støtte for disse NPAPI-programtilleggene.


Jeg har problemer

Om du ikke er klar for denne overgangen, vil ESR (Extended Support Release) av Firefox 52 fortsette å støtte disse programtilleggene frem til tidlig i 2018. Trykk her for å laste ned Firefox ESR.

Viktig: Windows 64-bit versjonen av Firefox 52 ESR støtter bare Adobe Flash og Microsoft Silverlight programtillegg. Hvis du også trenger støtte for Java eller andre installerte promgramtillegg, velg Windows (32-bit) nedlasting.

Som standard vil Firefox 52 ESR bruke de samme profil dataene som andre versjoner av Firefox. Å installere Firefox 52 ESR etter bruk av Firefox versjon 55 eller nyere kan forårsake problemer som tap av nettleser-historikk, feilmeldinger, brudd i deler av Firefox og problemer med enkelte nettsteder. Du burde enten lage en ny profil for å bruke sammen med Firefox 52 ESR eller tilbakestill Firefox etter installasjon av Firefox 52 ESR.
// These fine people helped write this article:user1174865. You can help too - find out how.

Var artikkelen nyttig? Vent ...

Volunteer for Mozilla Support